网元软件管理

网元软件管理（常称作DC），是一个图形化的工具，用于对网元上软件和数据进行管理。通过网元软件管理，可以对网元数据进行备份、对网元软件进行升级/降级。此外，也可以对网元日志以及License进行管理。对于网元软件的升级/降级方案，请严格按照主机产品发布的升级指导书或补丁说明书进行操作。

  • 关于帮助系统
    了解帮助系统的基本知识和使用方法，方便您迅速获取所需信息。
  • 快速入门
    网元软件管理，常称作DC（Data Center），是一个图形化的工具，用于管理网元软件和数据。主要作用包括网元数据备份和故障时的网元数据恢复、网元软件升级/降级、网元日志管理、License管理。本节介绍网元软件管理对网元升级的配置流程和网元软件管理的基本概念。
  • 准备工作
    介绍在使用网元软件管理对网元进行日常维护或升级前，需要进行哪些准备工作。
  • 软件管理
    通过软件库功能上传网元软件到网元软件管理所在计算机，可实现网元软件的集中管理，使选择加载软件的过程更加方便快捷。
  • 升级/降级任务管理
    网元软件管理将升级/降级网元软件所需进行的主要操作封装成任务，通过创建对应的升级/降级任务，并一键式开始任务，实现自动对网元软件进行升级/降级操作。
  • 升级前后文件对比
    升级完成后，可以将升级后的配置信息和路由信息与升级前比较，了解升级过程对网元造成了哪些影响。
  • 板级软件管理
    介绍如何针对网元上的部分单板进行软件加载和补丁加载。以及如何在更换新业务单板时，自动将其升级到与网元相同的版本。
  • 数据备份与恢复
    因网元维护或升级/降级需要，将最新的网元数据备份到网元软件管理所在计算机上，当对网元进行升级/降级后，或者当网元发生故障造成运行的数据丢失时，可以从备份文件中恢复网元数据。本节介绍如何立即保存、备份网元数据，以及如何从备份文件中恢复网元数据。
  • 网元补丁管理
    管理网元补丁功能包括：查看补丁信息、激活、去激活、确认、回滚、过滤和删除补丁。
  • 网元日志管理
    通过本章内容，您将了解如何查看、删除网元软件管理对网元的操作日志，以及如何备份网元的安全日志和操作日志。
  • 管理网元License
    申请安装网元License后，您可以获得相应的网元功能使用权。网元License管理包括了对网元License的查询、申请、安装、调整容量和变更。由于License控制了网元的使用期限或功能，通过查看网元License的状态并及时更换将过期的License，可以避免License过期对业务产生的影响。
  • 终端工具
    介绍如何使用终端工具登录网元，可以使用命令行对网元进行操作。
  • TL1命令行
    介绍如何使用网元软件管理的TL1命令行终端对SONET网元进行管理。
  • 网元管理
    在网元软件管理中，网元是最基本的操作对象。对网元进行操作前，首先要添加网元至网元列表。通过以下几节的讲述，您将了解通过网元软件管理可以对网元进行哪些基本操作，以及如何管理网元信息。
  • 附录
    本部分介绍与网元软件管理相关的参考内容。
华为专有和保密信息
版权所有 © 华为技术有限公司


关于帮助系统

了解帮助系统的基本知识和使用方法，方便您迅速获取所需信息。

  • 读者对象
    本帮助的读者对象是：网管管理员和系统维护工程师。
父主题： 网元软件管理


读者对象

本帮助的读者对象是：网管管理员和系统维护工程师。

父主题： 关于帮助系统


快速入门

网元软件管理，常称作DC（Data Center），是一个图形化的工具，用于管理网元软件和数据。主要作用包括网元数据备份和故障时的网元数据恢复、网元软件升级/降级、网元日志管理、License管理。本节介绍网元软件管理对网元升级的配置流程和网元软件管理的基本概念。

  • 升级流程
    通过网元软件管理对网元软件进行升级或降级。升级流程和降级流程相同。本节以升级流程为例。
  • 基本概念
    介绍备份、恢复、加载、任务等基本概念。
  • 设置显示效果
    可以根据需要灵活设置网元软件管理界面的显示效果。
父主题： 网元软件管理


升级流程

通过网元软件管理对网元软件进行升级或降级。升级流程和降级流程相同。本节以升级流程为例。

说明：

网元软件的升级/降级是危险操作，可能导致网元业务中断。对于网元软件的升级/降级，请严格按照对应网元产品发布的升级指导书或补丁说明书进行操作。建议联系华为技术服务工程师对网元软件进行升级/降级操作。

升级操作流程如图1所示。
图1 操作流程

父主题： 快速入门


基本概念

介绍备份、恢复、加载、任务等基本概念。

保存

配置网元后，数据默认保存在网元的内存中。通过保存操作将配置数据保存在网元的Flash中，防止重启时丢失配置文件。实现保存的方式如下：
  • 通过执行保存操作立即保存
  • 通过创建任务自动保存
  • 通过保存策略定时保存

传送域/PTN网元不支持保存操作。

备份

备份操作是将配置数据保存在网元以外的存储空间内（如客户端），用于网元的配置恢复。

当网元上没有其他操作（如加载、备份或恢复）正在进行，网元接受备份请求，将要备份的内容通过文件传输协议传输到网元软件管理的文件传输目录下。

备份过程中，网元软件管理会收集网元进度信息，实时显示备份的进度和结果。实现备份的方式如下：
  • 通过执行备份操作立即备份
  • 通过创建任务自动备份
  • 通过备份策略定时备份

加载

加载操作是将目标版本软件或补丁通过文件传输协议传输到网元上的过程。

当网元上没有其他操作（如加载、备份或恢复）正在进行，网元接受加载请求。网元软件管理将要加载的软件或补丁通过文件传输协议传输到网元上。

加载过程中，网元软件管理会收集网元进度信息，实时显示加载的进度和结果。实现加载的主要方式如下：
  • 通过创建任务自动加载
  • 通过板级软件或补丁管理方式自动加载

恢复

恢复操作可以将备份的数据恢复到网元上，用于网元的配置恢复。

当网元上没有其他操作（如加载、备份或恢复）正在进行，网元接受恢复请求。网元软件管理将要恢复的内容通过文件传输协议传输到网元上。

恢复过程中，网元软件管理会收集网元进度信息，实时显示恢复的进度和结果。实现恢复的方式如下：
  • 通过执行恢复操作立即恢复
  • 通过创建任务自动恢复（传送域/PTN网元）

任务

任务，即通过预先设置，实现一键式升级网元软件和更新网元补丁。

通过配置升级任务，可以预先批量选择待升级网元，配置升级所需要的步骤，在运行任务后，达到一键式升级的效果，最大程度减少手工操作，并提高升级性能。

任务应用于网元软件升级和补丁更新。包括以下几种类型：
  • 软件升级/降级任务
    使用场景：
    • 当网元在运行过程中出现了软件错误，或者增加新的业务功能而扩充软件代码时，需要对网元软件进行升级。
    • 当升级后的软件存在错误，或者网元的软件版本过高，不满足现网要求时，需要对网元软件进行降级。
    • 软件升级/降级任务用于为接入域网元、路由器/交换机进行软件升级/降级。
  • 补丁更新任务

    使用场景：网元运行后，当需要对网元程序进行一些适应性和排错性修改（包括改正系统中存在的缺陷、增加新功能以适应业务需求等情况）时，通常会对软件打补丁。软件补丁可以在不影响网元正常运行的情况下实现软件升级。

  • 模拟包升级任务

    描述：模拟包是指将网元上所有需要加载的软件集中在一起，用一个包描述文件定义各软件的加载属性。加载时，网元软件管理会按照描述文件中定义好的加载属性将软件加载到对应单板上。

    使用场景：
    • 当网元在运行过程中出现了软件错误，或者增加新的业务功能而扩充软件代码时，需要对网元软件进行升级。
    • 模拟包升级任务用于为传送域/PTN网元进行软件升级。
    • 由于加载到各单板前，所有软件是保存在网元软件管理所在计算机上，加载完成后，网元上也不会保留模拟软件包，因此模拟包升级任务适用于为内存小、没有CF卡的网元进行软件升级。
  • 包升级/降级任务

    描述：软件包是指将网元上所有需要加载的软件集中在一起，按照某一定义封装而形成的一个文件包。加载时，网元软件管理先将软件包加载到网元的主控板上，再由主控板按照封装时的定义将软件包中的各个软件分发到对应的单板上。

    使用场景：
    • 当网元在运行过程中出现了软件错误，或者增加新的业务功能而扩充软件代码时，需要对网元软件进行升级。
    • 当升级后的软件存在错误，或者网元的软件版本过高，不满足现网要求时，需要对网元软件进行降级。
    • 由于加载到各单板前，软件包已加载到网元主控板上，加载完成后，软件包会继续保留在主控板上，因此软件包升级/降级任务适用于为存在CF卡且内存较大并支持软件包升级的网元进行软件升级。
    • 包升级/降级任务用于为传送域/PTN网元进行软件升级/降级。
  • 包扩散升级/降级任务
    描述：
    • 网元软件管理根据网元上的路由关系计算出软件包的扩散路径并将扩散关系设置到网元上，再一次性将软件包中的所有软件加载到扩散路径的首节点网元上。首节点网元根据网元软件管理设置好的扩散关系将软件包根据扩散路径扩散到它的下游节点网元的升级/降级过程。
    • 包扩散按激活方式分为：

      类型

      特点

      适用范围

      网元级激活
      • 激活时，缺省按照路由顺序由远及近依次激活。（依次激活距离网关网元较远的非网关网元，最后激活网关网元）
      • 扩散关系中不是所有网元都需要进行软件包升级/降级。

      网络上多个相同类型且存在CF卡的网元。

      单板级激活
      • 不需要升级/降级的网元会将软件包透传到需要加载的网元上。
      • 扩散关系中不是所有网元都需要进行软件包升级/降级。

      网络上有多个不存在CF卡的网元需要进行软件包加载，且网元支持单板级激活。
    使用场景：
    • 当网元在运行过程中出现了软件错误，或者增加新的业务功能而扩充软件代码时，需要对网元软件进行升级。
    • 当升级后的软件存在错误，或者网元的软件版本过高，不满足现网要求时，需要对网元软件进行降级。
    • 包升级/降级任务用于为传送域/PTN网元进行软件升级/降级。
父主题： 快速入门


设置显示效果

可以根据需要灵活设置网元软件管理界面的显示效果。

  • 设置皮肤
    可以根据需要设置客户端的皮肤颜色。
  • 设置网元软件管理独立部署软件时间显示方式
    根据需要设置网元软件管理独立部署软件时间显示格式、时间模式和日期显示格式。
父主题： 快速入门


设置皮肤

可以根据需要设置客户端的皮肤颜色。

背景信息

  • 网元软件管理客户端皮肤颜色有两种风格：灰色与暗绿色风格。
  • 设置完客户端皮肤颜色后，需要重新启动网元软件管理客户端，才能使设置生效。

操作步骤

  1. 在主菜单中选择“系统 > 惯用选项”。
  2. 在“惯用选项”窗口左侧导航树中选择“皮肤”。
  3. 在“皮肤设置”中选择待设置的客户端皮肤颜色。
  4. 单击“确定”。
父主题： 设置显示效果


设置网元软件管理独立部署软件时间显示方式

根据需要设置网元软件管理独立部署软件时间显示格式、时间模式和日期显示格式。

  • 设置独立部署软件时间格式
    可以根据需要设置独立部署软件时间的格式。
  • 设置独立部署软件日期格式
    可以设置在独立部署软件上采用不同的日期显示格式。
父主题： 设置显示效果


设置独立部署软件时间格式

可以根据需要设置独立部署软件时间的格式。

背景信息

  • 设置完时间格式后，需要重新启动网元软件管理独立部署软件，才能使设置生效。

  • 当用户下次登录时，网元软件管理独立部署软件会自动采用用户上次的设置。

  • 设置后的时间显示效果会在“外观示例”区域框中显示。

操作步骤

  1. 在主菜单中选择“系统 > 惯用选项”。
  2. 在“惯用选项”窗口左侧导航树中展开“区域设置”，并选择“时间”。

  3. 在“时间”区域框中，设置时间格式。
  4. 单击“确定”。
父主题： 设置网元软件管理独立部署软件时间显示方式


设置独立部署软件日期格式

可以设置在独立部署软件上采用不同的日期显示格式。

背景信息

  • 设置完日期格式后，需要重新启动网元软件管理独立部署软件，才能使设置生效。

  • 当用户下次登录时，网元软件管理独立部署软件会自动采用用户上次的设置。

  • 设置后的日期显示效果会在“外观示例”区域框中显示。

操作步骤

  1. 在主菜单中选择“系统 > 惯用选项”。
  2. 在“惯用选项”窗口左侧导航树中展开“区域设置”，并选择“日期”。

  3. 在“日期”区域框中，设置日期格式。

    说明：
    • 日期分隔符：指定日期分隔的符号。有三种可选方式“/”、“-”和“.”。缺省为“/”。
    • 日期格式：指定日期显示的格式，可设置为“yyyy/MM/dd”、“dd/MM/yyyy”、“MM/dd/yyyy”三种格式。缺省为“MM/dd/yyyy”。

  4. 单击“确定”。
父主题： 设置网元软件管理独立部署软件时间显示方式


准备工作

介绍在使用网元软件管理对网元进行日常维护或升级前，需要进行哪些准备工作。

  • 登录
    使用网元软件管理前，需要登录网元软件管理。
  • 导入网元类型描述文件
    当增加一个新的Mxu网元类型时，在导入对应的网元类型描述文件后，就可以在网元软件管理中对新的Mxu网元进行操作，而不需要重新安装高版本的网元软件管理。
  • 创建网元
    在使用网元软件管理对某网元进行管理之前，需要先在网元列表中创建该网元。
  • 配置通信参数
    在使用网元软件管理对网元进行备份、加载、恢复等操作前，先要配置网卡信息、服务器信息、文件传输根目录，和网元传输协议。
  • 申请网元软件升级能力License
    通过认证网元软件管理License获取更高的升级并发度以及更多的网元软件管理功能。通过规范网元软件管理授权使用，使客户更高效的使用网元软件管理。
父主题： 网元软件管理


登录

使用网元软件管理前，需要登录网元软件管理。

操作步骤

  1. 解压缩独立部署安装包后，双击“dc_StandAlone.exe”。
  2. 在登录对话框中，设置“密码”。

    说明：
    “密码”长度必须为6到16位。

  3. 根据所操作的设备，选择域信息。
  4. 单击“确定”。
  5. 可选：为保证安全建议定期修改密码，步骤如下。
    1. 登录后，在网元软件管理界面中，在主菜单选择“系统 > 修改密码”。
    2. 在弹出对话框中，输入“原密码”、“新密码”、“确认新密码”。

      说明：
      密码必须包含至少如下2种字符的组合：数字、小写字母、大写字母、特殊字符。例如：+、@、#、%、* 等。

    3. 单击“确认”。
父主题： 准备工作


导入网元类型描述文件

当增加一个新的Mxu网元类型时，在导入对应的网元类型描述文件后，就可以在网元软件管理中对新的Mxu网元进行操作，而不需要重新安装高版本的网元软件管理。

前提条件

  • 接入域网元（Mxu网元类型）支持该功能。
  • 已经获取网元类型描述文件，并复制到网元软件管理所在机器上。

背景信息

  • 网元类型描述文件随主机软件发布。
  • 一个新的Mxu网元类型对应一个网元类型描述文件，网元类型描述文件后缀为xml。

操作步骤

  1. 在主菜单中，单击“系统 > 导入网元类型描述文件”。
  2. 在弹出的对话框中，单击 [image] 。
  3. 选择待导入文件后，单击“确定”
  4. 单击“确定”。可以在网元软件管理上创建一个新的Mxu类型网元并对其进行操作。
父主题： 准备工作


创建网元

在使用网元软件管理对某网元进行管理之前，需要先在网元列表中创建该网元。

  • 创建网元（传送/PTN）
    介绍如何在网元软件管理中创建传送域/PTN网元。
  • 创建网元（路由器/交换机）
    介绍如何在网元软件管理中创建路由器/交换机（不包含集群交换机）。
  • 创建网元（接入/集群交换机）
    介绍如何在网元软件管理中创建接入域网元和集群交换机。
  • 批量创建网元（导入方式）
    当需要同时创建多个网元时，推荐采用本节介绍的功能。通过导入包含网元特有信息的文件批量创建网元，操作方便快捷。
  • 自动创建网元（搜索方式）
    通过搜索的方式，实现将网络中的网关网元及其对应的非网关网元批量增加至网元视图。
  • 配置网元软件管理侧SNMPv1/v2/V3参数
    对于使用SNMP协议与网元软件管理通信的网元，需要在网元软件管理侧配置与待操作网元对应相同的SNMP参数。
  • 修改网元参数
    通过本节所述操作，可以对已创建的网元参数进行修改。
父主题： 准备工作


创建网元（传送/PTN）

介绍如何在网元软件管理中创建传送域/PTN网元。

前提条件

网元软件管理与网元间通讯正常。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在网元列表中单击右键，选择“网元管理 > 创建网元”。
  3. 在“创建网元”对话框中设置网元参数信息，其中带红色*标记部分为必填项。

    说明：
    • 当“网关类型”设置为“IP网关”，单击“网关地址”后的 [image] ，可以在网络中搜索网关网元。
    • 如果待创建的网元为非网关网元，“网关地址”处需要输入其对应网关网元的IP地址或NASP地址。

    “网关类型”选项

    描述

    设置

    IP网关

    适用于网元软件管理与网关网元间采用IP通信协议的情况。
    • 在“网关地址”中输入网关网元的IP地址。
    • “端口”保持缺省值。

    OSI网关

    适用于网元软件管理与网关网元间采用OSI通信协议的情况。
    • 在“网关地址”中输入网关网元的NSAP地址。
    • “端口”保持缺省值。
    说明：

    NSAP地址是最长为20字节的16进制数，其格式为：域地址+08003e+网元ID+NSEL。其中“域地址”最长13字节，由用户输入。“NSEL”是网络层协议的端口号，固定为1d，占1个字节。

  4. 单击“密码”列中的“配置”链接，可以在弹出对话框中设置网元“密码”。在后续“Stelnet配置”的“密码模式”中可以不用进行设置密码操作。
  5. 单击“高级设置”列中的“高级设置”链接，可以设置SFTP密码和设置Stelnet参数。

    • 在“SFTP配置”区域框中，单击“密钥保护密码”后的 [image] ，在弹出对话框中设置SFTP密钥保护密码。
    • 在“Stelnet配置”区域框中，选择“Stelnet配置”复选框。
      • 默认选中“密码模式”单选按钮。不用进行设置密码操作，密码已经在4中设置。
      • 若选择“密钥模式”单选按钮。
        1. 单击“导入”，在弹出对话框中导入密钥文件。
        2. 单击“密钥保护密码”后的 [image] ，在弹出对话框中设置SFTP密钥保护密码。

  6. 可选：当需要一次性创建多个网元时，单击“插入行”，重复3操作。
  7. 在列表中选择要创建的网元，单击“创建网元”。

    说明：

    一次可同时创建多个网元。

  8. 网元创建完毕后，单击“关闭”，关闭“创建网元”窗口。

操作结果

网元创建成功后，会显示在网元视图中。

父主题： 创建网元
相关任务
批量创建网元（导入方式）


创建网元（路由器/交换机）

介绍如何在网元软件管理中创建路由器/交换机（不包含集群交换机）。

背景信息

支持离线创建路由器/交换机（不包含集群交换机）。
说明：

通常情况下，升级的时间窗为0：00~6：00。为节约升级时间，需要提前做好准备工作。（包括创建网元、创建升级任务等）

离线创建网元解决了因网元未连接到网络而无法创建的问题。

集群交换机采用SNMP协议与网元软件管理通信。创建集群交换机的方法请参见创建网元（接入/集群交换机）。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在网元列表中单击右键，选择“网元管理 > 创建网元”。
  3. 设置网元参数。

    说明：

    必须设置的属性包括：网元IP/LAN/网关IP、代理类型、代理网元类型、接口协议、端口、密码和Super3密码。其他属性值请根据网元的实际信息进行设置，并与网元上的信息对应一致。其中，“VPN实例名”，只有在网元的代理类型为“直连”时才能设置。“密码”和“Super3密码”需要单击“配置”链接，在弹出窗口中设置。

    对于离线创建的网元，网元类型不会被自动识别，需要手工选择，确保其正确性。

    “代理类型”选项

    描述

    操作说明

    直连

    网元软件管理直接连接到目标网元A，进行升级。

    网元A创建完成后，可通过查询网元版本操作，了解网元A与网元软件管理是否能够正常通信。

    自动代理

    如果网元软件管理连接不到升级的目标网元A，而网元软件管理可以连接到另外一台网元B（代理网元类型为“NSM-UNIX”、“Cisco”、“Telent.huawei.com”或“Huawei”）,并且，网元B也能连通目标网元A，则网元软件管理可以通过网元B作为代理，升级目标网元A。
    代理网元B创建完成后，需要继续创建目标网元A。操作步骤如下：
    1. 选择自动代理网元B，单击右键，选择“新建子节点”。
    2. 按3方法，设置A的网元参数。
    说明：

    代理网元B的子节点仍可以为“自动代理”网元（2级代理）。从1级代理B开始，最多能创建6级代理网元，第7级网元必须为直连网元。

    目标网元A为直连网元。

    网元A创建完成后，可通过查询网元版本操作，了解网元A与网元软件管理是否能够正常通信。

父主题： 创建网元


创建网元（接入/集群交换机）

介绍如何在网元软件管理中创建接入域网元和集群交换机。

前提条件

网元软件管理与网元间通讯正常。

如果需要创建一种新的Mxu网元，需要先导入网元类型描述文件，请参考导入网元类型描述文件。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在网元视图中，单击右键，选择“网元管理 > 创建网元”。

    说明：

    创建集群交换机时，需要先单击“集群网元视图”页签，再进行此步操作。

  3. 在“创建网元”对话框中设置网元参数信息，其中带红色*标记部分为必填项。

    说明：

    “SNMP参数”的读、写团体名必须与网元侧配置为一致。单击“SNMP参数”中的 [image] 在弹出窗口中查看缺省值与网元对应参数值是否一致。如果不一致，需要根据网元侧的信息重新配置。配置方法可参见配置网元软件管理侧SNMPv1/v2/V3参数。

  4. 可选：当需要一次性创建多个网元时，单击“插入行”，重复3操作。
  5. 在列表中选择要创建的网元，单击“创建网元”。

    说明：

    一次可同时创建多个网元。

  6. 创建网元完毕后，单击“关闭”，关闭“创建网元”窗口。

操作结果

网元创建成功后，会显示在网元视图中。

父主题： 创建网元
相关任务
批量创建网元（导入方式）
配置网元软件管理侧SNMPv1/v2/V3参数


批量创建网元（导入方式）

当需要同时创建多个网元时，推荐采用本节介绍的功能。通过导入包含网元特有信息的文件批量创建网元，操作方便快捷。

前提条件

  • 网元软件管理与网元间通讯正常。

  • 集群交换机不支持该功能。
说明：

由于路由器/交换机（不包含集群交换机）支持离线创建。因此，创建这些类型的网元时，不需要关注此约束。

背景信息

可以通过两种方式获取导入的文件：
  1. 通过导出网元操作获得。导出网元的方法可参见导出网元。
  2. 编辑模板，导入自定义的文件。获取模板的方法可参见导出网元模板。

不支持通过导入方式批量创建代理网元和通过代理网元与网元软件管理通信的网元。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 请根据待导入的网元类型，选择导入方式。
    • 传送域/PTN网元/接入域网元：
      1. 在网元视图中，单击右键，选择“网元管理 > 创建网元”。
      2. 单击窗口上方的 [image] ，选择待导入文件后，单击“确定”，返回“创建网元”对话框。
      3. 单击“导入”。
      4. 关闭“导入网元”对话框。网元创建成功。
    • 路由器/交换机（不包含集群交换机）：
      1. 在网元视图中，单击右键，选择“网元管理 > 导入网元”。
      2. 在“导入网元”话框中，单击 [image] ，选择待导入文件后，单击“确定”，返回“导入网元”对话框。
      3. 单击“确定”。显示导入进度。
      4. 关闭进度框，网元创建成功。

操作结果

操作成功后，网元视图中将显示导入的网元。

父主题： 创建网元
相关任务
导出网元
导出网元模板


自动创建网元（搜索方式）

通过搜索的方式，实现将网络中的网关网元及其对应的非网关网元批量增加至网元视图。

说明：
仅传送/PTN域设备支持该功能。
  • 搜索网关网元
    介绍如何在网络中搜索网关网元，以及如何将搜索到的网关网元创建至网元软件管理的网元视图中。
  • 搜索非网关网元
    介绍如何在网络中搜索非网关网元，以及如何批量创建非网关网元至网元软件管理的网元视图中。
父主题： 创建网元


搜索网关网元

介绍如何在网络中搜索网关网元，以及如何将搜索到的网关网元创建至网元软件管理的网元视图中。

前提条件

网元软件管理与网元间通讯正常。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中单击右键，选择“网元管理 > 搜索网元”，打开“搜索网元”对话框。
  3. 单击“搜索网关”，网元软件管理将在网络中搜索网关网元。
  4. 搜索完成后，将显示操作结果。

    说明：

    搜索过程中，可以单击“停止”，中止搜索进度。

    1. 可选：若操作成功，单击“详细”，查看搜索结果的详细信息（网关类型、网关地址）。
    2. 单击“关闭”，返回“搜索网元”对话框。
  5. 可选：如果需要对搜索到的网关网元进行删除，选择待删除网元后，单击“删除”。
  6. 如果需要创建网关网元至网元视图中，选择一条网元信息，单击“创建网关”。弹出对话框如下所示。

    说明：
    此步骤不支持创建TL1网关网元。

    1. 请根据需要，对网关网元的信息进行修改。保持“创建该网元”复选框缺省选中状态。

      说明：

      • 去选“创建该网元”复选框，单击“确定”后，网关网元只会出现在“搜索网元”对话框中，不会被创建至“网元视图”。

      • 去选“创建该网元”复选框操作，适用于搜索并创建该网关网元下的非网关网元，而不能创建此网关网元。

    2. 单击“确定”，弹出进度框。
    3. 进度完成将显示操作结果。单击“关闭”。

操作结果

如果操作结果显示为成功，该网关网元将会显示在“网元视图”的列表中。

父主题： 自动创建网元（搜索方式）


搜索非网关网元

介绍如何在网络中搜索非网关网元，以及如何批量创建非网关网元至网元软件管理的网元视图中。

前提条件

已进行“搜索网关”操作，或“搜索网元”中已存在网关网元信息。

背景信息

搜索网关网元的详细信息请参见搜索网关网元。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中单击右键，选择“网元管理 > 搜索网元”，打开“搜索网元”对话框。
  3. 在已搜索到的网关网元视图中，选择一条网元信息，单击“搜索非网关”。网元软件管理将在网络中搜索该网关网元所带的非网关网元。

    说明：
    • 搜索过程中，可以单击“停止”，中止搜索进度。
    • 搜索结束后，列表中会显示全部符合条件的非网关网元。

  4. 如果需要创建非网关网元至网元视图中，选择一条或多条网元信息，单击“增加网元”。
    1. 在弹出的对话框中设置网元信息。带*标记的参数值不能为空。
    2. 单击“确定”，弹出进度框。
    3. 进度完成将显示操作结果。单击“关闭”。

操作结果

如果操作结果显示为成功，所选的非网关网元将会显示在“网元视图”中。

父主题： 自动创建网元（搜索方式）


配置网元软件管理侧SNMPv1/v2/V3参数

对于使用SNMP协议与网元软件管理通信的网元，需要在网元软件管理侧配置与待操作网元对应相同的SNMP参数。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 已获得待操作网元的相关参数值。

背景信息

  • 配置SNMP参数后，网元软件管理侧可以通过SNMP对一些网元进行远程配置和管理。
  • 本节只针对网元软件管理侧如何配置SNMPv1/v2/V3参数进行介绍。网元软件管理侧某些参数的配置需要与网元侧保持一致。
  • 对于接入域网元，配置网元软件管理侧SNMP参数的入口有两个：
    • 在创建网元的过程中，可以直接配置SNMP参数。操作方法请参见1。
    • 当已经完成了网元的创建，需要针对一个或多个网元重新设置或修改SNMP参数时，可以参见下述步骤中的2。
  • 对于集群交换机网元，配置网元软件管理侧SNMP参数的方法请参见1。

操作步骤

  1. 在创建网元的过程中，配置SNMP参数的方法如下：
    1. 进行创建网元（接入/集群交换机）中1到3操作。
    2. 单击“SNMP参数”后的 [image] 。弹出对话框如下所示。

    3. 可选：配置“SNMPv1参数”和“SNMPv2参数”的方法相同。根据需要，单击“SNMPv1参数”或“SNMPv2参数”页签。按照下列方法进行配置。

      1. 单击“增加”，创建新的SNMP模板。

      2. 在弹出窗口中，设置SNMP参数信息。带*标记为必须输入项。
        说明：

        “读团体名称”和“写团体名称”必须与网元侧配置为一致。否则无法对网元进行读写操作。

      3. 配置完成后，单击“确定”。
      4. 在“操作结果”对话框中，单击“确定”，完成配置。

    4. 可选：单击“SNMPv3参数”页签，按照下列方法进行配置“SNMPv3参数”。

      1. 单击“增加”，创建新的SNMP模板。

      2. 在弹出窗口中，设置SNMP参数信息。带*标记为必须输入项。
        说明：

        设置SNMP参数信息必须与网元侧配置为一致。否则无法对网元进行读写操作。

      3. 配置完成后，单击“确定”。
      4. 在“操作结果”对话框中，单击“确定”，完成配置。

    5. 可选：可以删除已经增加的SNMP模板。

      1. 在“配置SNMP参数”对话框中，选中已增加的模板，单击“删除”。
      2. 单击“是”，确认删除。
      说明：

      缺省模板不能被删除。

    6. 单击“确定”。完成配置。
  2. 当网元已经完成创建，需要对一个或多个网元设置或修改SNMP参数时，进行如下操作：
    1. 在主菜单中，选择“系统 > 网元协议参数配置”。弹出对话框如下所示。根据需要，选择“SNMPv1参数”、“SNMPv2参数”或“SNMPv3参数”页签。

    2. 在上方窗格中，选择一条或多条网元信息，在下方窗格中根据需要配置协议参数。带*标记为必须输入项。

      说明：
      • 当同时选择多条网元信息时，“网元名称”不能修改。
      • “读团体名称”和“写团体名称”必须与网元侧配置为一致。否则无法对网元进行读写操作。

    3. 单击“确定”。完成配置。
父主题： 创建网元
相关任务
创建网元（接入/集群交换机）


修改网元参数

通过本节所述操作，可以对已创建的网元参数进行修改。

前提条件

  • 已经在网元软件管理上创建了网元。
  • 未对待修改网元进行其他操作。

背景信息

一次仅能对一个网元进行操作。

对于路由器/交换机（不包含集群交换机）, 直接在“IP域网元视图”中修改网元参数。

以下操作仅适用于传送域/PTN网元、接入域网元、集群交换机。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在网元视图中选择一个网元，单击右键，选择“网元管理 > 修改网元”。
  3. 根据需要，按下图所示，在可编辑的文本框中修改网元参数。

    图1 修改网元—传送域/PTN网元

    说明：
    带*标记的参数值不能为空。

    图2 修改网元—接入域网元

    说明：
    修改接入域网元和集群交换机时，IP地址不能修改。

  4. 修改完成，单击“确定”。
  5. 查看操作结果，单击“关闭”。

操作结果

网元修改成功后，网元视图中的网元信息将同步更新。

父主题： 创建网元


配置通信参数

在使用网元软件管理对网元进行备份、加载、恢复等操作前，先要配置网卡信息、服务器信息、文件传输根目录，和网元传输协议。

  • 单网卡单IP地址
    在使用网元软件管理对网元数据和软件进行管理前，需要对网卡进行配置。当网管服务器所在计算机通过一个网卡与网元网络进行通信时，并且一个网卡对应一个IP地址，请按照本节内容进行配置。
  • 多个网卡多IP地址
    在使用网元软件管理对网元数据和软件进行管理前，需要对网卡进行配置。当网元软件管理通过多个网卡与网元所在网络进行通信时，并且一个网卡对应一个IP地址，请参考本小节进行配置。
  • 单网卡多IP地址
    在使用网元软件管理对网元数据和软件进行管理前，需要对网卡进行配置。网元软件管理所在计算机通过一个网卡与网元网络进行通信，该网卡配置了多个IP地址，请参考本小节进行配置。
  • 配置传输协议
    在使用网元软件管理对网元软件进行备份、加载、恢复或导入软件等操作时，需使用传输服务软件，以确保网元与服务器文件传输正常。网元与网管之间可以通过多种协议进行文件传输，不同网元所支持的文件传输协议可能不同。在使用网元软件管理对网元进行备份、恢复、加载等操作前，需要对网元使用何种文件传输协议进行配置。
  • 第三方xFTP服务器设置
    当网元与网元软件管理之间不能直接使用SFTP/FTP协议通信，而网元可以与另一计算机使用SFTP/FTP协议通信时，可以在网元软件管理上设置使用第三方SFTP/FTP服务器，对网元进行操作。为了稳定，需要周期性的将网元的配置数据备份到一个或多个第三方SFTP/FTP服务器上，以便网元出现故障时可以恢复，为此也需要配置多个第三方服务器信息。
父主题： 准备工作


单网卡单IP地址

在使用网元软件管理对网元数据和软件进行管理前，需要对网卡进行配置。当网管服务器所在计算机通过一个网卡与网元网络进行通信时，并且一个网卡对应一个IP地址，请按照本节内容进行配置。

背景信息

  • 当无法直接与处于互联网中的网元直接进行通信时，需进行NAT转换，即使用另一个IP地址与网元进行通信。本小节中，在“与网元通信的IP”处设置转换后的另一个IP地址。
  • NAT（Network Address Translation），即网络地址转换器。它可以实现将私有网络上的私有IP地址(如192.168.0.0范围内的地址)转换成一个或多个互联网公共IP地址。当信息包从互联网上反馈回来时，会进行反向转换。

操作步骤

  1. 在主菜单中，选择“工具 > FTP设置”。
  2. 缺省打开“系统信息”页签。

  3. 当网元软件管理所在计算机通过一个网卡与网元网络进行通信时，并且一个网卡对应一个IP地址。请选择“单网卡(系统通过一个网卡与网元网络通信)”单选框，只需在“系统IP”中设置本机的IP地址（与网元所在网络通信的IP地址）。

  4. 单击“应用”将修改应用到系统信息设置中，弹出“操作结果”对话框。
  5. 单击“确定”成功配置系统信息。
父主题： 配置通信参数


多个网卡多IP地址

在使用网元软件管理对网元数据和软件进行管理前，需要对网卡进行配置。当网元软件管理通过多个网卡与网元所在网络进行通信时，并且一个网卡对应一个IP地址，请参考本小节进行配置。

背景信息

  • 网元软件管理可以配置多个网卡用于与不同网络中的网元进行通信。
  • 当无法直接与处于互联网中的网元直接进行通信时，进行NAT转换，即使用另一个IP地址与网元进行通信。本小节中，在“系统IP”处设置转换后的另一个IP地址。
  • NAT（Network Address Translation），即网络地址转换器。它可以实现将私有网络上的私有IP地址(如192.168.0.0范围内的地址)转换成一个或多个互联网公共IP地址。当信息包从互联网上反馈回来时，会进行反向转换。

操作步骤

  1. 在主菜单中，选择“工具 > FTP设置”。
  2. 缺省打开“系统信息”页签。

  3. 当网元软件管理通过多个网卡与网元所在网络进行通信时，并且一个网卡对应一个IP地址。在该模式下，不同网段网元需要通过不同网卡和网元软件管理相连。请选择“多网卡(系统通过多个网卡与网元网络通信)”单选框，进行如下配置：

    1. 单击“增加”，弹出“增加系统通信IP”对话框。在“系统IP”中设置网元软件管理与网元网段通信的IP地址（通过其中一个网卡）。
    2. 在“与网元通信的IP/掩码”中设置网元所在网段。
      说明：
      在“系统IP”输入10.78.220.9，网段可以设置为10.78.220.0/24，其中24表示换算成二进制的IP地址后八位可变。则该网卡可以连接的网元IP范围为10.78.220.0–10.78.220.255。
    3. 单击“确定”，建立网元软件管理与某一网段内网元的连接关系。
    4. 可选：重复3.a到3.c，配置其他网卡信息。
    5. 可选：单击“修改”，对已增加的信息进行修改，设置方法与3.a到3.c相同。
    6. 可选：单击“删除”，删除已增加的信息。

  4. 单击“应用”将修改应用到系统信息设置中，弹出“操作结果”对话框。
  5. 单击“确定”成功配置系统信息。
父主题： 配置通信参数


单网卡多IP地址

在使用网元软件管理对网元数据和软件进行管理前，需要对网卡进行配置。网元软件管理所在计算机通过一个网卡与网元网络进行通信，该网卡配置了多个IP地址，请参考本小节进行配置。

背景信息

  • 当无法直接与处于互联网中的网元直接进行通信时，进行NAT转换，即使用另一个IP地址与网元进行通信。本小节中，在“系统IP”处设置转换后的另一个IP地址。
  • NAT（Network Address Translation），即网络地址转换器。它可以实现将私有网络上的私有IP地址(如192.168.0.0范围内的地址)转换成一个或多个互联网公共IP地址。当信息包从互联网上反馈回来时，会进行反向转换。

操作步骤

  1. 在主菜单中，选择“工具 > FTP设置”。
  2. 缺省打开“系统信息”页签。

  3. 网元软件管理所在计算机通过一个网卡与网元网络进行通信，该网卡配置了多个IP地址。在该情况下，请选择“多网卡(系统通过多个网卡与网元网络通信)”。

    举例如下：如果单网卡配置了多个IP地址，其中一部分IP地址通过NAT转换，与其他网络中的网元进行通信，也请选择“多网卡(系统通过多个网卡与网元网络通信)”。

    如上图所示，网元软件管理所在计算机有单网卡，使用IP地址10.88.20.21与网段1 中网元进行通信。网卡还连接了NAT1 设备，并通过NAT转换为另一个IP地址219.211.10.2，并使用该IP地址与网段2 中网元进行通信。

    1. 在“系统IP”处输入其中一个IP地址。上例中是IP地址10.88.20.21。
    2. 在“与网元通信的IP/掩码”中输入目标网元所在网段。上例中是网段1，即192.168.11.0/24。
      说明：
      在“系统IP”输入10.88.20.21，网段可以设置为192.168.11.0/24，其中24表示换算成二进制的IP地址后八位可变。则该网卡可以连接的网元IP范围为10.168.11.0–10.168.11.255。
    3. 单击“增加”。
    4. 输入NAT转换后的IP地址与对应网段信息。上例中是209.211.10.2，以及网段2，即192.168.12.0/24。
    5. 再输入NAT转换后的IP地址与对应网段信息。上例中是209.211.20.3，以及网段3，即192.168.10.0/24。
      图1 多网卡配置

  4. 单击“应用”将修改应用到系统信息设置中，弹出“操作结果”对话框。
  5. 单击“确定”成功配置系统信息。
父主题： 配置通信参数


配置传输协议

在使用网元软件管理对网元软件进行备份、加载、恢复或导入软件等操作时，需使用传输服务软件，以确保网元与服务器文件传输正常。网元与网管之间可以通过多种协议进行文件传输，不同网元所支持的文件传输协议可能不同。在使用网元软件管理对网元进行备份、恢复、加载等操作前，需要对网元使用何种文件传输协议进行配置。

前提条件

  • 已经启动文件传输服务，设置服务参数。

  • 具有网元软件管理操作员及以上权限。

背景信息

说明：
为了安全，建议使用SFTP协议。
  • 当网元软件管理服务器和第三方FTP/SFTP服务器位于同一台计算机时，
    • 已经启动第三方FTP/SFTP服务，请停止该FTP/SFTP服务。
    • 没有启动第三方FTP/SFTP服务，推荐使用网元软件管理自带的“SFTP/FTP服务器配置”功能。缺省情况下，网元软件管理界面中的“文件传输服务根目录”、“用户名称”、“密码”等参数已经与服务器上的参数对应一致，只需要单击“测试SFTP”，查看SFTP传输协议是否可用。
  • 当网元软件管理服务器和第三方FTP/SFTP服务器位于不同的计算机时，如果采用第三方FTP/SFTP服务，按照本章配置FTP/SFTP服务。

传送域/PTN网元中TL1和MML网元在进行备份、恢复、加载等操作时，必须保证SFTP/FTP正常运行。其他类型网元如果在创建升级任务过程中选择了“如果待加载网元是网关网元，强制选择SFTP/FTP协议加载”复选框时，必须保证SFTP/FTP正常运行。

在使用SFTP协议对传送域网关网元进行升级前，需要先对网元进行SFTP密钥配置，因此要保证SFTP正常运行。

操作步骤

  1. 在网管中配置FTP/SFTP协议参数。

    配置本地FTP/SFTP协议参数，执行以下操作：

    1. 在主菜单中选择“系统 > FTP服务器配置”。
    2. 在弹出的页面中，配置协议参数。

      说明：
      • 确保“工作目录”与FTP/SFTP软件中的参数保持一致。
      • 默认用户为“ftpuser”，默认密码为“Changeme_123”，为保证系统安全，请及时修改密码并定期更新。
      • 为保证系统安全，设置的密码请满足一定的复杂性要求，例如密码长度推荐8个字符以上，至少包含数字、字母、特殊字符3类字符两种的组合。并请定期更新密码。

    配置第三方FTP/SFTP协议参数，请参考第三方xFTP服务器设置操作。

  2. 配置网元传输协议

    网元与网管之间可以通过多种协议进行文件传输，不同网元所支持的文件传输协议可能不同。在使用网元软件管理对网元进行备份、恢复、加载等操作前，需要对网元使用何种文件传输协议进行配置。

    网元与网元软件管理可以正常进行文件传输的前提：
    • 已经配置好网元与服务器的文件传输协议(本节所述功能)。但传送域/PTN网元不需要配置此参数。
    • 网元与服务器对应的传输服务已经启动并正常运行。

    1. 在主菜单中，选择“系统 > FTP设置”。
    2. 单击“传输协议”页签。
    3. 在网元与服务器的文件传输协议区域，根据网元类型，设置采用哪种“协议”与服务器进行文件传输。
    4. 单击“应用”，使设置生效。
    5. 弹出“操作结果”对话框，单击“确定”。
    6. 单击“确定”，关闭“FTP设置”对话框。
父主题： 配置通信参数
相关概念
配置SFTP服务器
相关任务
FTP服务器配置


第三方xFTP服务器设置

当网元与网元软件管理之间不能直接使用SFTP/FTP协议通信，而网元可以与另一计算机使用SFTP/FTP协议通信时，可以在网元软件管理上设置使用第三方SFTP/FTP服务器，对网元进行操作。为了稳定，需要周期性的将网元的配置数据备份到一个或多个第三方SFTP/FTP服务器上，以便网元出现故障时可以恢复，为此也需要配置多个第三方服务器信息。

前提条件

说明：
为了安全，建议使用SFTP协议。
网元需要支持SFTP/FTP协议进行文件传输；网元和指定的第三方SFTP/FTP服务器可以连通。只支持IP域和传送域网元。

背景信息

  • 当网元与网元软件管理之间不能直接使用SFTP/FTP协议通信，而网元可以与另一计算机使用SFTP/FTP协议通信。此时网元软件管理与网元之间依然是连通的，只是不能直接使用SFTP/FTP协议通信。
  • 创建任务时，设置了“用第三方SFTP/FTP服务器上的软件升级”后，备份、加载操作将在网元与第三方SFTP/FTP服务器之间进行。

操作步骤

  1. 在主菜单中选择“系统 > FTP设置”。
  2. 选择“第三方FTP服务器设置”页签。
  3. 在“第三方xFTP服务器信息”对话框中可根据需要执行如下操作：

    选项

    操作步骤

    测试第三方xFTP服务器信息

    选中一条已设置好的xFTP服务器信息，单击“测试”，对第三方xFTP服务器的xFTP功能的可用性进行测试。

    如果校验失败，则需要重新设置相关参数。

    增加第三方xFTP服务器信息
    1. 单击“增加”。
    2. 在“增加第三方xFTP服务器信息”对话框中设置相关参数。
      说明：
      若“类型”设置为“SFTP”，请根据实际需要设置“认证模式”。
    3. 可选：单击“测试”，对第三方xFTP服务器的xFTP功能的可用性进行测试。

      如果测试失败，请根据提示信息重新设置相关参数。

    4. 单击“确定”。
      说明：
      单击“确定”会自动测试xFTP功能的可用性。

    删除第三方xFTP服务器信息
    1. 选中一条需要删除的xFTP服务器信息，单击“删除”。
    2. 在“确认”对话框中单击“是”。

    修改第三方xFTP服务器信息
    1. 选中一条需要修改参数的xFTP服务器信息，单击“修改”。
    2. 在“修改第三方xFTP服务器信息”对话框中修改相关参数。
      说明：
      若需要修改认证信息，选中“修改认证信息”，进行认证信息修改。
    3. 可选：单击“测试”，对第三方xFTP服务器的xFTP功能的可用性进行测试。

      如果测试失败，请根据提示信息重新设置相关参数。

    4. 单击“确定”。
      说明：
      单击“确定”会自动测试xFTP功能的可用性。

父主题： 配置通信参数


申请网元软件升级能力License

通过认证网元软件管理License获取更高的升级并发度以及更多的网元软件管理功能。通过规范网元软件管理授权使用，使客户更高效的使用网元软件管理。

背景信息

当网元软件管理License有效期失效时，影响如下。
  • 升级并发度受控，不同域设备并发度受控不同：
    • 接入域升级并发度为10。
    • 传送域升级并发度不做控制。
    • IP域升级并发度为10。
  • 升级功能部分受限。举例如下：对接入域网元不能进行OLT代理升级任务。

网元软件管理license有以下三种认证方式：

  • 网络认证：通过输入support或W3账号和密码进行license认证。网络认证通过后，license有效期为180天。
  • License文件认证：选择网元软件管理授权的license文件进行认证。
  • 临时认证：
    • 当网元软件管理使用期限即将到期时，网元软件管理提供一次临时认证，确保用户可以在此期间申请网元软件管理License。
    • 在网元软件管理无Licence认证时，也可以申请使用临时Licence。
    说明：

    临时认证的规则如下：

    • 临时认证在每次license即将到期之后只能使用一次。
    • 临时认证成功后，license的有效期为7天。
    • 当用户再次申请了正式license，并通过验证之后，临时认证可选。
    • 认证通过后，如要进行临时认证，需在license失效前三天内申请，否则软件提示认证失败。

操作步骤

  1. 在主菜单中选择“系统 > 网元软件升级能力license”。弹出对话框，如下图所示。

    说明：

    在弹出的窗口可查看网元软件版本及license使用期限，软件在license失效前3天提示license即将过期，需要重新申请。

  2. 单击“申请”，弹出“License认证”对话框，如下图所示。

    图1 网络认证

    图2 License文件认证

    图3 临时认证

  3. 选择其中一种认证方式进行license申请。以网络认证为例，输入w3账号和密码，单击“确定”，操作成功后，在弹出窗口中提示license申请的有效期限，如下图所示。

    说明：
    • 认证通过后，如要进行临时认证，需在license失效前三天内申请，否则软件提示认证失败。
    • 在license有效期内，可以继续进行网络认证，认证通过后，license有效期从当前认证日期开始往后延60天，有效期不叠加。

父主题： 准备工作


软件管理

通过软件库功能上传网元软件到网元软件管理所在计算机，可实现网元软件的集中管理，使选择加载软件的过程更加方便快捷。

  • 修改软件文件
    通过以下操作，可以对软件库中软件文件的版本和描述进行修改。
  • 删除软件文件
    为保证网元软件管理所在计算机有充足的空间容纳新数据，需要及时删除网元上无用的软件文件，以释放存储空间。
  • 备份网元映像程序到软件库
    介绍如何将网元映像程序备份至软件库中对应网元类型的版本目录下。
父主题： 网元软件管理


修改软件文件

通过以下操作，可以对软件库中软件文件的版本和描述进行修改。

前提条件

  • 已经导入软件至软件库。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元软件库管理”。
  2. 选择待修改软件文件，单击右键，选择“修改”。

    说明：

    修改过程中，仅可以对软件文件版本和描述信息进行修改。

  3. 可选：单击“使用已经存在的版本”复选框。在“版本”下拉列表中，选择当前网元已经导入软件库中的软件版本。
  4. 在“版本”中，修改软件版本。
  5. 在“描述”中，修改软件描述。
  6. 单击“确定”。
  7. 单击“确定”，关闭“操作结果”对话框。
父主题： 软件管理


删除软件文件

为保证网元软件管理所在计算机有充足的空间容纳新数据，需要及时删除网元上无用的软件文件，以释放存储空间。

前提条件

  • 已经导入软件至软件库。

背景信息

  • 在网元类型树中选择某个网元类型或版本，在“网元软件库管理”列表中，显示相关软件信息。
  • 在网元类型树中选择某个网元类型，单击右键，选择“删除所有文件”，将会删除该网元类型下已导入的所有软件文件。
  • 由于导入到“网元软件库管理”中的软件数目会受限于网元软件管理所在计算机上文件传输目录所在磁盘空间的大小，建议定时删除无用的软件文件。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元软件库管理”。
  2. 选择一个或多个软件文件，单击右键，选择“删除”。
  3. 弹出“操作确认”对话框中，单击“是”。
  4. 在弹出对话框中，可以查看操作结果详细信息，单击“关闭”关闭对话框。
父主题： 软件管理


备份网元映像程序到软件库

介绍如何将网元映像程序备份至软件库中对应网元类型的版本目录下。

前提条件

  • 待操作网元支持该功能。

背景信息

  • 升级时，可以从下面途径获取升级软件。
    • 从华为网站下载。
    • 在一个网元上执行本操作后，升级所需软件保存到软件库中，在其它同类型网元上升级时可以选择加载该软件。创建升级任务时，如何选择加载软件操作，请参考升级/降级任务管理。
  • 同一时刻只能对一个映像程序进行操作。
  • 只有路由器/交换机支持此功能。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中选择一个网元，在下方窗格中单击“网元映像程序”页签。
  3. 单击“查询”。网元对应的操作状态会显示查询进度。
  4. 在查询到的映像程序列表中，选择待备份的软件，单击右键，选择“备份”。弹出“备份”对话框。

  5. 输入映像程序的“版本”。

    说明：
    • 如果“网元映像程序”页签下显示了程序“版本”，则在如上图所示的对话框中，会自动显示版本信息。请直接进行6。
    • 如果“网元映像程序”页签下未显示软件的“版本”，请根据网元信息输入正确的版本信息，并注意版本信息为大写形式。

  6. 可选：在“描述”区域，输入对映像程序的描述信息。
  7. 单击“确定”。

操作结果

在网元软件库管理界面显示备份的映像程序文件信息。

父主题： 软件管理


升级/降级任务管理

网元软件管理将升级/降级网元软件所需进行的主要操作封装成任务，通过创建对应的升级/降级任务，并一键式开始任务，实现自动对网元软件进行升级/降级操作。

说明：

网元软件的升级/降级是危险操作，可能导致网元业务中断。对于网元软件的升级/降级，请严格按照对应网元产品发布的升级指导书或补丁说明书进行操作。建议联系华为技术服务工程师对网元软件进行升级/降级操作。

升级流程和降级流程相同。本节以升级流程为例。升级操作流程如图1所示。

图1 Upgrade Process

  • 编辑任务
    创建升级/降级任务后，可以对原任务配置进行查看、修改。当需要快速创建一个与原任务相同或相似的任务时，可以通过复制任务功能实现。此外，还可以从任务列表中删除已执行完或不再需要的任务。
  • 运行任务
    创建升级/降级任务后，需要开始任务以执行升级/降级操作。执行升级/降级操作的过程中，当需要对网元执行任务以外的某些手工操作，或通过查看检测报告以确定是否继续进行升级/降级时，可以暂停任务，待完成手工操作或确认环节后，可以继续任务，使升级/降级操作继续执行。
  • 查看配置比较结果
    在同一个交换机类型网元中，通过比较升级前与升级后网元参数配置，了解升级过程是否造成网元配置发生改变。
  • 统计任务
    升级前后及升级过程中，通过查看任务统计，可以了解任务中网元数目、网元运行情况及网元运行结果的统计信息。
  • 网元级操作
    对任务进程进行控制的操作可以分为任务级操作和网元级操作。网元级操作，即在任务列表中单击 [image] 展开任务，直接对网元进行的右键操作。
  • 隔离室管理
    对于传送网元，在包加载或包扩散升级任务中，当某个网元的单板执行激活或分发操作失败，为不影响其他网元和该网元其他未运行单板继续执行升级操作，可以在隔离室中对该网元（包含操作成功和失败的单板）进行单独管理。可进行的操作包括刷新网元软件包状态、重试失败操作、回滚软件、继续执行任务、解除单板隔离、删除隔离数据等。
  • 查看任务报告
    通过查看任务报告、日志流、回显信息，可以了解任务执行情况。
父主题： 网元软件管理


编辑任务

创建升级/降级任务后，可以对原任务配置进行查看、修改。当需要快速创建一个与原任务相同或相似的任务时，可以通过复制任务功能实现。此外，还可以从任务列表中删除已执行完或不再需要的任务。

  • 查看任务信息
    介绍如何查看已创建任务的信息。
  • 修改任务
    创建任务后，可以根据需要对任务的一些配置项进行修改。
  • 复制任务
    当待创建的任务与原有任务操作步骤相同或相似时，通过复制任务操作，可以快速创建新任务。
  • 删除任务
    介绍如何在任务列表中删除一个或多个任务。
父主题： 升级/降级任务管理


查看任务信息

介绍如何查看已创建任务的信息。

前提条件

  • 已经创建任务。

背景信息

  • 在同一时间，只能查看一个任务。
  • 查看任务操作不限于特定的任务类型。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，选择待查看任务，单击右键，选择“查看任务”。

    说明：

    任务中所需的操作根据任务类型及网元类型的不同可能不同。“查看任务”对话框显示的页签与具体的任务相关。

  3. 根据需要，单击具体页签，查看任务信息。
父主题： 编辑任务


修改任务

创建任务后，可以根据需要对任务的一些配置项进行修改。

前提条件

  • 已创建任务，且任务处于未运行状态。
  • 当任务已经开始运行，一般不允许修改任务，除模拟包升/降级任务例外。
    • 当模拟包升/降级任务处于备份、加载、激活前暂停状态，可以修改任务（且仅允许修改激活分组及激活时间）。
    • 如果模拟包升/降级任务中有网元设备已经开始激活或任务中未选中激活步骤，则不可修改任务。

背景信息

  • 在同一时间，只能修改一个任务。
  • 任务类型、网元类型不能修改。
  • 由于任务在修改过程可以进行的配置操作与创建任务时的配置方法和注意事项相似，请根据任务类型进行具体配置项的修改操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 右键单击要修改的任务，选择“修改任务”，打开“修改任务”对话框。
  3. 根据需要，可选择对不同页签下的配置选项进行修改。

    说明：
    当包扩散任务（单板级）中设置的激活分组与网元上实际的激活分组不匹配时（可能原因：任务创建完成后，网元上的单板信息发生改变），任务执行激活操作的过程中会提示出错，任务暂停。此时需要修改任务中的激活分组信息。操作方法如下：
    1. 在“修改任务”对话框中，单击“激活”页签。
    2. 单击 [image] ，弹出检测对话框。在此期间，系统会核对当前的激活分组信息是否正确，并能够对错误的分组信息进行自动校正。

  4. 完成修改后，单击“确定”。
父主题： 编辑任务


复制任务

当待创建的任务与原有任务操作步骤相同或相似时，通过复制任务操作，可以快速创建新任务。

背景信息

  • 当任务执行失败，需要重新执行相同或相似的升级/降级操作时，可以应用此功能，快速创建新任务。
  • 在同一时间，只能复制一个任务。
  • 所有任务类型都支持复制。
  • 任务在复制过程可以对一些配置进行修改。由于复制任务操作与创建任务时的配置方法和注意事项相似，请根据任务类型进行具体配置项的修改操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 右键单击待复制任务，选择“复制任务”。
  3. 在“任务名称”文本框中，输入新任务名称。
  4. 对于路由器/交换机，当任务已经执行完毕，但任务中有部分网元执行操作失败。若复制任务，对操作失败网元再次进行升级时，可以进行如下选择：

    说明：

    复制成功的任务时，不会出现以下选项。请跳过此步，直接进行下一步操作。

    选项 | 描述
    所有网元 | 目标任务中包含源任务中的所有网元（成功和失败）。
    失败网元 目标任务中仅包含源任务中执行失败的网元。

    适用于源任务中有部分网元执行成功，需要仅为失败的网元重新执行升级/降级任务的情况。
  5. 单击“确定”。
  6. 根据需要，可选择对不同页签下的配置选项进行修改。完成修改后，单击“确定”。
父主题： 编辑任务


删除任务

介绍如何在任务列表中删除一个或多个任务。

前提条件

  • 任务不处于运行中状态。

背景信息

  • 所有任务类型都可以执行此操作。
  • 可以同时对多个任务进行操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 选择一个或多个任务，单击右键，选择“删除任务”。
  3. 在弹出对话框中，单击“是”。
  4. 在“操作结果”对话框中，单击“确定”。
父主题： 编辑任务


运行任务

创建升级/降级任务后，需要开始任务以执行升级/降级操作。执行升级/降级操作的过程中，当需要对网元执行任务以外的某些手工操作，或通过查看检测报告以确定是否继续进行升级/降级时，可以暂停任务，待完成手工操作或确认环节后，可以继续任务，使升级/降级操作继续执行。

  • 暂停任务
    当升级/降级过程中需要对网元进行其他操作时，可以暂停任务。
  • 继续任务
    通过继续任务操作，使已经停止的任务继续执行。
  • 移动到已完成
    任务执行失败后，可以将任务移动到已完成列表中。
  • 重试任务
    在批量的包扩散任务中（一般网元个数超过了10个），如果任务执行失败，例如全部网元加载失败或者激活失败时，可以重试任务。任务在所有的网元上重新执行。
父主题： 升级/降级任务管理


暂停任务

当升级/降级过程中需要对网元进行其他操作时，可以暂停任务。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 任务处于运行状态。

背景信息

  • 执行暂停任务操作后，任务不会立即暂停，而是继续执行完当前操作，在下一步操作执行前暂停。
  • 对于路由器网元，由于升级/降级检测项多，执行完所有检测需要等待较长时间，因此，当任务正在执行前/后检测操作时，进行“暂停任务”操作，任务会在执行完当前的检测项后暂停，而不是执行完当前操作（全部检测执行完毕）后才暂停。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 选择待操作任务，单击右键，选择“暂停任务”。

    说明：

    可以同时对多个任务进行操作。

  3. 在确认对话框中，单击“是”。

    说明：

    在选择“暂停任务”后，如果操作不成功，会弹出对话框，显示操作失败项和失败原因，单击“关闭”。

  4. 在“操作结果”对话框中，单击“确定”。

操作结果

操作成功后，在执行下一个步骤前操作状态将显示为暂停。

父主题： 运行任务


继续任务

通过继续任务操作，使已经停止的任务继续执行。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 任务处于停止状态。

背景信息

  • 所有任务类型都可以执行继续任务操作。
  • 可以同时对多个任务进行操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 右键单击待继续任务，选择“继续任务”。

操作结果

操作成功后，操作状态中显示任务执行进度。

  • 操作失败时，若弹出操作结果对话框，可在“详细”中查看失败原因。失败原因如果包含链接，可单击链接查看详细信息。
  • 操作失败时，若无对话框弹出，在操作结果栏中显示失败原因。失败原因如果包含链接，可单击链接查看详细信息。
父主题： 运行任务


移动到已完成

任务执行失败后，可以将任务移动到已完成列表中。

前提条件

  • 任务已执行失败。

背景信息

  • 所有任务类型都可以执行此操作。
  • 可以同时对多个任务进行操作。
  • 对于传送网元，若网元上有运行失败的升级任务，还想在该网元上运行新的升级任务，需要将原失败任务移动到“已完成”节点下，否则新的升级任务不能成功运行。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 右键单击待操作任务，选择“移动到已完成”。
  3. 在弹出对话框中，单击“是”。
  4. 在“操作结果”对话框中，单击“确认”。

操作结果

若操作成功，任务被移至已完成列表中。

父主题： 运行任务


重试任务

在批量的包扩散任务中（一般网元个数超过了10个），如果任务执行失败，例如全部网元加载失败或者激活失败时，可以重试任务。任务在所有的网元上重新执行。

前提条件

  • 已经创建包扩散任务。
  • 任务中所有的网元都执行失败。

背景信息

在批量的包扩散任务中，一般网元个数超过了10个，而且每个网元都失败的情况下，使用该功能可以提高升级效率。对于任务中多数网元升级成功，只有单个网元升级失败情况，可以使用网元级别的重试操作。参考重试。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，选择待查看任务，单击右键，选择“重试”。

    说明：
    任务开始执行后，右下方窗格中将显示任务执行进度。

操作结果

  • 操作失败时，若弹出操作结果对话框，可在“详细”中查看失败原因。失败原因如果包含链接，可单击链接查看详细信息。
  • 操作失败时，若无对话框弹出，在操作结果栏中显示失败原因。失败原因如果包含链接，可单击链接查看详细信息。
父主题： 运行任务


查看配置比较结果

在同一个交换机类型网元中，通过比较升级前与升级后网元参数配置，了解升级过程是否造成网元配置发生改变。

前提条件

  • 升级任务包含前检测与后检测操作，并且配置前检测信息和配置后检测信息时，都选择了“当前配置信息”选项。
  • 只支持在同一个交换机类型网元进行比较。不支持多个交换机类型网元之间的比较，或交换机类型网元与其它类型网元之间的比较。

操作步骤

  1. 在任务列表中，当升级任务进行了前和后检测操作后，单击右键，在右键菜单中选择“查看配置比较结果”。
  2. 在弹出的对话框中，查看比较结果，单击网元后的“查看”链接，查看详细信息。

    说明：
    • 通过左上角显示的上下调节按钮，可以定位到上一条或下一条两侧文件的不同处。
    • 系统会以醒目的颜色突出显示两个比较文件的不同点。

父主题： 升级/降级任务管理


统计任务

升级前后及升级过程中，通过查看任务统计，可以了解任务中网元数目、网元运行情况及网元运行结果的统计信息。

前提条件

  • 已经创建任务。

背景信息

  • 任务统计报告能够保存为*.html，*.txt，*.csv格式的文件。也可以预览和打印。
  • 任何任务类型都可以查看任务统计报告。
  • 可以同时对多个不同任务的统计信息进行查看。
  • 可以查看的信息包括：网元/槽总数、运行/未运行网元、成功/失败网元等。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，选择一个或多个任务，单击右键，选择“任务统计”，打开“任务统计”对话框。
  3. 在“任务统计”对话框中显示相关任务的统计信息。

  4. 可选：单击“任务统计”对话框左上方三个按钮可分别对统计报告进行保存、预览和打印。
父主题： 升级/降级任务管理


网元级操作

对任务进程进行控制的操作可以分为任务级操作和网元级操作。网元级操作，即在任务列表中单击 [image] 展开任务，直接对网元进行的右键操作。

  • 任务级操作，即在任务列表中选择任务，直接对任务进行的右键操作，不单击 [image] 展开任务。
  • 本章节介绍的如下网元级操作，若操作失败，将在操作结果栏中显示失败原因。失败原因如果包含链接，可单击链接查看详细信息。
  • 重试
    当网元在任务开始后因为某一环节执行失败导致任务失败时，通过重试操作，可以重新执行失败环节。
  • 停止
    对于正在执行任务的网元，可使其暂停执行下面的升级/降级操作。
  • 继续
    对于任务中处于暂停状态的网元，可以通过本节所述功能，使网元继续执行任务中接下来的操作。
  • 下一步
    为保障S9300、CX600与传送网元设备的升级成功率和升级效率，在任务执行的过程中，可以跳过网元的当前操作，执行下一步操作。
  • 回滚
    通过回滚操作使网元软件回退到升级前软件状态。
  • 重新检测
    当网元在执行任务过程中已完成了状态检测，为确保检测信息准确，可以通过本节所述功能对网元状态进行重新检测。
  • 刷新
    在创建包升级/降级或包扩散升级/降级任务后，通过刷新操作，可以实时了解网元在任务中的执行状态。
  • 取消
    当网元正在执行加载或备份操作时，可以通过取消操作，使系统回退到加载或备份前的状态。
  • 手工激活（单板级操作）
    模拟包任务中，可以通过本节所述功能手工对未激活或者激活失败的单板进行激活操作。
  • 忽略（激活失败容错）
    软件包加载和网元级软件包扩散任务中，如果网元部分单板激活失败，可以进行忽略操作，继续激活其它未激活的单板。
  • 查询激活失败单板
    软件包加载和网元级软件包扩散任务中，如果网元中有部分单板激活失败，可以查询激活失败的网元单板信息。
  • 移除
    包含多个网元的升级任务，当升级过程中有部分网元操作失败时，可以从任务中删除失败的网元。
父主题： 升级/降级任务管理


重试

当网元在任务开始后因为某一环节执行失败导致任务失败时，通过重试操作，可以重新执行失败环节。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 网元执行任务失败。

背景信息

  • 所有任务类型都可以执行重试任务操作。
  • 重试任务只能在操作失败的网元上进行。
  • 当任务执行失败时，系统会自动进行回滚。对进行包加载和包扩散任务的网元进行重试操作时，系统会自动检查网元当前待进行的操作（最初失败的操作或回滚后待进行的操作），并重新执行该操作。
    说明：

    如果重试成功，网元将继续依次执行任务中的其他操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在“任务管理”列表中，单击 [image] 展开失败的任务。
  3. 右键单击操作失败的网元，选择“重试”。

    说明：

    重试操作执行后，“操作状态”处会显示重试状态。

父主题： 网元级操作


停止

对于正在执行任务的网元，可使其暂停执行下面的升级/降级操作。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 网元处于执行任务状态。

背景信息

  • 执行“停止”操作后，网元不会立即暂停执行任务，而是继续执行完当前操作，在下一步操作前暂停。
  • 对于路由器网元，由于升级/降级检测项多，执行完所有检测需要等待较长时间。因此，当网元正在执行前/后检测操作时，进行“停止”操作，网元会在执行完当前的检测项后暂停，而不是执行完当前操作（全部检测执行完毕）后才暂停。
  • 本操作适宜用于以下情况：任务中包含多个网元；只需要对任务中的部分网元进行暂停。如果需要对任务中的全部网元执行暂停任务操作，请参见暂停任务。
  • 传送域/PTN网元不支持“停止”操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在任务列表中，单击 [image] ，展开任务节点。在任务节点下选择待操作网元，单击右键，选择“停止”。

    说明：

    可以同时对同一任务下的多个网元进行操作。

  3. 弹出“操作结果”对话框，单击“是”。

    说明：
    • 如果所选网元被暂停时下一个操作不可用，出现“任务操作结果”对话框并显示状态为“下面的资源或任务操作失败”。
    • 在“任务操作结果”中，可以查看“详细”操作状态。

操作结果

执行“停止”操作后，网元和任务节点对应的操作状态都会相应改变。

父主题： 网元级操作


继续

对于任务中处于暂停状态的网元，可以通过本节所述功能，使网元继续执行任务中接下来的操作。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 支持的任务类型：模拟包升级任务、软件升/降级任务。
  • 网元处于操作暂停状态。
    说明：
    在模拟包升级任务中，以下情况不能使用此功能：
    • 网元执行激活步骤前暂停
    • 单板激活分组间操作暂停
    • 任务中所有网元处于同一操作步骤前暂停

背景信息

  • “继续”操作与网元所执行的任务类型无关。
  • 可以同时对任务节点下的多个网元进行操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] ，展开任务节点。在任务节点下选择一个或多个网元，单击右键，选择“继续”。
  3. 弹出“操作结果”对话框，单击“是”。

操作结果

执行“继续”操作后，网元和任务节点对应的操作状态都会相应改变。

父主题： 网元级操作


下一步

为保障S9300、CX600与传送网元设备的升级成功率和升级效率，在任务执行的过程中，可以跳过网元的当前操作，执行下一步操作。

前提条件

  • 当前操作不是最后一步操作。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。
  • 对传送域网元，当任务类型为模拟包升级任务时，支持该功能。
  • S9300网元类型在激活失败时，也支持该功能。
  • 软件升/降级任务中，CX600网元类型在加载失败时支持该功能。
  • 对于传送网元类型，处于以下状态时可以进行此操作：
    • 前检测操作执行失败
    • 备份操作执行失败
    • 加载操作执行失败
    • 激活操作前暂停
    • 激活操作执行失败

背景信息

忽略的步骤不影响升级任务的执行结果。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] 展开任务节点。
  3. 选择一个网元，单击右键，选择“下一步”。网元将执行任务中的下一步操作。
父主题： 网元级操作


回滚

通过回滚操作使网元软件回退到升级前软件状态。

前提条件

  • 对于进行包加载和包扩散的网元，须满足：
    • 网元上存在升级前的软件包。
    • 回滚操作只能在以下三种情况下使能：
      • 加载完成后分发操作前
      • 分发完成后激活操作前
      • 激活完成后提交操作前
  • 对于路由、交换域网元，包括补丁回滚与软件回滚。
    • 对补丁回滚，须满足：
      • 补丁已成功加载。
      • 升级任务成功运行。
      • 若升级前网元中已运行补丁，回滚时，网元上需存在升级前用于启动的补丁文件
    • 对软件回滚，须满足：
      • 已经加载软件，并且加载软件中需包含程序文件。
      • 已进行激活软件操作
      • 任务成功完成
      • 网元上存在升级前用于启动的软件文件
  • 待操作网元支持该功能。
  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

注意：
回滚操作会导致网元业务中断，或者网元脱管，请慎用。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] 展开任务节点。
  3. 选择待操作网元，单击右键，选择“回滚”。

操作结果

“当前操作”显示为“回滚”。“操作状态”中显示执行进度。

父主题： 网元级操作


重新检测

当网元在执行任务过程中已完成了状态检测，为确保检测信息准确，可以通过本节所述功能对网元状态进行重新检测。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。
  • 对于路由器网元，须已经在任务中完成了前检测或后检测操作。
  • 对于传送网元，须已经在任务中完成了后检测操作（后检测操作成功或者失败）。
  • 支持的任务类型：模拟包升级任务、软件升/降级任务。
  • 网元所在任务不能移动到已完成。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] ，展开任务节点。在任务节点下选择一个待操作网元，单击右键，选择“重新检测”。
  3. 在弹出对话框中，单击“确定”。网元重新执行检测操作

操作结果

对于路由器网元，操作成功后，前后检测报告内容会根据检测结果自动更新。

父主题： 网元级操作


刷新

在创建包升级/降级或包扩散升级/降级任务后，通过刷新操作，可以实时了解网元在任务中的执行状态。

前提条件

  • 已经创建任务，且任务类型只能为包升级/降级或包扩散升级/降级。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] ，展开任务节点。在任务节点下选择待操作网元，单击右键，选择“刷新”。

  3. 在如上图所示对话框中，查看“状态”，单击“关闭”。
父主题： 网元级操作


取消

当网元正在执行加载或备份操作时，可以通过取消操作，使系统回退到加载或备份前的状态。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。
  • 已经开始任务，网元处于运行任务状态。
  • 网元正在执行任务中的加载操作或备份操作。

背景信息

取消操作执行成功，任务的“操作状态”将显示为“失败”。可以对网元进行“重试”，重新执行已经取消的操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] 展开任务节点。
  3. 选择一个网元，单击右键，选择“取消”。

操作结果

操作成功后，网元操作状态显示为“取消操作成功”，对应任务的操作状态显示为“失败”。

父主题： 网元级操作


手工激活（单板级操作）

模拟包任务中，可以通过本节所述功能手工对未激活或者激活失败的单板进行激活操作。

前提条件

  • 任务类型为模拟包升级任务。
  • 单板处于激活未运行或激活失败状态。
    说明：

    当待操作单板所在的网元正在执行任务级激活操作时，不能进行此操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在任务列表中，单击 [image] 展开任务，单击 [image] 展开网元。
  3. 选择待操作的单板，单击右键，选择“手工激活”。

    说明：

    不能同时选择不同网元节点下的单板进行手工激活操作。

操作结果

单板对应的“当前操作”显示为“激活”。“操作状态”中显示执行进度。

父主题： 网元级操作


忽略（激活失败容错）

软件包加载和网元级软件包扩散任务中，如果网元部分单板激活失败，可以进行忽略操作，继续激活其它未激活的单板。

前提条件

  • 任务处于提交前暂停状态。
  • 网元处于激活失败状态。
  • 同时选择多个网元时，网元处于同一激活分组中。
  • 升级任务类型为包加载或网元级包扩散。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] 展开任务节点。
  3. 选择待操作网元，单击右键，选择“忽略”。

操作结果

对网元进行忽略操作后，任务继续执行激活操作，激活操作成功完成后，网元状态为部分成功。

父主题： 网元级操作


查询激活失败单板

软件包加载和网元级软件包扩散任务中，如果网元中有部分单板激活失败，可以查询激活失败的网元单板信息。

前提条件

升级任务类型为包加载或网元级包扩散。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，单击 [image] 展开任务节点。
  3. 选择待操作网元，单击右键，选择“查询”。
  4. 查询进度完成，单击“显示查询结果”，显示激活失败网元单板信息。
  5. 查询完成，单击“关闭”。
父主题： 网元级操作


移除

包含多个网元的升级任务，当升级过程中有部分网元操作失败时，可以从任务中删除失败的网元。

前提条件

  • 任务类型为模拟包升级任务。
  • 任务中的网元执行某项操作失败。
  • 网元所在任务未移动到已完成。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在任务列表中，单击 [image] ，展开任务节点。在任务节点下选择一个或多个失败网元，单击右键，选择“移除”。
  3. 弹出“操作结果”对话框，单击“是”。
父主题： 网元级操作


隔离室管理

对于传送网元，在包加载或包扩散升级任务中，当某个网元的单板执行激活或分发操作失败，为不影响其他网元和该网元其他未运行单板继续执行升级操作，可以在隔离室中对该网元（包含操作成功和失败的单板）进行单独管理。可进行的操作包括刷新网元软件包状态、重试失败操作、回滚软件、继续执行任务、解除单板隔离、删除隔离数据等。

当单板执行分发或激活操作失败后，任务暂停，容错网元会自动进入隔离室中。此时，在“任务视图”页签中，容错网元会灰化，其对应的“操作状态”会提示该网元中部分单板已被隔离，单击链接，可以进入隔离室。

进入隔离室的网元处于操作成功状态，只有失败的单板被隔离。可以在隔离室中对网元或失败单板进行操作，如，查看哪些单板执行失败，并使失败单板重试失败操作。当判定失败单板不影响网元整体升级，或排除了失败单板的故障后，可以使网元继续执行升级操作。

容错网元的每一步升级操作的状态都可以通过日志流查看。方法：在隔离室界面最下方，单击 [image] ，打开操作日志流。日志流中包含已执行操作的起始时间、操作结果等信息。

  • 刷新SWDL状态
    在隔离室中，可以刷新软件包的当前状态，以确定下一步如何对网元或单板进行操作。SWDL（SoftWare DownLoad）即软件包加载。
  • 继续升级操作
    在隔离室中，网元每执行完一步操作后都会暂停。当失败单板不影响网元整体升级，或排除了失败单板的故障后，可以继续对网元进行升级操作。
  • 重试失败操作
    单板执行某个操作失败后，可以先对其或其所在网元进行重试。如果操作仍失败，建议对失败单板进行系统的故障排查。
  • 回滚软件
    升级过程中，当新软件存在问题，需要使网元或单板回退到升级前状态时，可以进行回滚操作。
  • 查看容错报告
    通过查看容错报告，可以了解隔离室中容错网元的升级过程信息和单板信息。
  • 删除数据
    当不再需要对隔离室中的网元进行任何操作时，可以从隔离室中删除该网元数据。
  • 解除隔离
    当隔离单板故障恢复后；或当网元已经完成提交操作，而失败的单板仍处于隔离状态时，可选择手工对这些单板解除隔离。
父主题： 升级/降级任务管理


刷新SWDL状态

在隔离室中，可以刷新软件包的当前状态，以确定下一步如何对网元或单板进行操作。SWDL（SoftWare DownLoad）即软件包加载。

前提条件

隔离室中存在容错网元。

操作步骤

  1. 在“隔离室”中，选择待操作网元，单击右键，选择“刷新SWDL状态”。

    说明：

    可同时对同一任务中的多个网元进行操作，不能对不同任务中的网元同时进行操作。

操作结果

刷新后，软件包的状态更新为当前状态。

父主题： 隔离室管理


继续升级操作

在隔离室中，网元每执行完一步操作后都会暂停。当失败单板不影响网元整体升级，或排除了失败单板的故障后，可以继续对网元进行升级操作。

前提条件

隔离室中存在容错网元，且容错网元的操作状态不能为失败。

操作步骤

  1. 在“隔离室”中，选择待操作网元，单击右键，选择“继续”。

    说明：

    可同时对同一任务中的多个网元进行操作，不能对不同任务中的网元同时进行操作。

操作结果

执行“继续”操作后，网元的当前操作，以及网元和单板节点对应的操作状态都会相应刷新。

在网元激活过程中，存在激活失败单板的网元进入隔离室，网元状态为激活“挂起”情形下：
  • 如果选择执行“继续”操作，系统会直接跳过激活步骤，执行下一步任务操作。
  • 如果选择执行“重试”操作，系统会对剩下的未激活的单板执行激活操作。
  • 如果想对激活失败的单板重新执行激活操作，请选中激活失败的单板，执行“重试”操作。
父主题： 隔离室管理


重试失败操作

单板执行某个操作失败后，可以先对其或其所在网元进行重试。如果操作仍失败，建议对失败单板进行系统的故障排查。

前提条件

  • 隔离室中存在容错网元。
  • 容错网元执行完激活操作。特例：对于PTN网元，当执行完分发操作后，执行前检测操作失败时，可以对网元进行重试操作。
  • 对网元进行重试操作，则该网元必须存在隔离单板；对单板进行重试操作，则该单板必须处于隔离状态。
  • 只能对失败的操作进行重试。
  • 提交后不能进行重试操作。

操作步骤

  1. 在隔离室中，选择待操作单板或网元，单击右键，选择“重试”。

    说明：
    • 可以对隔离单板或其所在网元进行重试。
    • 可以对同一任务中的多个失败单板同时进行重试。不同任务中的单板不能同时重试。
    • 可以对同一任务中的多个失败网元同时进行重试。不同任务中的网元不能同时重试。

操作结果

执行“重试”后，单板或网元的“操作状态”处会显示重试状态和重试后的操作结果。

在网元激活过程中，存在激活失败单板的网元进入隔离室，网元状态为激活“挂起”情形下：
  • 如果选择执行“继续”操作，系统会直接跳过激活步骤，执行下一步任务操作。
  • 如果选择执行“重试”操作，系统会对剩下的未激活的单板执行激活操作。
  • 如果想对激活失败的单板重新执行激活操作，请选中激活失败的单板，执行“重试”操作。
父主题： 隔离室管理


回滚软件

升级过程中，当新软件存在问题，需要使网元或单板回退到升级前状态时，可以进行回滚操作。

前提条件

  • 隔离室中存在容错网元。
  • 容错网元未执行提交操作。
  • 对网元进行回滚操作，则该网元必须存在隔离单板；对单板进行回滚操作，则该单板必须处于隔离状态。
  • 对单板进行回滚操作时，单板的当前操作必须处于失败状态。

背景信息

回滚后，网元或单板仍运行原版本软件。

操作步骤

  1. 在隔离室中，选择待操作网元或隔离单板，单击右键，选择“回滚”。

    说明：
    • 同一时刻，可以对同一任务中的多个网元进行回滚。不同任务中的网元不能同时回滚。
    • 同一时刻，可以对同一网元中的多个单板进行回滚。不同网元中的单板不能同时回滚。

操作结果

执行“回滚”后，网元或单板的“操作状态”处会显示回滚进度和回滚后的操作结果。

父主题： 隔离室管理


查看容错报告

通过查看容错报告，可以了解隔离室中容错网元的升级过程信息和单板信息。

前提条件

隔离室中存在容错网元。

背景信息

报告需要保存至本地目录进行查看。报告只能保存为*.XLS格式。

操作步骤

  1. 在隔离室中，单击“导出”。弹出对话框如下所示。

  2. 在“文件路径”中，单击 [image] ，设置报告保存的路径。

    说明：
    • 保存报告的缺省路径为“\client\report”。
    • 同一时刻，会导出隔离室中全部任务的容错报告。
    • 当需要将自定义设置的“文件路径”恢复为缺省路径，单击“恢复缺省”。

  3. 可选：当隔离室存在多个任务，需要将报告保存成同一格式并保存至同一路径时，单击“和第一行的配置相同”。
  4. 单击“确定”。
  5. 弹出对话框如下所示。选择需要查看的报告，单击“打开”，查看任务报告。

父主题： 隔离室管理


删除数据

当不再需要对隔离室中的网元进行任何操作时，可以从隔离室中删除该网元数据。

前提条件

  • 隔离室中存在容错网元。
  • 网元/任务不处于运行状态。

背景信息

当任务中的所有网元都需要删除时，可以直接对任务进行删除。

操作步骤

  1. 在隔离室中，选择待删除任务或网元，单击右键，选择“删除”。

    说明：

    可以同时删除同一任务下的多个网元，也可以同时删除多个任务。

  2. 在弹出确认对话框中，单击“是”。显示删除进度。
  3. 待进度完成后，查看操作结果，单击“关闭”，完成操作。
父主题： 隔离室管理


解除隔离

当隔离单板故障恢复后；或当网元已经完成提交操作，而失败的单板仍处于隔离状态时，可选择手工对这些单板解除隔离。

前提条件

  • 隔离室中存在容错网元。
  • 单板处于隔离状态。
  • 隔离单板已经执行完提交操作。

操作步骤

  1. 在隔离室中，选择待解除隔离的单板，单击右键，选择“解除隔离”。

    显示解除隔离的进度信息。

    说明：

    可以同时对同一网元下的多个隔离单板进行操作。不同网元中的隔离单板不能同时进行操作。

操作结果

操作成功后，对应单板的“是否被隔离”状态更新为“否”。

在隔离室中，单板被解除隔离后，不能再对其进行任何操作。

父主题： 隔离室管理


查看任务报告

通过查看任务报告、日志流、回显信息，可以了解任务执行情况。

在任务开始后，可以单击界面最下面的 [image] ，查看任务中的操作日志流。

  • 生成任务报告
    通过任务报告，可以了解任务的配置信息和执行信息。本节介绍如何生成任务报告。
  • 查看回显信息
    当任务执行完可行性检测或前后检测操作后，通过查看回显信息，可以实时了解网元的状态。
  • 查看前检测报告
    通过查看前检测报告，可以了解网元升级前的基本状态信息。
  • 查看后检测报告
    通过查看后检测报告，可以了解网元升级后的基本状态信息。
  • 查看比较报告
    通过查看对比报告，可以了解网元升级前后状态的对比信息。
父主题： 升级/降级任务管理


生成任务报告

通过任务报告，可以了解任务的配置信息和执行信息。本节介绍如何生成任务报告。

前提条件

  • 任务已经开始。
  • 任务不处于运行状态。

背景信息

  • 任务处于停止、失败、成功状态都可以生成任务报告。
  • 所有类型的任务都支持生成任务报告。
  • 任务报告需要保存至本地目录进行查看。报告只能保存为*.XLS格式。
  • 可以同时对多个任务进行操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在右侧窗格中，选择待操作的任务，选择“生成报告”。弹出对话框如下图所示。

  3. 在“文件路径”中，单击 [image] ，设置报告保存的路径。

    说明：
    • 保存报告的缺省路径为“\client\report”。
    • 当需要将自定义设置的“文件路径”恢复为缺省路径，单击“恢复缺省”。

  4. 可选：如果同时对多个任务进行操作，且需要将报告保存至同一路径，单击“和第一行的配置相同”。
  5. 单击“确定”。
  6. 弹出对话框如下图所示。单击“打开”，查看任务报告。

父主题： 查看任务报告


查看回显信息

当任务执行完可行性检测或前后检测操作后，通过查看回显信息，可以实时了解网元的状态。

前提条件

  • 任务已经运行，且待查看回显信息所对应的操作已执行完毕。
  • 待操作网元支持该功能。

背景信息

  • 查看回显信息是任务中的网元级操作。
  • 同一时刻只能对一个网元进行操作。
  • 前、后检测在操作完成后可以查看回显信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 在任务列表中单击 [image] 展开任务节点，选择待操作网元。

  3. 单击已完成的操作，在右侧子操作列表中，单击“查看”。弹出“查看命令回显”对话框。
  4. 可选：单击“保存”，将回显信息保存至本地目录。
  5. 单击“确定”，关闭对话框。
父主题： 查看任务报告


查看前检测报告

通过查看前检测报告，可以了解网元升级前的基本状态信息。

前提条件

  • 任务已经运行，且已完成前检测操作。
  • 待操作网元支持该功能。

背景信息

  • 前检测报告中显示的内容与创建任务时配置的检测项相对应。
  • 前检测报告可以保存，可以选择仅查看失败的检测项。
  • 通过前检测报告，可以查看网元执行任务的回显信息。详细信息请参见查看回显信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 单击 [image] 展开任务节点，选择一个或多个网元，单击右键，选择“查看检测报告 > 查看前检测报告”。

    说明：

    对于MA系列的接入域网元，可以选择待操作的任务，单击右键，选择“查看检测报告 > 查看前检测报告”，查看该任务中所有网元的前检测信息。

  3. 可选：如果仅需要查看失败的检测项，选择“查看失败的检测项”复选框。

    说明：

    选择“查看所有检测项”复选框，查看全部检测项信息。

  4. 可选：如果需要查看任务回显信息，单击检测项后的“查看”。

    说明：

    只有路由器/交换机支持此功能。

  5. 可选：如果需要对检测报告进行保存，单击“另存为”。
  6. 查看完成，单击“关闭”。
父主题： 查看任务报告


查看后检测报告

通过查看后检测报告，可以了解网元升级后的基本状态信息。

前提条件

  • 任务已经运行，且已完成后检测操作。
  • 待操作网元支持该功能。

背景信息

  • 后检测报告中显示的内容与创建任务时配置的检测项相对应。
  • 后检测报告可以保存，可以选择仅查看失败的检测项。
  • 通过后检测报告，可以查看网元执行任务的回显信息。详细信息请参见查看回显信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 单击 [image] 展开任务节点，选择一个或多个网元，单击右键，选择“查看检测报告 > 查看后检测报告”。
  3. 可选：如果仅需要查看失败的检测项，选择“查看失败的检测项”复选框。

    说明：

    选择“查看所有检测项”复选框，查看全部检测项信息。

  4. 可选：如果需要查看任务回显信息，单击检测项后的“查看”。

    说明：

    只有路由器/交换机支持此功能。

  5. 可选：如果需要对检测报告进行保存，单击“另存为”。
  6. 查看完成，单击“关闭”。
父主题： 查看任务报告


查看比较报告

通过查看对比报告，可以了解网元升级前后状态的对比信息。

前提条件

  • 任务已经运行，且已完成前、后检测操作。
  • 待操作网元支持该功能。

背景信息

  • 对比报告可以保存，可以选择仅查看存在差异的比较信息。
  • 通过比较报告，可以查看网元执行任务的回显信息。详细信息请参见查看回显信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元升级任务管理”。
  2. 单击 [image] 展开任务节点，选择一个或多个网元，单击右键，选择“查看检测报告 > 查看比较报告”。
  3. 可选：如果仅需要查看对比中存在差异的信息，选择“查看差异的和失败的检测项”复选框。

    说明：

    选择“查看所有检测项”复选框，查看全部检测项信息。

  4. 可选：如果需要查看任务回显信息，单击检测项后的“查看”。

    说明：

    只有路由器/交换机支持此功能。

  5. 可选：如果需要对检测报告进行保存，单击“另存为”。
  6. 查看完成，单击“关闭”。
父主题： 查看任务报告


升级前后文件对比

升级完成后，可以将升级后的配置信息和路由信息与升级前比较，了解升级过程对网元造成了哪些影响。

  • 配置文件对比
    通过比较升级前后的配置文件，了解网元升级前和升级后的配置信息有何异同。
  • 路由文件对比
    在网元升级完成后，可通过对比升级前和升级后的路由文件，确认升级影响的范围，以及路由信息是否改变。
父主题： 网元软件管理


配置文件对比

通过比较升级前后的配置文件，了解网元升级前和升级后的配置信息有何异同。

前提条件

  • 只有路由域与交换机网元支持该功能。
  • 已经将升级前和升级后的配置信息文件保存在本地。

背景信息

只支持比较.txt、.cfg和.log格式的配置信息文件。

操作步骤

  1. 在主菜单中选择“系统 > 文件对比 > 配置文件对比”，弹出“配置文件对比”对话框。

  2. 在“配置文件对比”对话框的左侧单击“选择”，弹出“选择文件”对话框。

  3. 选择升级前的配置信息文件，单击“确定”。
  4. 在“配置文件对比”对话框的右侧单击“选择”，弹出“选择文件”对话框。
  5. 选择升级后的配置信息文件，单击“确定”。
  6. 在“配置文件对比”对话框中单击“比对”，系统弹出进度条，提示对比的进度。

    说明：

    在对比时，请勿删除正在对比的文件，否则系统会提示文件不存在，中止对比。

  7. 对比完成后，可在“配置文件对比”对话框的左右两个区域框中查看升级前/后的差异信息。

    说明：
    • 粉红色字体表示两个文件中相同位置存在差异的信息。
    • 蓝色字体表示其中一个文件相较另一个文件多出部分的信息。

  8. 可选：单击 [image] 或 [image] ，光标会自动跳转到下一个或上一个差异信息，并将两个文件中的差异信息显示在“配置文件对比”对话框下侧的两个文本框中。

父主题： 升级前后文件对比


路由文件对比

在网元升级完成后，可通过对比升级前和升级后的路由文件，确认升级影响的范围，以及路由信息是否改变。

前提条件

  • 只有路由域与交换机网元支持该功能。
  • 已经将升级前和升级后的路由信息文件保存在本地。

背景信息

  • 在网元升级前和完成升级后，需要输入命令行disp ip routing-table，并且将回显信息保存为路由信息文件，以供对比。
  • 只支持比较.txt、.cfg和.log格式的路由信息文件。

操作步骤

  1. 在主菜单中选择“系统 > 文件对比 > 路由文件对比”，弹出“路由文件对比”对话框。
  2. 在“配置文件对比”对话框的左侧单击“选择”，弹出“选择文件”对话框。

  3. 选择升级前的路由信息文件，单击“确定”。
  4. 在“路由文件对比”对话框的右侧单击“选择”，弹出“选择文件”对话框。
  5. 选择升级后的路由信息文件，单击“确定”。
  6. 在“路由文件对比”对话框中单击“比对”，弹出进度条，提示比对的进度。

    说明：

    在比对时，请勿删除正在比对的文件，否则会提示文件不存在，中止对比。

  7. 比对完成后，可在“路由文件对比”对话框的左右两个区域框中查看升级前/后的差异信息。

  8. 单击“关闭”，完成路由信息文件的比对。
父主题： 升级前后文件对比


板级软件管理

介绍如何针对网元上的部分单板进行软件加载和补丁加载。以及如何在更换新业务单板时，自动将其升级到与网元相同的版本。

  • 加载板级软件
    只需要对网元上的部分单板进行软件加载操作时，可使用单板级软件加载功能。
  • 加载板级补丁软件
    板级补丁软件是对网元主控板软件或其他单板软件的补充，一般用于修正这些软件中存在的缺陷，也可以用于增强网元性能。
父主题： 网元软件管理


加载板级软件

只需要对网元上的部分单板进行软件加载操作时，可使用单板级软件加载功能。

前提条件

  • 已经创建网元。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。

背景信息

加载单板软件功能只适用于传送域/PTN网元。
说明：
RTN设备默认不支持该功能。

加载主控板（主机）软件前，需了解并注意以下内容：

  • 对存在两套主机软件的主控板进行加载操作时，新加载的软件只能作为备用软件驻留在主控板上，激活后才能成为主用软件。
  • 由于激活Fpga软件会使网元硬复位并导致业务中断，所以如果对同一主控板的两个区加载了相同的Fpga文件，第二次加载完成后可以不激活。
  • 对于存在双主控板的网元，直接加载并激活主用主控板可能会导致业务中断。所以应该先加载并激活备用主控板，然后再加载主用主控板。
  • 同时对多个网元进行加载操作时，必须等待所有加载操作完成后才能逐个激活。
  • 主机软件在加载完成但未激活的情况下，如果重新启动网元软件管理进程，则主机软件需要重新加载并激活。
  • 不能对同一网元同时进行软件加载、数据备份和恢复等多项操作。
  • 不能对同一网元的主控板和单板同时进行软件加载。
说明：

网元软件管理提供删除网元数据库的功能入口，可以手工删除网元数据库。请参考删除数据库。

操作步骤

  1. 在菜单中选择“板级软件管理 > 板级软件加载”，功能树中将显示已添加的网元。
  2. 单击 [image] 更新网元列表。如果待操作网元不在网元列表中，创建网元并显示在功能树中。
  3. 登录待操作网元。
  4. 右键单击已登录的网元，在弹出的右键菜单中选择“查询单板”，查询该网元的单板信息。

    说明：

    在执行查询单板的时候，网元需要等待一段时间，属于正常情况。

  5. 单击 [image] ，展开单板列表。
  6. 选中待加载单板前的复选框并使单板列表展开，单击 [image] 将单板添加到操作列表。
  7. 单击各“待升级版本”参数框中的 [image] ，弹出“设置单板软件”窗口。
  8. 选择软件加载类型，单击“添加软件”，弹出“选择文件”对话框。

    说明：

    单击“添加软件”，可以添加多个文件。

  9. 在“选择文件”对话框中选择待加载的文件。

    说明：
    • 如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。
    • 输入“服务器地址”、“用户名称”、“密码”、“端口”，单击 [image] ，连接成功后可以访问Server上的文件。若使用FTP协议，设置“端口”为21，若使用SFTP协议，设置“端口”为22。
      说明：
      为了安全，建议使用SFTP协议。

  10. 在“设置单板软件”窗口单击“确定”，即可完成升级软件选择。
  11. 选中操作列表中的单板，单击“开始”。

    说明：

    加载过程中单击“停止”可停止加载操作。

  12. 加载完成后，单击“激活”，系统弹出“警告”对话框，确认是否激活。
  13. 单击“是”，开始激活。
  14. 激活成功后，系统弹出“操作结果”对话框，提示激活成功。单击“关闭”，关闭该对话框。
父主题： 板级软件管理


加载板级补丁软件

板级补丁软件是对网元主控板软件或其他单板软件的补充，一般用于修正这些软件中存在的缺陷，也可以用于增强网元性能。

前提条件

  • 已经创建网元。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 请确保要加载的补丁软件与主机软件的版本配套正确。

背景信息

代表该网元只支持补丁包加载。

代表该网元只支持板级补丁加载。

网元需要登录后才能区分是否支持板级补丁加载功能。

补丁软件只能升级加载，不能重复或降级加载。

操作步骤

  1. 在菜单中选择“板级软件管理 > 板级补丁升级”，功能树中将显示已添加的网元。
  2. 单击 [image] 更新网元列表。如果待操作网元不在网元列表中，创建网元并显示在功能树中。
  3. 登录待操作网元。
  4. 在功能树中网元名称上单击右键，选择“查询单板”。
  5. 展开网元的所有单板，然后选择需要加载的单板，单击 [image] ，操作列表中出现待操作单板的相关信息。

    说明：

    在执行查询单板的时候，网元需要等待一段时间，属于正常情况。

  6. 在操作列表中选中待加载单板，在参数框“待升级版本”中单击 [image] ，弹出“选择文件”对话框，选择需要加载的软件。被访问路径不能包含除英文和数字之外的字符。

    说明：
    • 如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。
    • 如果不选中“FTP/SFTP Server上的文件”单选框，则访问路径为网管服务器上xFTP服务的根目录。
    • 如果选中“FTP/SFTP Server上的文件”单选框，则需要输入正确的FTP/SFTP服务器信息，访问路径为远程服务器。若使用FTP协议，设置“端口”为21，若使用SFTP协议，设置“端口”为22。
      说明：
      为了安全，建议使用SFTP协议。

  7. 单击“开始”开始加载软件。

    说明：
    • 加载开始后，界面显示加载进度，状态显示为“正在加载”。当状态显示为“加载完成待激活”时表示加载结束。
    • 加载过程中，单击“停止”可以停止加载操作。
    • 加载过程中，单击“回滚”将回滚到加载前的状态。

  8. 加载结束后，单击“激活”，激活补丁软件。

    说明：

    单击“回滚”，可以进行回滚操作。

    激活过程中单板状态显示为“正在激活”，激活完成后，网元状态显示为“激活完成”。

  9. 单击“升级完成”，完成补丁升级。

    说明：

    单击“升级完成”后，如果升级失败，将自动回滚到加载前的状态。

    单击“升级完成”后，如果升级成功，将不能再进行回滚操作，网元状态显示为“正常态”。

父主题： 板级软件管理


数据备份与恢复

因网元维护或升级/降级需要，将最新的网元数据备份到网元软件管理所在计算机上，当对网元进行升级/降级后，或者当网元发生故障造成运行的数据丢失时，可以从备份文件中恢复网元数据。本节介绍如何立即保存、备份网元数据，以及如何从备份文件中恢复网元数据。

  • 备份网元数据
    因网元维护或升级/降级需要，将网元数据备份到网元软件管理所在计算机上，以防止升级/降级或意外原因导致网元数据损坏或丢失。本节介绍如何手工备份网元数据。
  • 恢复网元数据
    因网元维护需要，或当网元发生故障造成数据库文件丢失时，可以从已备份的数据库文件中恢复网元数据库。
  • 保存网元数据
    系统配置后，数据保存在网元内存中。通过保存操作将网元数据从网元内存保存到网元Flash或CF卡中，防止重启时丢失网元数据。
  • 备份文件管理
    介绍如何对备份到文件传输目录中的网元数据文件进行查看、比较、保存至本地目录、删除等操作。
父主题： 网元软件管理


备份网元数据

因网元维护或升级/降级需要，将网元数据备份到网元软件管理所在计算机上，以防止升级/降级或意外原因导致网元数据损坏或丢失。本节介绍如何手工备份网元数据。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。
  • 网元上已经配置Telnet参数，参考“网管基础操作”中的“网管与网元的通信协议”。
  • 保证网管上SNMP写团体字与网元上配置一致，参考“网管基础操作”中的“网管与网元的通信协议”。
  • 已经启动并配置FTP/SFTP服务。详细内容请参考配置传输协议。
    说明：
    • 为了安全，建议使用SFTP协议。
  • 通过代理网元为目标网元做备份时，须保证第三方FTP服务器与目标网元间可以正常进行文件传输。
  • 数通网络常常会配置VPN（Virtual Private Network），此时数通网元也需要配置VPN参数。

背景信息

  • 当备份网元数据到网元软件管理所在计算机时，文件传输根目录下会自动创建backup文件夹。备份的网元数据会通过FTP/SFTP传输至backup文件夹下。
  • 当待操作的网元与网元软件管理间无法连接时，可以通过代理网元为目标网元进行备份。但此操作的前提是必须配置第三方FTP服务器，使其与目标网元间能够正常进行文件传输。备份的过程，即通过FTP协议将网元数据备份到第三方FTP服务器的过程。第三方FTP服务器配置参考第三方xFTP服务器设置。
  • 支持同时对多个不同类型的网元进行备份。带有“-”标记，代表该网元不支持此功能。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作的网元，单击“备份”。
  3. 选择备份的“文件类型”。

    说明：

    若选择不支持的文件类型进行备份，网管会提示错误。

    选项 描述

    启动配置文件

    路由器/交换机的一种数据文件类型。该文件由保存在网元Flash中的数据生成。

    运行配置文件

    路由器/交换机的一种数据文件类型。该文件由网元内存中当前运行的数据生成。

    数据文件

    接入域网元的一种数据文件类型。文件格式为二进制。升级时，对于不支持内部数据库升级的网元，需要使用升级工具对网元数据进行升级。

    配置文件

    接入域网元的一种数据文件类型。文件中可查看具体的命令。升级时，不需要对配置文件进行升级。但由于升级前的配置文件可能在新版本中不完全兼容，从而导致业务丢失，因此推荐使用数据文件进行升级。

    数据库包/配置数据
    • 传送域的数据文件类型。多数网元仅支持数据库包，只有较早版本的网元支持配置数据。
    • 若选择不支持的文件类型进行备份，网管会提示错误。
  4. 可选：如果需要文件在备份前自动保存，选中“备份前保存”复选框。

    说明：

    备份前先保存，是将网元当前运行在内存中的数据保存到Flash中，确保从Flash中备份的网元数据为最新（与网元当前运行的数据一致）。

  5. 单击“开始”。

操作结果

操作状态中显示操作进度。操作完成后将显示操作结果。

后续处理

  • 当需要查看某个网元的备份文件信息时，可在“网元视图”中选择该网元，单击“备份信息”页签，进行查看。

  • 在“备份信息”页签中，还可以对网元的备份文件进行管理。详细信息请参见备份文件管理。

父主题： 数据备份与恢复


恢复网元数据

因网元维护需要，或当网元发生故障造成数据库文件丢失时，可以从已备份的数据库文件中恢复网元数据库。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。
  • 已经备份网元数据至网元软件管理。
  • 已经启动并配置FTP/SFTP服务。详细操作请参见配置传输协议。
    说明：
    • 为了安全，建议使用SFTP协议。
  • 使用第三方SFTP方式进行恢复操作时，网元软件管理作为客户端访问SFTP服务器，需要注意如下条件。
    1. 网元软件管理作为客户端，需要安装在如下的操作系统中。
      • Windows 2000， 2003， XP
      • Solaris 8/10
      • Linux (SuSE 10)
    2. 支持的第三方SFTP服务器类型为：
      • OpenSSH 4.3p2 Server for Linux(V4.3p2)
      • SSH Tectia Server for Windows XP/2003(V5.0.1.79)
      • OpenSSH 3.8p1 Server for Linux(V3.8p1)
      • OpenSSH 4.3p2 Server for Solaris(V4.3p2)
  • 通过代理网元为目标网元做备份时，须保证第三方服务器与目标网元间可以正常进行文件传输。

背景信息

网元软件管理通过FTP/SFTP将要恢复的内容（备份文件）传输至网元上。再经过激活操作，使备份文件在网元上生效，完成网元的数据恢复。

当待操作的网元与网元软件管理间无法连接时，可以通过代理网元为目标网元进行恢复操作。但此操作的前提是必须配置第三方FTP服务器，使其与目标网元间能够正常进行文件传输。恢复的过程，即通过FTP协议将已备份到第三方FTP服务器的数据重新恢复到网元上的过程。

支持同时对多个不同类型的网元进行数据恢复。带有“-”标记，代表该网元不支持此功能。

注意：

将网元数据库文件恢复到网元前，必须确保待恢复的数据库文件正确，否则将导致业务中断。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作的网元，单击“恢复”。
  3. 在“板”下拉列表中选择需要进行数据恢复的主控板类型。

    说明：

    只有接入域网元支持此项配置。

    当同时恢复的网元中不包含接入域网元时，界面中将不会显示此配置项。

  4. 在“文件类型”下拉列表中，选择需要恢复的配置文件类型。

    说明：

    只有部分路由器/交换机支持此项配置。

    由于多数网元仅支持对一种类型的配置文件进行恢复，则对这些网元进行配置时，不需要选择此配置项。

    当同时恢复的网元都仅支持恢复一种类型的配置文件时，界面中将不会显示此配置项。

    当同时恢复的网元中不包含路由器/交换机时，界面中将不会显示此配置项。

  5. 在“文件名称”下拉列表中，选择已备份的文件。

    说明：

    缺省会选择该网元最后一次备份的文件。

    如果下拉列表中没有可选内容，可以在“文件名称”下拉列表中，选择“浏览”，可以指定网管服务器、客户端或第三方服务器，并在路径下选择备份文件。

    特例：对于通过代理网元与网元软件管理通信的网元，需要从第三方服务器上选择备份文件进行配置恢复。因此，需要在文本框中手工输入“文件名称”。输入时需要注意：
    • 备份时，备份的数据会生成在一个以时间命名的文件夹里面，恢复路径输入到以时间命名的文件夹即可。例如“20101216111922\vrpcfg.cfg”。
    • 文件名称中必须包含扩展名。
    • 输入的内容不能超过64个字符。

  6. 在“激活类型”下拉列表框中，选择需要的激活方式。

    说明：
    此处选择激活类型，但是不会执行激活操作。
    注意：

    选择立即重启、断业务等激活类型时会自动重启网元。网元重启时会中断业务，请谨慎操作。

    选项 描述

    不重启

    不自动重启网元。手工重启网元后完成数据恢复。

    立即重启

    立即重启网元。重启后完成数据恢复。

    路由器/交换机支持该激活类型。

    （中）断业务

    自动重启网元，重启时中断业务，重启后完成数据恢复。

    接入域网元支持该激活类型。
  7. 可选：当需要使业务单板也恢复上次备份的配置时，选中“下发配置到单板”复选框。

    说明：

    不选择此选项，仅对网元主控单板的配置信息进行恢复。由于网元单板当前的配置信息与恢复文件中的配置信息可能不一致，所以需要判断是否将备份的配置信息同时恢复到业务单板上。

    只有部分类型的传送域/PTN网元支持此项配置，对于不支持“下发配置到单板”功能的网元，请去选此配置选项。

  8. 单击“开始”。
  9. 在弹出对话框中，单击“是”。确认进行恢复操作。

操作结果

操作状态中显示恢复进度。操作完成后将显示恢复成功或失败。

后续处理

对于传送域/PTN网元，选择恢复文件后，需要对数据库进行激活，使网元数据库恢复成功。激活数据库的操作方法，请参见激活数据库。

父主题： 数据备份与恢复


保存网元数据

系统配置后，数据保存在网元内存中。通过保存操作将网元数据从网元内存保存到网元Flash或CF卡中，防止重启时丢失网元数据。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。

背景信息

传送域/PTN网元不支持保存操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择一个或多个网元，单击右键，选择“保存”。
  3. 在弹出对话框中，单击“开始”。

操作结果

“操作状态”显示操作进度。完成后，操作状态显示操作成功或失败。若操作失败，将在操作结果栏中显示失败原因。失败原因如果包含链接，可单击链接查看详细信息。

父主题： 数据备份与恢复


备份文件管理

介绍如何对备份到文件传输目录中的网元数据文件进行查看、比较、保存至本地目录、删除等操作。

  • 查看备份文件
    介绍如何查看保存在服务器上的网元备份文件。
  • 比较备份文件
    当网元上的配置数据发生了变化或进行升级后，为了解网元情况，需要比较服务器端同一网元或不同网元上两次备份文件的异同。
  • 与网元文件比较
    介绍如何比较备份文件与网元当前运行的配置文件。
  • 删除备份文件
    为保证网元软件管理所在计算机有充足的空间容纳新数据，需要及时删除网元上较旧的备份文件，以释放存储空间。
父主题： 数据备份与恢复


查看备份文件

介绍如何查看保存在服务器上的网元备份文件。

前提条件

  • 待操作网元支持该功能。
  • 已通过网元软件管理对网元文件进行了备份。

背景信息

本操作不适用于传送域/PTN网元。

对于接入域网元，只能查看配置文件，不能查看数据文件。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 从“网元视图”中选择一个网元，单击“备份信息”页签。

    说明：

    一次操作只能选择一个网元。当选择多个网元时，“备份信息”页签将不可用。

  3. 选择待查看的文件信息，单击右键，选择“查看文件”。
父主题： 备份文件管理


比较备份文件

当网元上的配置数据发生了变化或进行升级后，为了解网元情况，需要比较服务器端同一网元或不同网元上两次备份文件的异同。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中选择待操作网元。

    说明：

    如果选择了多个网元，“备份信息”页签不可用。

  3. 右键单击待比较的备份文件，在右键菜单中选择“选择左边的比较文件”。
  4. 右键单击其它待比较的备份文件。备份文件可以在同一网元或不同网元上。

    说明：

    可以进行比较的备份文件格式只能为.zip与.cfg。且两种格式的备份文件可以相互比较。

  5. 在快捷菜单上，选择“与左边文件比较”。

    说明：
    • 若操作成功，比较进度完成后，弹出对话框显示两个备份文件的比较结果。
      • 通过左上角显示的上下调节按钮，可以定位到上一条或下一条两侧文件的不同处。
      • 若两个文件的内容不同，用不同颜色突出显示。
    • 若不成功，系统将给出比较文件失败的提示信息。

父主题： 备份文件管理


与网元文件比较

介绍如何比较备份文件与网元当前运行的配置文件。

前提条件

  • 服务器上存在已经备份的配置文件。

背景信息

待比较的备份文件为配置文件，且文件格式只能为.cfg或.zip，才可以与网元文件比较。

传送域/PTN网元不支持此功能。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 从网元视图内选择网元，选择“备份信息”页签查看所选网元的备份文件。

    说明：
    如果选择了多个网元，“备份信息”页签不可用。

  3. 选择待比较的备份文件，单击右键，选择“与网元文件比较”。

    弹出“获取备份文件”进度条。获取网元配置文件成功后，进度条消失。如下图所示对话框中显示两个备份文件的比较结果。

    说明：

    通过左上角显示的上下调节按钮，可以定位到上一条或下一条两侧文件的不同处。

    系统会以醒目的颜色突出显示两个比较文件的不同点。

父主题： 备份文件管理


删除备份文件

为保证网元软件管理所在计算机有充足的空间容纳新数据，需要及时删除网元上较旧的备份文件，以释放存储空间。

背景信息

由于网元软件管理所在计算机能够存储的备份文件数目受限于文件传输目录所在磁盘空间的大小，建议定时删除较旧的备份文件。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中，选择一个网元，在下方窗格中单击“备份信息”页签。

    说明：

    如果同时选择了多个网元，“备份信息”页签不可用。

  3. 在“备份信息”页签中，选择一个或多个待删除的文件。
  4. 单击右键，选择“删除文件”。
  5. 在确认对话框中，单击“是”，删除备份文件。
  6. 单击“关闭”。
父主题： 备份文件管理


网元补丁管理

管理网元补丁功能包括：查看补丁信息、激活、去激活、确认、回滚、过滤和删除补丁。

补丁类型包括：冷补丁和热补丁。补丁状态包括：待激活状态、激活状态和去激活状态。

操作结果显示成功与失败。若操作失败，将在操作结果栏中显示失败原因。失败原因如果包含链接，可单击链接查看详细信息。

  • 获取补丁
    介绍如何查看一个或多个网元的补丁信息。
  • 激活补丁
    介绍如何激活已经加载到网元上的软件补丁。
  • 去激活补丁
    介绍如何使处于激活状态的补丁转变成去激活状态。
  • 确认补丁
    补丁激活后将处于试运行状态。通过确认补丁操作，使补丁正式运行。
  • 回滚补丁
    如果在补丁升级后，发现网元上的补丁版本存在问题，通过回滚补丁操作可以将网元恢复到补丁升级前的状态。
  • 过滤补丁
    介绍如何根据过滤条件对已经获取的补丁文件进行过滤。
  • 删除补丁
    若运行过程出现异常，需要删除补丁，使网元恢复到补丁升级前状态。
父主题： 网元软件管理


获取补丁

介绍如何查看一个或多个网元的补丁信息。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

同时对多个相同类型的网元进行操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中，选择一个或多个相同类型的网元，单击右键，选择“获取补丁”。弹出“获取补丁”对话框，如下图所示。

  3. 可选：单击“详细”，查看操作结果。

    说明：

    对于传送域/PTN网元，在“补丁视图”页签中，只能查看补丁信息，不能对补丁进行操作。

父主题： 网元补丁管理


激活补丁

介绍如何激活已经加载到网元上的软件补丁。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 补丁处于去激活（加载成功）状态。

背景信息

  • 加载成功后，补丁默认显示去激活状态。

  • 对于接入域网元，补丁之间存在依赖关系时，补丁号大的依赖于补丁号小的补丁。加载（补丁号）较大的补丁之前，必须先激活并确认（补丁号）较小的补丁，否则较大的补丁无法加载成功。

  • 传送域/PTN网元不支持激活补丁操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中，选择网元，单击“获取补丁”。操作细则可参考获取补丁。
  3. 在“补丁视图”页签内选择一个或多个补丁，单击右键，选择“激活补丁”。
  4. 在弹出的对话框中，单击“是”，激活选择的补丁。在“补丁视图”列表内显示操作状态。

    说明：

    对于接入域网元，如果是冷补丁，系统询问是否要重启网元。如果选择“否”，补丁变为待激活状态。网元重启后，补丁变为激活状态。

父主题： 网元补丁管理


去激活补丁

介绍如何使处于激活状态的补丁转变成去激活状态。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 补丁处于激活状态。

背景信息

对于接入域网元，补丁之间存在依赖关系时，补丁号大的依赖于补丁号小的补丁。加载（补丁号）较大的补丁之前，必须先激活并确认（补丁号）较小的补丁，否则较大的补丁无法加载成功。

传送域/PTN网元不支持去激活补丁操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作网元，单击“获取补丁”。操作细则可参考获取补丁。
  3. 在“补丁视图”页签内选择一个或多个补丁，单击右键，选择“去激活”。
  4. 在弹出的对话框中，单击“是”，在“补丁视图”列表内显示操作状态。
父主题： 网元补丁管理


确认补丁

补丁激活后将处于试运行状态。通过确认补丁操作，使补丁正式运行。

前提条件

  • 补丁处于激活状态。
  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

对于接入域网元，补丁分为热补丁和冷补丁。其中，冷补丁需要重新启动网元后才会被激活。

对于接入域网元，补丁之间存在依赖关系时，补丁号大的依赖于补丁号小的补丁。加载（补丁号）较大的补丁之前，必须先激活并确认（补丁号）较小的补丁，否则较大的补丁无法加载成功。

传送域/PTN网元不支持此功能。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作网元，单击“获取补丁”。操作细则可参考获取补丁。
  3. 在“补丁视图”页签内，选择一个或多个补丁，单击右键，选择“确认”。
  4. 在弹出对话框内，单击“是”，对所选的网元上处于激活态补丁进行确认。

    • 如果操作成功，补丁状态变为运行，该状态显示在“补丁视图”列表中。
    • 对于接入域网元，如果是冷补丁且补丁状态为待激活，系统询问是否要重启网元。如果选择“否”，补丁状态变为“待运行”。网元重启后，补丁运行。

父主题： 网元补丁管理


回滚补丁

如果在补丁升级后，发现网元上的补丁版本存在问题，通过回滚补丁操作可以将网元恢复到补丁升级前的状态。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。
  • 对接入域网元，执行回滚补丁操作无限制。对传送域/PTN网元，补丁未运行前可以执行回滚补丁操作；补丁运行后，不可执行回滚补丁操作。
  • 回滚操作只针对热补丁。

背景信息

传送域/PTN网元和接入域网元支持此功能。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择一个或多个同类型网元，单击右键，选择“回滚补丁”。
  3. 在“操作确认”对话框中，单击“是”，执行补丁回滚。

操作结果

“网元视图”列表中，将显示回滚操作状态。

父主题： 网元补丁管理


过滤补丁

介绍如何根据过滤条件对已经获取的补丁文件进行过滤。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作网元，单击“获取补丁”。操作细则可参考获取补丁。
  3. 在“补丁视图”列表中，单击“过滤”。
  4. 可选：在弹出的对话框中，若出现“单板树”，请勾选需要的单板类型。
  5. 根据需要设置过滤条件，如下图所示。

  6. 单击“确定”。

操作结果

“补丁视图”列表中，将显示符合过滤条件的补丁。

父主题： 网元补丁管理


删除补丁

若运行过程出现异常，需要删除补丁，使网元恢复到补丁升级前状态。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

对于接入域网元，补丁之间存在依赖关系时，补丁号大的依赖于补丁号小的补丁。删除（补丁号）较小的补丁时，依赖于它的补丁会同时被删除。

对于传送域/PTN网元，补丁运行后，不可执行回滚补丁操作。而如果此时网元升级出现异常，可以删除补丁，使网元恢复到补丁升级前状态。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中，选择网元，单击“获取补丁”。操作细则可参考获取补丁。
  3. 在“补丁视图”中，选择一个或多个删除的补丁，单击右键，选择“删除”。

    说明：
    • 对于热补丁，补丁被直接删除。
    • 对于冷补丁，根据补丁状态的不同，操作存在差异。
      • 当补丁处于激活或运行状态，在弹出的“确认补丁操作”对话框中：
        • 单击“否”，补丁变为待删除状态。待网元重启后，补丁被删除。
        • 单击“是”，网元立即重启，补丁被删除。
      • 当补丁处于其他状态，单击“删除”后，补丁直接被删除。

父主题： 网元补丁管理


网元日志管理

通过本章内容，您将了解如何查看、删除网元软件管理对网元的操作日志，以及如何备份网元的安全日志和操作日志。

  • 查看日志信息
    介绍如何通过设置自定义过滤选项的方式查看日志信息。
  • 删除日志
    删除不需要的日志可以释放网管服务器磁盘空间。本节介绍如何删除日志。
  • 备份网元日志到本地服务器
    为确保网元安全日志和操作日志的可靠性，可以定期将日志备份到本地计算机上。
  • 备份网元日志到远程服务器
    为确保网元安全日志和操作日志的可靠性，可以定期将日志备份到远程计算机上。
父主题： 网元软件管理


查看日志信息

介绍如何通过设置自定义过滤选项的方式查看日志信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元软件日志管理”。
  2. 缺省显示最近24小时的日志信息。若需要查看特定日志信息，可进行如下操作，3到11。
  3. 单击“过滤器”，弹出“过滤日志”对话框。

  4. 从“网元类型”下拉列表框中，选择网元类型。缺省网元类型为“所有”。
  5. 在“网元选项”区域，对日志信息进行过滤，参见表1。

    表1 过滤操作(1)
    选择项目 | 操作
    如果选择了“网元名称” | 输入网元名称对日志信息进行过滤
    如果选择了“IP地址” | 输入网元IP地址对日志信息进行过滤

  6. 在“用户选项”区域，输入客户端用户名称对客户端日志信息进行过滤；或输入127.0.0.1 做为客户端IP地址对日志信息进行过滤。
  7. 在“高级选项”区域，选择“成功”或“失败”复选框对日志进行过滤。

    如果选择了“成功”复选框，过滤出操作成功的日志。

  8. 从“操作类型”下拉列表中，选择要过滤的操作类型。缺省操作类型为“所有”。
  9. 可以在下拉列表中选择从“第一条日志”开始过滤，或者从自定义的“开始时间”进行过滤，参见表2

    表2 过滤操作(2)
    选择项目 | 操作
    如果选择从“第一条日志”开始过滤 | 则直接进入10
    如果选择从自定义的“开始时间”进行过滤 | 则在微调框中设置起始时间

  10. 可以在下拉列表中选择过滤操作到“最后一条日志”结束，或者到自定义的“结束时间”结束，参见表3。

    表3 过滤操作(3)
    选择项目 | 操作
    如果选择过滤操作到“最后一条日志”结束 | 则直接进入11
    如果选择过滤操作到自定义的“结束时间”结束 | 则在微调框中设置结束时间
    说明：

    过滤日志操作的起止条件可以交叉选择。例如，可以设置从“第一条日志”开始，到“结束时间”结束。

    所设置的“开始时间”和“结束时间”必须要早于当前时间。

  11. 单击“确定”，在“网元软件日志管理”页签中查看过滤出的日志信息。
父主题： 网元日志管理


删除日志

删除不需要的日志可以释放网管服务器磁盘空间。本节介绍如何删除日志。

背景信息

  • 可以同时对多条日志信息进行删除。
  • “网元日志管理”页签下，需要输入过滤条件，才能对网元日志进行操作。详细信息请参见查看日志信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元软件日志管理”。
  2. 单击“过滤器”，输入过滤条件，查看指定范围内的日志。
  3. 在已过滤出的日志列表中选择一条或多条日志信息，单击右键，选择“删除”。
  4. 在弹出对话框中，单击“是”。
父主题： 网元日志管理


备份网元日志到本地服务器

为确保网元安全日志和操作日志的可靠性，可以定期将日志备份到本地计算机上。

前提条件

  • 已创建相应网元。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。

背景信息

网元安全日志记录的信息包括：查询网元登录信息、删除网元用户、强制网元用户退出登录状态等操作。

只有传送域/PTN网元支持此功能。

操作步骤

  1. 在菜单中选择“备份网元日志 > 备份网元日志”，功能树中将显示已添加的网元。
  2. 单击 [image] 更新网元列表。如果待操作网元不在网元列表中，创建网元并显示在功能树中。
  3. 登录待操作网元。
  4. 选中待操作网元前的复选框，单击 [image] ，操作列表中出现待操作网元的相关信息。
  5. 在操作列表中选中待操作网元，在参数框“协议”中选择本操作所使用的协议。
  6. 在“日志类型”参数框中选择“安全日志”或“操作日志”。
  7. 在参数框“文件”中单击右键，选择“选择文件”，在弹出的对话框中选择文件的备份路径。

    说明：
    • 如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。
    • 备份网元日志到本地服务器时，不要选中“FTP/SFTP Server上的文件”单选框，选中则表示备份网元日志到远程服务器。

  8. 单击“开始”，开始备份，网元状态显示为“复制态”，备份结束后网元显示为“正常态”。
父主题： 网元日志管理


备份网元日志到远程服务器

为确保网元安全日志和操作日志的可靠性，可以定期将日志备份到远程计算机上。

前提条件

  • 已创建相应网元。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 待操作网元支持该功能。

背景信息

网元安全日志记录的信息包括：查询网元登录信息、删除网元用户、强制网元用户退出登录状态等操作。

只有传送域/PTN网元支持此功能。

操作步骤

  1. 在菜单中选择“备份网元日志 > 备份网元日志”，功能树中将显示已添加的网元。
  2. 单击 [image] 更新网元列表。如果待操作网元不在网元列表中，创建网元并显示在功能树中。
  3. 登录待操作网元。
  4. 选中待操作网元前的复选框，单击 [image] ，操作列表中出现待操作网元的相关信息。
  5. 在操作列表中选中待操作网元，在参数框“协议”中选择本操作所使用的协议。
  6. 在“日志类型”参数框中选择“安全日志”或“操作日志”。
  7. 在参数框“文件”中单击右键，选择“选择文件”，弹出“选择文件”对话框。
  8. 选中“FTP/SFTP Server上的文件”单选框，输入远程服务器上正确的FTP服务器地址、用户名称、密码和端口，单击 [image] ，连接成功后即可访问FTP Server上的文件。

    说明：
    • 如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。
    • 如果使用的是有多网卡多IP地址的机器，FTP服务器IP与本机IP必须选择在同一网段上，否则可能连接不正常，导致获取文件列表失败。
    • 为了安全，建议使用SFTP协议。

  9. 单击“开始”，开始备份，网元状态显示为“复制态”，备份结束后网元显示为“正常态”。
父主题： 网元日志管理


管理网元License

申请安装网元License后，您可以获得相应的网元功能使用权。网元License管理包括了对网元License的查询、申请、安装、调整容量和变更。由于License控制了网元的使用期限或功能，通过查看网元License的状态并及时更换将过期的License，可以避免License过期对业务产生的影响。

  • 了解网元License管理
    对网元License管理场景的介绍，有助于您了解不同场景下网元License管理的操作步骤；对网元License各种状态的解释说明，能帮助您判断处于各种状态的License是否满足业务需要。
  • 查询网元License信息
    通过查询网元License信息可以了解网元License所处的状态，找出需要维护的网元License。
  • 申请网元License
    安装网元时，为了保证网元功能可以正常使用，需要导出网元申请信息，用于申请网元License。
  • 安装网元License
    网元安装有效的License文件后，才可以使用相关功能。
  • 同步网元信息
    将网元的“ESN”和“License信息”上传给网管。当网元接入到网管，或者由于网元和网管之间的网络由断连恢复正常通信时使用“同步网元信息”。
  • 调整网元License容量
    通过调整网元License容量可以提高License利用率，减少运营商的运维成本。
  • 变更网元License
    在网元的ESN(Equipment Serial Numbers)发生变化或将License调整给其他网元使用时，需要变更网元License。
  • 备份RTN网元License文件
    对于使用License进行管理的网元，为防止网元发生故障时License丢失，需要对License进行备份。建议在网元更新License之后立即对License进行备份。
  • 加载RTN网元License文件
    网元上的License文件可能会因为网元发生故障等原因而丢失或不可用，这时就需要将先前备份的License文件恢复到网元上去。需要更新网元License文件时，也要使用加载网元License功能。
父主题： 网元软件管理


了解网元License管理

对网元License管理场景的介绍，有助于您了解不同场景下网元License管理的操作步骤；对网元License各种状态的解释说明，能帮助您判断处于各种状态的License是否满足业务需要。

网元License操作场景

当用户新申请一个网元License，可以进行查询网元License、安装网元License、调整网元License和变更网元License等操作。

网元License状态

网元License有五六种状态。在维护网元License之前，您需要先熟悉每种状态。 网元License状态如表1所示。

表1 网元License状态
状态 | 说明
缺省状态 | 网元以License控制项的最小配置运行，已有的网元License功能可以正常使用，不允许新添加网元License功能。
调测状态 | 调测网元时申请的网元License，其状态为调测状态。在调测状态下，可以一定的时间内正常使用网元各项功能。License过期后，将影响正常使用，请在License到期前申请商用License。
正常状态 | 在正常状态下可以正常使用网元License中包含的资源和功能。
保护期状态 | 在网元License已经过期情况下，为了预留时间申请新的License，License会在一段时间内处于保护期。此时网元License中的各个控制项仍然可以用。
紧急状态 | 在救灾等紧急状态下，网元License可以设为紧急状态。在紧急状态中，网元的License控制将被解除，容量取设备最大配置，从而保护网元业务不受损失。 说明： 当进入网元License紧急状态需要联系华为技术支持工程师进行操作。
试用状态 | 在试用状态下，设备可以继续使用网元License文件中的资源和功能授权。该状态的产生主要由于网元License文件正确性校验失败导致，可缺省保持60天，称为“保活期”。
父主题： 管理网元License


查询网元License信息

通过查询网元License信息可以了解网元License所处的状态，找出需要维护的网元License。

背景信息

  • 网元License状态将影响网元License各项功能的正常使用。

  • 执行该操作前，请同步网元信息。具体操作请参见同步网元信息。

操作步骤

  1. 在“网元License管理”导航树上，单击“查询License信息”。
  2. 单击“过滤”。

    说明：
    • 启动网管客户端后，第一次打开“网元License管理”窗口缺省弹出“过滤”对话框，便于用户设置过滤条件。
    • 在“网元License管理”窗口中，选择左侧导航树中的“查询License信息”，单击“过滤”打开“过滤”对话框。

  3. 在“过滤”对话框“License状态”区域框中选择所要查询的License状态；在“版本选择”下拉列表中选择所要查询的网元软件版本。
  4. 在“设备”区域框中单击“选择”。
  5. 在“选择网元”对话框中的“待选设备”区域框，单击“版本选择”下拉列表，选择所需查询的网元软件版本。使用 [image] 、 [image] 、 [image] 、 [image] 在“待选设备”列表框和“已选设备”列表框间选择或移除设备，单击“确定”。
  6. 在“过滤”对话框中，单击“确定”。
  7. 在License列表中查看License对应的“网元名称”、“网元描述”、“网元类型”、“版本”、“ESN”、“License状态”。

    说明：
    • 选择一条网元License的记录，在“详细信息”区域框中可以查看“运行商索引”、“运行商名称”、“License项”、“License项描述”、“分配值”。
    • 选择一条或多条网元License查询记录，单击右键，选择“导出选中记录”或“导出全部记录”，可以保存所查询网元的License详细信息到本地。用户可以将文件保存为“.xml”的格式。

父主题： 管理网元License


申请网元License

安装网元时，为了保证网元功能可以正常使用，需要导出网元申请信息，用于申请网元License。

前提条件

执行该操作前，请同步网元信息，具体操作请参见同步网元信息。

操作步骤

  1. 在“网元License管理”导航树上，选中“网元License维护”。在“网元License管理”窗口中单击“导出网元申请信息”。
  2. 在“导出网元申请信息”对话框中单击“选择”。
  3. 在“选择网元”对话框中选择网元。
    1. 在“待选设备”区域框单击“版本选择”下拉列表，选择所需的网元软件版本。
    2. 在“选择网元”对话框中，使用 [image] 、 [image] 、 [image] 、 [image] 在“待选设备”列表框和“已选设备”列表框间设置选择网元。完成操作后在“选择网元”对话框中单击“确定”。
  4. 单击“选择导出文件”文本框后的 [image] 。在“保存”对话框中设置网元License申请信息的存放文件名及文件存放位置，单击“保存”。用户可以将文件保存为“.xml”格式。
  5. 在“导出网元申请信息”对话框中，单击“确定”。

    说明：

    执行所有操作后，如果没有任何文件输出，可能是因为主任务下的子任务没有全部执行成功。可以展开主任务节点，查看子任务执行失败的原因。

    “网元License维护”页面对应的表格中将显示任务类型为“导出网元申请信息”的任务记录。
    说明：
    对该类型任务的记录可以做如下操作：
    • 删除操作：当主任务的“执行状态”为100%，选中主任务单击右键菜单选择“删除记录”。
    • 重试操作：当子任务的“执行状态”为“执行失败”或“执行超时”时，选中该子任务单击右键菜单选择“重试”可重新执行该任务。
    • 导出结果操作：当子任务的“执行状态”为“执行成功”时，选中主任务单击右键菜单选择“导出结果”可将该任务中指定的网元的License信息导出到xml文件中。
  6. 请将导出的网元申请信息发给华为技术支持工程师，由其进行申请网元License的操作。
父主题： 管理网元License


安装网元License

网元安装有效的License文件后，才可以使用相关功能。

前提条件

  • 本地主机上已存放由华为技术支持工程师申请成功的网元License文件。

  • 执行该操作前，请同步网元信息，具体操作请参见同步网元信息。

  • NAT组网场景下，执行该操作前，请配置NAT转换信息。具体操作请参见网管帮助“配置NAT地址转换（NAT组网）”页面。

操作步骤

  1. 在“网元License管理”导航树上，单击“网元License维护”。
  2. 单击“加载License文件”。
  3. 在“加载License文件”对话框中，单击 [image] 。
  4. 在“打开”对话框中，根据加载License文件方式(单个或批量)选择License文件，并加载到指定的网元。

    License文件格式

    加载方式

    操作

    TXT或DAT

    单个
    如果网管无法自动识别License匹配的网元，可以手动调整License文件匹配的网元。
    1. 在“加载License文件”对话框右侧，单击 [image] ，选择txt或dat格式的License文件。
    2. 在“选择网元”中，调整“版本选择”下拉列表框中的版本。
      1. 单击 [image] 、 [image] 、 [image] 、或 [image] ，调整“已选设备”区域框中的设备。单击“确定”。
      2. 在“加载License文件”对话框中，单击“完成”。

    zip

    批量
    1. 在“加载License文件”对话框右侧，单击 [image] ，选择zip格式的License文件。
    2. 在“加载License文件”对话框中，勾选待加载的License文件前的复选框，单击“下一步”。
    3. 单击“完成”。
    说明：

    在匹配网元步骤，“加载License文件”对话框中右侧显示匹配的License文件列表。

操作结果

  1. “网元License维护”页面对应的表格中将显示任务类型为“加载License文件”的任务记录。
    说明：
    对该类型任务的记录可以做如下操作：
    • 删除操作：当主任务的“执行状态”为100%，选中主任务单击右键菜单选择“删除记录”。
    • 重试操作：当子任务的“执行状态”为“执行失败”或“执行超时”时，选中该子任务单击右键菜单选择“重试”可重新执行该任务。
    • 强制执行操作：当子任务的“执行状态”为“轻微错误”时，选中该子任务单击右键菜单选择“强制执行”可忽略轻微错误并强制执行任务。
  2. 展开“加载License文件”的任务记录。
    • 如果子任务的“执行状态”为“执行成功”或“轻微错误”，则License文件会按照“lic_设备的ESN_yyMMddHHmmss_索引.文件扩展名”命名方式保存在网元内，文件扩展名为DAT或TXT。例如：设备的ESN为2102112729T9C004297，License文件在2012年5月15日10:40:31加载成功，则它在网元内的文件名为“lic_2102112729T9C004297_120515104031_0.dat”或“lic_2102112729T9C004297_120515104031_0.txt”。同时为多个网元加载License文件，索引取值从0开始，每成功加载License文件到一个网元该取值加1。
    • 如果子任务的“执行状态”为“执行失败”或“执行超时”，表示License文件加载失败，需要先定位和排除故障，然后重新加载网元license文件。
父主题： 管理网元License


同步网元信息

将网元的“ESN”和“License信息”上传给网管。当网元接入到网管，或者由于网元和网管之间的网络由断连恢复正常通信时使用“同步网元信息”。

操作步骤

  1. 在“网元License管理”导航树上，选择“网元License维护”。
  2. 单击“同步网元信息”。
  3. 在“同步网元信息”对话框中，单击“选择”。
  4. 在“选择网元”对话框中，设置需要同步网元信息的设备，单击“确定”。

    说明：

    设置已选设备：在“选择网元”对话框中，单击 [image] 、 [image] 、 [image] 、 [image] ，调整“待选设备”区域框中的网元。

  5. 在“同步网元信息”对话框中，单击“确定”同步网元信息。

操作结果

“网元License维护”页面对应的表格中将显示任务类型为“同步网元信息”的任务记录。
说明：
对该类型任务的记录可以做如下操作：
  • 删除操作：当主任务的“执行状态”为100%，选中主任务单击右键菜单选择“删除记录”。
  • 重试操作：当子任务的“执行状态”为“执行失败”或“执行超时”时，选中该子任务单击右键菜单选择“重试”可重新执行该任务。
父主题： 管理网元License


调整网元License容量

通过调整网元License容量可以提高License利用率，减少运营商的运维成本。

前提条件

  • 由华为技术支持工程师提供有效的网元License。

  • 执行该操作前，请同步网元信息。具体操作请参见同步网元信息。

背景信息

  • 网管支持将不同网元间的License容量互相调换，例如运营商拥有的网元A和网元B中License控制的容量均为50个，根据业务需要，网元B中需要调整为80个，而网元A中只需要使用20个。在运营商拥有的License容量不变的情况下，使用调整网元License容量的功能可以将网元A中多余的License调换给网元B使用。
  • 在调整网元License容量时，会先将原License设置为失效状态，再应用新网元的License才能调整成功。

操作步骤

  1. 在“网元License管理”导航树上，单击“网元License维护”。
  2. 单击“调整License容量”，在弹出“确认”提示框中单击“是”。
  3. 在“调整License容量”对话框中，单击“选择”。在“选择网元”对话框中，将网元设备移动到“已选设备”区域框中，表明选中了调整License的网元。单击“确定”。
  4. 单击“选择导出文件”文本框后的 [image] 。在“保存”对话框中设置网元License申请信息的存放文件名及文件存放位置，单击“保存”。用户可以将文件保存为“.xml”格式。
  5. 在“调整License容量”对话框中，单击“选择导出文件”右侧的 [image] ，设置待保存的文件名，保存网元License的信息。单击“确定”。

    说明：
    • 执行所有操作后，如果没有任何文件输出，可能是因为主任务下的子任务没有全部执行成功。可以展开主任务节点，查看子任务执行失败的原因。
    • 导出的文件为网元License的信息，该信息在申请新的网元License时需要使用。

    “网元License维护”页面对应的表格中将显示任务类型为“调整license容量”的任务记录。
    说明：
    对该类型任务的记录可以做如下操作：
    • 删除操作：当主任务的“执行状态”为100%，选中主任务单击右键菜单选择“删除记录”。
    • 重试操作：当子任务的“执行状态”为“执行失败”或“执行超时”时，选中该子任务单击右键菜单选择“重试”可重新执行该任务。
    • 导出结果操作：当子任务的“执行状态”为“执行成功”时，选中主任务单击右键菜单选择“导出结果”可将该任务中指定的网元的License信息导出到xml文件中。
  6. 在“网元License维护”窗口中，单击“加载License文件”，将新申请的网元License加载到U2000。具体请参见License。
父主题： 管理网元License


变更网元License

在网元的ESN(Equipment Serial Numbers)发生变化或将License调整给其他网元使用时，需要变更网元License。

前提条件

执行该操作前，请同步网元信息。具体操作请参见同步网元信息。

操作步骤

  1. 失效原网元License。
    1. 在主菜单中选择“系统 > 网元License管理”。
    2. 在“网元License管理”导航树上，单击“网元License维护”。
    3. 单击“失效License”。
    4. 在“确认”提示框中，确认需要执行失效网元License操作。单击“是”。
    5. 在“失效License”对话框中，单击“选择”，在“选择网元”中，调整“版本选择”下拉列表框中的版本。
    6. 单击 [image] 、 [image] 、 [image] 、 [image] ，调整“已选设备”区域框中的设备。单击“确定”。
    7. 单击“选择导出文件”文本框后的 [image] 。在“保存”对话框中设置网元License申请信息的存放文件名及文件存放位置，单击“保存”。用户可以将文件保存为“.xml”格式。

      网元失效的信息将导出在该文件中。

    8. 在“失效License”对话框中，单击“确定”。

      说明：

      执行所有操作后，如果没有任何文件输出，可能是因为主任务下的子任务没有全部执行成功。可以展开主任务节点，查看子任务执行失败的原因。

      “网元License维护”页面对应的表格中将显示任务类型为“失效License”的任务记录。
      说明：
      对该类型任务的记录可以做如下操作：
      • 删除操作：当主任务的“执行状态”为100%，选中主任务单击右键菜单选择“删除记录”。
      • 重试操作：当子任务的“执行状态”为“执行失败”或“执行超时”时，选中该子任务单击右键菜单选择“重试”可重新执行该任务。
      • 导出结果操作：当子任务的“执行状态”为“执行成功”时，选中主任务单击右键菜单选择“导出结果”可将该任务中指定的网元的License信息导出到xml文件中。
  2. 申请新的网元License。请将导出失效网元License文件发给华为技术支持工程师，由其进行申请网元License的操作。

    说明：

    原有的网元License处于失效状态，有对应的网元License失效文件才可以申请新的网元License。

  3. 安装新的网元License。具体请参见安装网元License。
父主题： 管理网元License


备份RTN网元License文件

对于使用License进行管理的网元，为防止网元发生故障时License丢失，需要对License进行备份。建议在网元更新License之后立即对License进行备份。

前提条件

  • 已经创建网元。
  • 待操作网元支持该功能。
  • 网元软件管理所在计算机与网元间通讯正常。

操作步骤

  1. 在主菜单中选择“License管理 > RTN License管理”，导航树中将显示已添加的网元。
  2. 单击 [image] 更新网元列表。如果待操作网元不在网元列表中，创建网元并显示在功能树中。
  3. 登录待操作网元。
  4. 选中待操作网元前的复选框，单击 [image] ，操作列表中出现待操作网元的相关信息。
  5. 在参数框“备份/加载”中选择“备份”。
  6. 单击参数框“文件”中的 [image] ，在弹出的对话框中选择文件备份路径。

    说明：
    • 备份路径只能包含字母或者数字，不能有其他种类的字符，否则会导致无法读取备份文件。
    • 备份网元License到本地服务器时，不要选中“FTP Server上的文件”单选框，选中则表示备份网元License到远程服务器。

  7. 单击“开始”。网元软件管理将网元的License文件复制到指定路径下，并创建名为“NE-Name_license.lcs”的文件，其中NE-Name表示网元名称。例如：NE3500_license.lcs。
父主题： 管理网元License


加载RTN网元License文件

网元上的License文件可能会因为网元发生故障等原因而丢失或不可用，这时就需要将先前备份的License文件恢复到网元上去。需要更新网元License文件时，也要使用加载网元License功能。

前提条件

  • 已经创建网元。
  • 已经准备待加载的License文件。
  • 待操作网元支持该功能。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 待加载License文件中ESN必须与网元ESN匹配。

背景信息

加载License成功后，网元会自动激活License文件。激活过程中网元会对待加载的License文件进行校验，如果发现待加载的License文件权限小于当前正在使用的License文件权限，则会上报网元软件管理。网元软件管理弹出是否更新License提示框，由用户确认加载操作是否继续。

如果用户选择继续，则新的License会替换掉网元上正在使用的License。如果用户选择取消或15分钟内不予选择，加载操作将会中止并开始回滚，网元上License文件不更新。

操作步骤

  1. 在主菜单中选择“License管理 > RTN License管理”，导航树中将显示已添加的网元。
  2. 单击 [image] 更新网元列表。如果待操作网元不在网元列表中，创建网元并显示在功能树中。
  3. 登录待操作网元。
  4. 选中待操作网元前的复选框，单击 [image] ，操作列表中出现待操作网元的相关信息。
  5. 在参数框“备份/加载”中选择“加载”。
  6. 单击参数框“文件”中的 [image] ，在弹出的对话框中选择需要加载的License。

    说明：
    • 如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。
    • 备份网元License文件到本地服务器时，不要选中“FTP Server上的文件”单选框，选中则表示从远程服务器加载License。

  7. 单击“开始”。
  8. 在弹出提示框中选择“是”，网元软件管理开始加载操作。

    说明：
    • 加载操作开始后，网元状态切换为“复制态”。复制成功后，切换为“正常态”。
    • 如果用户在加载过程中弹出的提示框中选择了取消操作，网元软件管理会开始回滚操作，网元状态切换到“回滚态”。
    • 如果加载或回滚失败，网元状态切换为“异常态”。如果加载失败，可尝试重新加载。如果回滚失败，请联系华为技术工程师。

父主题： 管理网元License


终端工具

介绍如何使用终端工具登录网元，可以使用命令行对网元进行操作。

操作步骤

  1. 有三种方式，请选择执行。
    • 网元已经添加到网元软件管理中，即在网元列表中存在该网元。
      1. 在主菜单中选择“系统 > 网元软件管理 > 网元数据备份/恢复”（传统风格）或在“应用中心”中选择“固网网元软件管理”，再选择“网元软件管理 > 网元数据备份/恢复”（应用风格）。
      2. 在网元列表中，选择所需网元，单击右键，在右键菜单中选择“终端工具”。
    • 网元未添加到网元软件管理中，即在网元列表中不存在该网元。
      1. 在主菜单中选择“系统 > 终端系统”。
      2. 在弹出对话框中，选择“接口协议”，输入网元的IP地址、端口号。
      3. 单击“确定”。
    • 在执行任务时，如果激活步骤前暂停，可以选择所需要的网元，单击右键，选择“终端工具”。
  2. 在终端工具命令窗口中，对网元进行操作。

后续处理

在终端工具窗口，单击左键选择所需的命令，可以拷贝命令。在所需位置处单击右键，可以粘贴命令。
父主题： 网元软件管理


TL1命令行

介绍如何使用网元软件管理的TL1命令行终端对SONET网元进行管理。

  • TL1命令行概述
    网元软件管理提供对SONET网元的命令行管理功能，使用TL1命令行可直接对网元下发命令，使其完成相应操作或进行参数设置。
  • 执行TL1命令
    对于SONET网元，可以通过下发TL1命令方式对其进行操作和管理。
父主题： 网元软件管理


TL1命令行概述

网元软件管理提供对SONET网元的命令行管理功能，使用TL1命令行可直接对网元下发命令，使其完成相应操作或进行参数设置。

TL1概述

TL1，即Transaction Language 1，是一种事务处理语言。在电信领域广泛应用于机器-机器（OS/NE）之间的接口，特别是在北美市场，它被用来管理众多的宽带和接入产品，包括SONET/SDH、ATM/ISDN等网元。TL1作为一种语言，在OS/NE的应用中常采用字符流模式，一般采用TCP/IP协议，支持串口、X.25、网口连接。

TL1终端

网元软件管理可以作为TL1终端管理网元，TL1终端界面被划分为三个区：导航树、消息输入区和消息输出区。
  • 导航树：显示当前被网元软件管理管理的网元。
  • 消息输入区：显示用户输入的命令信息。
  • 消息输出区：显示来自网元的信息，包括如下三种：
    • 确认消息
    • 应答消息
    • 网元自发信息

输入命令信息

输入命令消息是指由用户在输入区下发的命令。命令格式一般为command_code:staging_parameter_blocks:message_payload_block。
  • Command_code：描述网元收到输入消息以后应该采取的行为和动作。
  • Staging_parameter_blocks：标识网元内部的一个将被远程管理系统所监控的对象实体，同时描述该命令在网元上如何执行。
  • Message_payload_block：消息净负荷，描述消息的主要内容，可以为空。

确认消息

确认消息是对输入命令消息简单的输出响应。通常情况下，一个确认消息的后面都会紧跟着针对输入命令消息的一个响应消息。但是在有些情况下，确认消息是一个命令输入的唯一输出。当一条输入命令的响应消息不能在2秒钟之内反馈回来的时候，应该发送一条确认消息。用户可通过命令打开或关闭“网元上是否发送确认消息”的开关。

应答消息

应答消息也即响应消息，是由网元发出的对输入命令的反馈信息，通常情况下会跟随在确认消息之后返回。

网元自发消息

网元自发消息是指由网元主动发送给管理系统的信息。典型的网元自发消息有：
  • 上报告警或非告警的紧急事件
  • 上报一些对网元的预定的诊断性测试
  • 上报性能检视数据
  • 上报网元数据库数据的改变
  • 周期性上报满足设置条件的信息
父主题： TL1命令行


执行TL1命令

对于SONET网元，可以通过下发TL1命令方式对其进行操作和管理。

前提条件

  • 已创建相应网元。
  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

消息内容不可以编辑，但可以进行查找、清除和保存等操作。

网元软件管理在长期运行的情况下，产生的消息数量会很多。为了保证历史消息不被覆盖、不丢失，需要一个能把窗口中数据转存到文件中的功能。网元软件管理会自动保存消息内容在\client\log\tklog目录下。

操作步骤

  1. 在主菜单中，选择“板极软件管理 > TL1命令行终端”，打开“TL1命令行终端”页签。
  2. 单击 [image] 刷新网元列表。右键单击待登录的网元，选择“登录”，登录待操作网元。
  3. 选中待操作网元前的复选框，单击 [image] ，选中的网元被添加至右边窗格中，每个网元对应独立的页签。
  4. 在命令输入区输入脚本命令，运行该脚本，消息显示区显示执行脚本的成功信息。

    说明：
    根据运行脚本的范围不同，分别执行如下操作：
    • 执行当前脚本时，将光标移到该脚本，按“Enter”键。
    • 执行部分脚本时，选中要执行的部分脚本，单击右键，选择“运行选择脚本”。
    • 执行所有脚本时，单击右键，选择“运行”。

父主题： TL1命令行


网元管理

在网元软件管理中，网元是最基本的操作对象。对网元进行操作前，首先要添加网元至网元列表。通过以下几节的讲述，您将了解通过网元软件管理可以对网元进行哪些基本操作，以及如何管理网元信息。

  • 查询网元版本
    在进行升级/降级操作前，通过查询网元版本，可以了解网元当前运行的版本信息。
  • 查看软件统计报告
    通过查看软件统计报告，可了解网元信息、对应的单板信息及软件信息。
  • 配置脚本文件
    通过网元软件管理，可以将自定义的脚本文件加载到网元上，使配置信息在网元上生效。
  • 删除网元文件
    日常维护中，为保证网元有充足的空间容纳新数据，可定期删除网元上无用的旧文件，以释放网元的存储空间。
  • 删除映像程序
    介绍通过网元软件管理如何删除网元上不需要的映像程序，以释放网元上的存储空间。
  • 设置OSPF状态
    包扩散升级中，网元软件管理需要根据网元上的路由关系计算出软件包的扩散路径，因此网元必须开启动态路由功能。待升级完成后，网元可以根据需要将路由功能关闭。本节介绍如何在网元上设置OSPF状态。
  • 回滚软件
    对于UA5000PVM网元，进行升级/降级后，通过回滚软件操作，可以使网元软件回退到升级/降级前状态。
  • 导出网元
    导出已创建的网元列表，在独立部署的升级软件中可以批量创建网元。
  • 导出网元模板
    批量创建网元时，需要导入含有网元信息且格式固定的文件。本节介绍如何获取网元模板，通过自定义编辑，可用于批量导入网元。
  • 保存网元列表
    介绍如何将“网元视图”中的网元列表保存至网元软件管理所在计算机上。
  • 导出自定义检测项模板
    对于支持该功能的路由域网元和交换机网元升级时，可以自定义检测项，了解网元状态。将自定义检测项模板导出后，用户可以在模板中填写检测项，以后在创建任务时，就可以将该模板导入，无需再次输入自定义检测项，提高升级效率。
父主题： 网元软件管理


查询网元版本

在进行升级/降级操作前，通过查询网元版本，可以了解网元当前运行的版本信息。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

在网元类型树中选择类型节点，“网元视图”将显示该类型下的所有网元及相应的网元信息。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中，选择一个或多个网元，单击“获取版本”。
  3. 单击“关闭”。

操作结果

  • 如果操作成功，“网元视图”和网元类型树中的版本信息显示为最新获取到的网元版本。
  • 若操作失败，将在操作结果栏中显示失败原因。失败原因如果包含链接，可单击链接查看详细信息。
父主题： 网元管理


查看软件统计报告

通过查看软件统计报告，可了解网元信息、对应的单板信息及软件信息。

前提条件

  • 待操作网元支持该功能。
  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

此功能只适用于传送域/PTN网元。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 右键单击待查询的网元，选择“软件统计”。
  3. 待进度条信息显示“操作完成”后，单击“显示软件统计”，查看统计信息。

    说明：

    通过单击“软件统计”对话框左上角三个按钮，可以实现对软件统计报告进行保存、预览和打印。

  4. 查询完成后，单击“关闭”。
父主题： 网元管理


配置脚本文件

通过网元软件管理，可以将自定义的脚本文件加载到网元上，使配置信息在网元上生效。

前提条件

  • 待操作网元支持该功能。
  • 具有网元软件管理操作权限。
  • 网元软件管理所在计算机与网元间通讯正常。
  • 从客户端选择待加载的脚本文件时，必须保证客户端与服务器间的文件传输服务正常运行（可采用FTP或SFTP协议进行传输，为了安全，建议使用SFTP协议。）。配置客户端与服务器之间的文件传输协议，详细操作请参见配置传输协议。

背景信息

  • 可以通过FTP加载脚本文件至网元。
  • 当脚本执行失败时，可以通过网元软件管理查看执行失败的命令。
  • 只有传送域/PTN网元支持此功能。

操作步骤

  1. 选择待操作网元，单击右键，选择“配置脚本文件”。
  2. 在“文件名称”下拉列表中，选择“浏览”。
  3. 在弹出对话框中，选择待加载的脚本文件。单击“确认”。

    注意：

    必须保证脚本文件所在目录下不能有O KB的文件，否则会导致文件执行失败。

  4. 单击“开始”，在操作确认对话框中单击“是”。

操作结果

在“网元视图”的操作状态中会显示脚本文件加载和执行的进度信息。进度的前20%是加载过程，后80%为执行过程，执行成功后，结果会显示在操作状态中。如果执行脚本失败，网元软件管理会提示具体执行失败的命令。

父主题： 网元管理


删除网元文件

日常维护中，为保证网元有充足的空间容纳新数据，可定期删除网元上无用的旧文件，以释放网元的存储空间。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

只有路由器/交换机支持此功能。

可以对网元主备主控板上存储卡（包括CF卡、Flash等）中的文件进行删除。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 单击鼠标右键，选择“删除网元文件”。弹出“误删除文件会导致主机业务中断，确认想要删除吗？”告警框，单击“是”，进入如下所示对话框。

  3. 在“选择待删除文件”区域框中选中需要删除的文件名称，单击 [image] ，待删除文件自动移动到“待删除文件”区域框中并显示待删除文件的大小。如下图所示。

    说明：
    在“选择待删除文件”区域框中，按住“Ctrl”键，批量选中需要删除的文件，单击 [image] ，批量待删除文件自动移动到“待删除文件”区域框中。

  4. 单击“删除”，弹出“操作确认”对话框。
  5. 单击“是”，弹出“删除文件”对话框，显示删除文件成功。
  6. 单击“关闭”，退出“删除文件”对话框，完成本次删除文件操作。
父主题： 网元管理


删除映像程序

介绍通过网元软件管理如何删除网元上不需要的映像程序，以释放网元上的存储空间。

前提条件

  • 待操作网元支持该功能。
  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

只有路由器网元支持此操作。

同一时刻只能对一个映像程序进行操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 在“网元视图”中选择一个网元，在下方窗格中单击“网元映像程序”页签。
  3. 选择待删除的映像程序，单击右键，选择“删除”。
  4. 在弹出的对话框中，单击“是”。

操作结果

在操作状态栏中，可以查看进度和操作结果。
父主题： 网元管理


设置OSPF状态

包扩散升级中，网元软件管理需要根据网元上的路由关系计算出软件包的扩散路径，因此网元必须开启动态路由功能。待升级完成后，网元可以根据需要将路由功能关闭。本节介绍如何在网元上设置OSPF状态。

前提条件

  • 待操作网元支持该功能。
  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

注意：
设置OSPF状态，可能会影响网元与网管之间的通信，请谨慎操作。

只有传送域/PTN网元支持此操作。

操作步骤

  1. 选择一个或多个网元，单击右键，选择“设置OSPF状态”。
  2. 在弹出对话框中，设置“打开”或“关闭”。
  3. 单击“确定”。
  4. 在弹出对话框中，单击“关闭”。
父主题： 网元管理


回滚软件

对于UA5000PVM网元，进行升级/降级后，通过回滚软件操作，可以使网元软件回退到升级/降级前状态。

前提条件

  • 网元软件已经完成升级/降级。
  • 只有UA5000PVM网元支持此功能。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作网元，单击右键，选择“回滚软件”。

操作结果

网元“操作状态”处显示进度。执行结束后，“操作状态”处显示操作成功或失败。

父主题： 网元管理


导出网元

导出已创建的网元列表，在独立部署的升级软件中可以批量创建网元。

前提条件

  • 已经在网元软件管理上创建了网元。

背景信息

可以将多个同域的网元一次性导出。以便后续在独立部署网元软件管理上操作时，可以直接导入网元，无需再手工逐一创建。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择一条或多条待导出网元信息，单击右键，选择“网元管理 > 导出网元”。
  3. 在弹出对话框中，输入文件名称。
  4. 在弹出对话框中，输入文件名称，选择文件保存的目录。
  5. 单击“导出”。
  6. 操作完成后显示操作结果，单击“确定”。
父主题： 网元管理


导出网元模板

批量创建网元时，需要导入含有网元信息且格式固定的文件。本节介绍如何获取网元模板，通过自定义编辑，可用于批量导入网元。

背景信息

  • 导出的模板可以直接编辑。在模板中提前将待操作的网元的信息输入完整，使用时，直接导入网元模板即可在网元软件管理中管理这些网元。节约了现场逐一创建网元的操作时间。
  • 不同域网元导出模板的操作入口不同，模板中所含信息不同，因此不能混用。模板中需要设置的内容与创建网元时相同。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 不同域网元导出模板的操作方法不同。
    选项 描述
    路由器/交换机（不包含集群交换机） 操作步骤如下：

    在“网元视图”中，单击右键，选择“网元管理 > 导出网元模板”。
    传送域/PTN网元 操作步骤如下：
    1. 单击右键，选择“网元管理 > 创建网元”。
    2. 在“创建网元”对话框中，单击“导出模板”。
    接入域网元 操作步骤如下：
    1. 单击右键，选择“网元管理 > 创建网元”。
    2. 在“创建网元”对话框中，单击“导出模板”。
  3. 在“导出模板”对话框中，单击 [image] ，在弹出对话框中选择模板的保存路径。
  4. 单击“确定”，返回“导出模板”对话框。
  5. 单击“确定”，导出完成后显示操作结果，单击“确定”。

操作结果

网元模板已成功导出，在指定路径下可以查看该模板。

父主题： 网元管理
相关任务
批量创建网元（导入方式）


保存网元列表

介绍如何将“网元视图”中的网元列表保存至网元软件管理所在计算机上。

背景信息

  • 网元列表可以保存为.TXT、.CSV和.HTML三种不同的格式。
  • 导出的网元列表文本文件，用浏览器打开的时候，如果文本文件与浏览器的编码格式不同，查看中可能会出现乱码。此时需要用户设置浏览器的编码格式与文本文件保持一致。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 单击“保存网元列表”。
  3. 设置保存路径和列表名称后，单击“保存”。
父主题： 网元管理


导出自定义检测项模板

对于支持该功能的路由域网元和交换机网元升级时，可以自定义检测项，了解网元状态。将自定义检测项模板导出后，用户可以在模板中填写检测项，以后在创建任务时，就可以将该模板导入，无需再次输入自定义检测项，提高升级效率。

背景信息

  • 若路由器网元和交换机网元支持此功能，该功能项可见。
  • Windows环境下该模板为*.xls格式。
  • 模板中导入项不要多于100条，不能有重复导入项。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 网元列表中选择所需网元，单击右键，选择“网元管理 > 导出自定义检测项模板”。
  3. 在对话框内，选择路径，输入文件名称。
  4. 单击“保存”。
  5. 单击“确定”，关闭对话框。

后续处理

  • 按照模板中指定的字段输入检测项的名称、命令、描述信息。然后在创建升级任务时，就可以将该模板导入，无需再次输入自定义检测项。
  • 创建升级任务中导入自定义检测项模板，受网元软件License控制，需要License在有效期内，参考申请网元软件升级能力License。
父主题： 网元管理


附录

本部分介绍与网元软件管理相关的参考内容。

  • 配置SFTP服务器
    当服务器与网元间通过SFTP协议进行文件传输，或者网元与客户端进行文件传输时，需要在服务器上配置SFTP服务参数，使其与网元软件管理备份、加载路径配置保持一致。本章将针对不同操作系统下的服务器，各提供一种配置SFTP参数的方法。
  • 图例
    通过“图例”，可以了解网元类型、任务管理、软件库管理、视图、网元树节点、通用操作，以及单板状态所对应的图形标识。
父主题： 网元软件管理


配置SFTP服务器

当服务器与网元间通过SFTP协议进行文件传输，或者网元与客户端进行文件传输时，需要在服务器上配置SFTP服务参数，使其与网元软件管理备份、加载路径配置保持一致。本章将针对不同操作系统下的服务器，各提供一种配置SFTP参数的方法。

  • Windows环境下配置SFTP（CYGWIN）服务器
    如果用户不使用网管自带的SFTP服务器软件，也可以自行决定使用哪种第三方SFTP服务器。为增强安全性，推荐使用网管自带的CYGWIN+OpenSSH SFTP服务器软件。
父主题： 附录


Windows环境下配置SFTP（CYGWIN）服务器

如果用户不使用网管自带的SFTP服务器软件，也可以自行决定使用哪种第三方SFTP服务器。为增强安全性，推荐使用网管自带的CYGWIN+OpenSSH SFTP服务器软件。

背景信息

  • 当网元软件管理对网元数据文件进行备份和加载操作时，“文件传输根目录”的选择要与服务器的配置结果保持一致。即

    配置SFTP服务的“文件传输根目录”、“用户名称”和“密码”必须与后续在网元软件管理客户端上配置的结果相一致。建议按照本手册内容进行操作，以避免服务器与客户端对应项配置不一致导致相关操作无法正常进行。

  • 目前CYGWIN最新版本：1.7.17-1，OpenSSH最新版本：Openssh-6.0p1-2。
  • 网管安装过程中，会自动安装CYGWIN+OpenSSH软件，并且自动创建三个操作系统用户：
    • ftpuser：SFTP服务器默认用户，提供SFTP登录服务。
    • cyg_server：计算机管理员账户，用于启动OpenSSH服务，初始密码同ftpuser，请及时修改初始密码。
    • sshd：系统管理ssh服务用户，默认禁用（如果没有禁用，建议手工禁用此用户）。
  • SFTP服务器默认的用户为“ftpuser”，“ftpuser”用户是计算机管理员级别的用户，为保证系统安全，请按照如下步骤设置“ftpuser”用户的密码和根目录。本节操作以网管安装在“D:\oss”为例。
  • 如果使用第三方SFTP服务器，请先停止CYGWIN+OpenSSH SFTP服务器软件。停止方法如下：
    1. 进入网管安装目录“D:\oss\server\common\dc\3rdTool\cygwin”。
    2. 双击StopService.bat。
  • 配置SFTP服务密钥的方法如下：
    1. 进入网管安装目录“D:\oss\server\common\dc\3rdTool\cygwin”，双击“Cygwin.bat”。
    2. 在弹出的对话框中执行命令，切换当前目录到SFTP的根目录，例如“D:”，同时需要把密钥文件authorized_keys也拷贝到该目录下。
      $ cd d:
    3. 把公钥信息粘贴到SFTP根目录下的“.ssh”文件夹中。若“.ssh”文件夹不存在，请执行下面的命令创建该文件并且拷贝密钥文件：
      $ mkdir .ssh
$ cp authorized_keys .ssh
    4. 执行下面的命令修改文件的权限：
      $ chmod go-w d:/.ssh
$ chmod 600 d:/.ssh/authorized_keys
$ chown  ftpuser d:/.ssh/authorized_keys

操作步骤

  1. 进入网管安装目录“D:\oss\server\common\dc\3rdTool\cygwin”。
  2. 双击StartService.bat。

    说明：

    CYGWIN+OpenSSH SFTP软件会自动识别是否初始化过密码和SFTP根目录，如果已经初始化过，就不用做其他处理；如果没有初始化过，就会提示用户输入密码和SFTP根目录。

后续处理

SFTP服务器配置成功后，请登录网元软件管理客户端，配置文件传输服务等。请参见配置传输协议。

测试SFTP服务是否正常，需要进入“本地xFTP信息”界面进行。界面入口请参考配置传输协议。

父主题： 配置SFTP服务器
相关任务
配置传输协议


图例

通过“图例”，可以了解网元类型、任务管理、软件库管理、视图、网元树节点、通用操作，以及单板状态所对应的图形标识。

图例及相关说明如表1所示。
表1 图例描述
快捷图标 | 描述
 | 网关网元
 | 任务节点
 | 未运行的任务
 | 运行的任务
 | 完成的任务
 | 软件升级任务
 | 软件降级任务
 | OLT代理升级任务
 | 补丁升级任务
 | 包升级任务
 | 模拟包升级任务
 | 包扩散升级任务
 | 折叠任务
 | 展开任务
 | 标准的文件
 | 支持拆包的文件
 | 拆包成功的文件
 | 拆包失败的文件
 | 网元视图
 | 网元树节点
 | 保存
 | 预览
 | 打印
 | 导出
 | 导入
 | 搜索
 | 过滤
 | 普通单板
 | 软复位单板
 | 硬复位单板
 | 正常
 | 仅进行收集，不进行分析的检查项，比对结果正确或不需要比对，以提示符表示。其中用户自定义的检查项属于此类
 | 检查项不涉及
 | 进行收集的检查项，无论是否进行分析，如果比对结果错误，以错误信息提示
 | 向设备发送命令异常或工具分析失败，以告警提示，而非错误提示
 | 正在运行


版本

参数含义

显示所选网元当前的软件版本。可通过“获取版本”操作获取或者刷新此参数的显示结果。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：MA5600V800R007C01 | -


备份信息

参数含义

显示某一网元全部的备份文件信息。包括：备份路径、文件属性等。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
文件路径，内容类型，版本，文件大小，最后修改时间 | -

各参数取值的含义如下。

参数选项 | 说明
文件路径 | 显示备份文件保存的路径。
内容类型 | 显示备份文件的类型。
版本 | 显示备份文件的版本。
文件大小 | 显示备份文件的大小。
最后修改时间 | 显示备份文件的最后修改时间。在未对文件进行手工修改的情况下，显示的时间即备份成功的时间。


单板信息

参数含义

显示某一网元的单板信息。包括：单板的位置、名称、版本等。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
单板位置，单板名称，单板版本 | -

各参数取值的含义如下。

参数选项 | 说明
单板位置 | 显示单板所在的支架或槽位号。
单板名称 | 显示单板的实际名称。
单板版本 | 显示单板的软件版本，包括软件、扩展BIOS、FPGA等。


网元映像程序

参数含义

单击“查询”按钮后，显示某一网元的映像程序信息。包括：映像程序的名称、所在的盘符位置、大小、版本和启动情况等。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
程序名称，程序地址，程序大小，程序版本，当前启动文件，下一次启动文件 | -

各参数取值的含义如下。

参数选项 | 说明
程序名称 | 显示设备映像程序文件的实际名称。
程序地址 | 显示映像程序在网元上的盘符位置。
程序大小 | 显示映像程序的大小。
程序版本 | 显示映像程序的版本。该版本信息由系统自动获取，若获取失败，显示为NULL。
当前启动文件 | 显示映像程序文件是否为网元当前使用的文件。
下一次启动文件 | 显示映像程序是否为网元重启后会使用的文件。


磁盘空间信息

参数含义

显示所选网元上所有磁盘的名称、磁盘类别、总空间和剩余空间。加载前需要查看磁盘剩余空间，以判断是否有充足空间满足新软件或新补丁的加载需求。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
磁盘名称，磁盘类别，磁盘容量，剩余空间 | -

各参数取值的含义如下。

参数选项 | 说明
磁盘名称 | 显示网元包含磁盘的名称。
磁盘类别 | 显示磁盘所属类别。
磁盘容量 | 显示每个磁盘的总容量。
剩余空间 | 显示每个磁盘的剩余空间。加载前，需要查看剩余空间大小，判断是否有充足空间容纳新软件或新补丁，如不满足加载的空间需求，需要手工删除部分文件。操作方法可参见删除网元文件。


License和PAF信息

参数含义

显示某一网元的License和PAF信息。包括：文件的名称、所在位置和大小等。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
文件名称，文件地址，文件大小 | -

各参数取值的含义如下。

参数选项 | 说明
文件名称 | 显示网元上License和PAF文件的名称，文件后缀为.txt。
文件地址 | 显示License和PAF文件在网元上的位置。
文件大小 | 显示网元上License和PAF文件的大小。


配置文件信息

参数含义

显示某一网元的配置文件信息。包括：文件的名称、所在位置和大小等。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
配置文件名称，文件地址，文件大小 | -

各参数取值的含义如下。

参数选项 | 说明
配置文件名称 | 显示网元上包含配置文件的名称，文件后缀为.cfg。
文件地址 | 显示配置文件在网元上的位置。
文件大小 | 显示网元上包含配置文件的大小。


操作类型

参数含义

设置是否开启网元上的动态路由功能。

对系统的影响

设置OSPF状态，可能会影响网元与网管之间的通信，请谨慎操作。

参数值

取值范围 | 缺省值
打开，关闭 | 打开

取值原则

  • “打开”——当进行包扩散升级时，网元软件管理需要根据网元上的路由关系计算出软件包的扩散路径，因此必须开启网元的动态路由功能。此时，选择此参数。
  • “关闭”——当包扩散升级完成后，需要关闭网元的动态路由功能时，选择此参数。


文件信息

参数含义

显示网元上存在的存储区，存储区内存在哪些文件，以及存储区的空间大小和占用情况。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如： cfcard:/(剩余空间:253,493,248 Byte/总空间:518,520,832 Byte) log.dblg | -


系统IP

参数含义

设置经过NAT转换后与网元网络通信的IP地址。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
某一互联网公共IP地址 | 空

取值原则

当待操作的网元处于互联网中，无法与私网中的网管服务器进行直接通信时，需要设置此参数。

如图1所示，网元A处于互联网中，网管系统处于私网中。网管系统需要与网元A通信，首先须将私网地址IP1(系统IP)经过NAT转换成互联网公网IP地址IP2（与网元A所在网络通信的IP）。
图1 网管系统IP经NAT转换与网元通信示意图


与网元通信的IP/掩码

参数含义

设置与网管系统通信的网段（待管理网元所在的网段）。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：10.78.220.1/24 | 空

取值原则

当网管系统通过多个网卡与网元网络通信时，需要设置此参数。

在“增加系统通信IP”对话框中，设置网管系统中与网元网段通信的IP地址（通过其中一个网卡），和网元所在的网段。（此参数即用来设置网元所在网段）网段的设置方法如10.78.220.1/8，表示换算为二进制的IP地址后八位可变。则该网元所在的网段为10.78.220.0–10.78.220.255。

与其他参数的关联关系

只有当“多网卡”设置为选中状态时，本参数才可以设置。


目录设置

参数含义

设置文件传输根目录。当通过网元软件管理对网元进行加载、备份、恢复时，都需要进行文件传输，所传输的文件都需要经过或最终保存在文件传输根目录。

对系统的影响

此处必须与服务器上设置的文件传输根目录相同，否则会导致网元软件管理加载、备份、恢复等基本功能不可用。

参数值

取值范围 | 缺省值
例如：D: | D:

取值原则

路径只能由字母、数字和下划线组成，不能包含中文、空格和特殊字符，如!@#$%^&*()- + = ./*[]{}等。


客户端与服务器的文件传输协议

参数含义

设置网管客户端与服务器进行文件传输时使用的协议。例如：将网元数据备份到网管客户端，在客户端对备份到服务器上的文件做操作，或者在网管客户端选择待加载文件时，都需要使用此协议。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
SFTP，FTP | SFTP

取值原则

  • “SFTP”——当网管服务器与客户端采用SFTP进行文件传输时（必须保证SFTP服务正常运行），选择此参数。
  • “FTP”——当网管服务器与客户端采用FTP进行文件传输时（必须保证FTP服务正常运行），选择此参数。


协议

参数含义

设置网元与网管服务器进行文件传输时使用的协议。例如：备份、恢复、加载等操作，都需要使用此协议。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
FTP，SFTP，TFTP 不同网元支持的协议可能不同，请根据界面实际提供的选项进行选择。 | 多数类型网元的缺省值为FTP，部分类型接入域网元的缺省值为TFTP

取值原则

  • “SFTP”——当网元与网管服务器采用SFTP进行文件传输时（必须保证SFTP服务正常运行），选择此参数。
  • “FTP”——当网元与网管服务器采用FTP进行文件传输时（必须保证FTP服务正常运行），选择此参数。
  • “TFTP”——当网元与网管服务器采用TFTP进行文件传输时（必须保证TFTP服务正常运行），选择此参数。


FTP服务器IP

参数含义

设置第三方FTP服务器的IP地址。当网元与网元软件管理之间连通，但是不能使用FTP协议通信时，可以通过另一台支持FTP服务的计算机（第三方FTP服务器）与网元进行升级时的备份、加载等文件传输操作。采用此操作方式前，需先要设置此参数。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
与网元处于同一网段的IP地址 | 默认不配置

取值原则

当需要使用第三方FTP服务器与网元进行升级时的文件传输操作时，选择此参数。


License文件

参数含义

导入已准备好的License文件，以提高网元升级/降级操作的并发效率。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：license.dat | 空

取值原则

  • License文件是用于控制软件升级/降级并发度的授权文件。在没有License文件的情况下，升级/降级操作的并发效率较低。如需要提高升级/降级操作的并发效率，请联系华为工程师购买相关服务。
  • License文件仅用来控制软件升级/降级的并发度，加载补丁、网元数据备份和恢复等操作不受License文件的控制。


导入模式

参数含义

设置导入软件的方式。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
单个文件导入，全版本导入 | 单个文件导入

各参数取值的含义如下。

参数选项 | 说明
单个文件导入 | 逐一将所需软件文件导入至软件库中。导入过程中，需要确保软件类型、软件版本等信息设置正确。
全版本导入 | 通过导入软件版本描述文件ver_desc.ini，一次性将版本中各软件文件自动导入至软件库中。

取值原则

  • “单个文件导入”——当需要手工逐一导入软件文件时，选择此参数。
  • “全版本导入”——当需要选择版本描述文件，自动导入软件文件时，选择此参数。


文件类型

参数含义

设置待导入软件文件的类型。

对系统的影响

此参数的设置结果必须与实际导入的软件类型匹配，否则会导致文件导入失败或者导入的软件不可用。

参数值

取值范围

缺省值

不同系列的网元支持的文件类型可能不同。请根据具体网元配套的升级指导书中提供的“文件列表”进行选择。
  • 接入域网元：打包/拆包工具
  • 路由器/交换机：软件映像
  • 传送域/PTN网元：软件包

取值原则

根据实际导入的软件类型设置对应参数。


版本

参数含义

设置软件的版本信息。

对系统的影响

软件的版本信息输入不正确，升级时会直接影响系统对加载软件的版本校验，导致升级结果显示为失败。

参数值

取值范围 | 缺省值
例如：MA5600V800R006C02SPC100 | 空

取值原则

  • 输入时须采用大写形式。
  • 严格按照软件发布时的版本信息输入，保证信息的完整性和正确性。
  • 如果已自动识别出版本信息，只需要确认该版本信息是否正确。如不正确，需要手工修正。
  • 对于MXU网元，当导入IO包时，仍需要输入与IO包（补丁）配套（同时发布）的软件版本号。


补丁版本

参数含义

显示导入补丁（包括MXU网元的IO包）的版本信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：SPC100 | 空


使用已经存在的版本

参数含义

设置是否使用已经存在于软件库中的版本信息。适用于已经导入过与当前待导入文件配套的软件文件（具有相同版本信息的网元文件），软件库中已记录了上次导入时设置的版本信息，此次操作可以直接使用，减少了重复设置的工作量和出错几率。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

  • 使能——当已经导入过与当前待导入文件配套的软件文件，而需要直接选择上次设置的版本信息时，选择此参数，并在下拉列表中选择目标版本。
  • 不使能——当第一次导入某一版本的软件文件时，选择此参数。


包加载状态

参数含义

显示软件包的加载状态。只有在软件包加载或扩散任务中，才会根据软件包的实际状态动态刷新显示结果。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
正常态，拷贝文件开始，拷贝文件结束，分发开始，分发结束，正在激活，激活完成，正在提交，软件回滚，拷贝文件挂起，激活网元，激活备板，激活单板，加载未激活，待稳定态，扩散初始态，扩散加载态，正在同步从网元，正在同步主网元 | 空


目标版本

参数含义

显示网元升级/降级完成后的软件版本。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：MA5600V800R007C01 | 空


任务名称

参数含义

设置任务的名称。当同时创建多个相同类型的任务时，可以通过自定义任务名称，区分任务中包含的操作，或者任务的启动顺序。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：任务_091111020255 | 任务+下划线+当前时间（其中，当前时间的显示格式为“年yy月mm日dd时hh分mm秒ss”）

取值原则

  • 最大长度为255个字符。
  • 可以使用中文、英文、数字和下划线等字符。
  • 任务名称中不能包含空格及以下特殊字符：~!@#$%^&*|<>[]{}=+?”\;'。


文件类型

参数含义

设置在网元进行启动时系统配置的恢复方式。

对系统的影响

无。

参数值

取值范围 | 缺省值
数据文件 | 数据文件

各参数取值的含义如下。

参数选项 | 说明
数据文件 | 在系统重新启动时，系统会从数据库文件进行系统配置恢复。数据文件是指以数据库形式保存系统配置数据的文件，该文件为二进制文件。

取值原则

“数据文件”——在系统重新启动时，系统会从数据库文件进行系统配置恢复。使用该方式恢复系统配置较快，一般用于升级场景。


目标版本

参数含义

设置网元升级的目标软件版本。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：MA5600V800R006C02SPC100 | 空

各参数取值的含义如下。

参数选项

说明

具体的软件版本号
  • 此选项可设置（在下拉列表中选择）的前提是已经将软件导入至软件库。
    说明：

    当已经将待升级网元的目标版本软件导入至软件库后，下拉列表中将会显示软件的全部版本信息。这些版本信息与导入软件时设置的“版本”相对应。

  • 当已经导入待加载软件到软件库后，创建任务时，只需要设置此参数，即能够完成“选择加载软件”这项配置，无需在任务的操作配置中单击链接重复配置。
  • 当没有完成软件导入，需要进入软件库进行操作时，只需要单击 [image] ，即可进入导入软件的操作界面。

空

尚未导入任何与待操作网元配套的软件到软件库中。

取值原则

  • 具体的软件版本——当需要通过软件库功能选择加载软件时，选择此参数。
  • 空——当需要手工选择加载软件时，选择此参数。


开始时间

参数含义

设置是否采用任务自动开始功能，并设置任务自动开始的时间。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

  • 使能——当需要应用任务自动开始功能时，选择此参数。选择此参数后，缺省显示当前时间，单击 [image] ，在弹出对话框中设置任务自动开始的时间。
  • 不使能——当需要手工开始任务时，选择此参数。


操作

参数含义

显示升级任务中包含哪些操作。用户根据实际需要，选择在任务中具体执行哪些操作。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
包含加载、激活等操作。（对应不同类型/版本网元的任务中包含的操作可能不同） 多数操作可通过复选框进行选择或者去选。 | -

取值原则

  • 需要在升级任务中自动执行的操作，设置为使能。（对应操作前的复选框为选中状态）
  • 不需要在升级任务中执行的操作，设置为不使能。（对应操作前的复选框为去选状态）


操作配置

参数含义

设置已选操作的配置信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：配置激活信息 | -

取值原则

  • 对于已选择且可以配置的操作，此列中会显示链接。单击链接，将进入具体的配置界面。
  • 不能够配置的操作，此列会对应显示为空。
  • 可以配置但没有选择的操作，此列会灰化。
  • 显示为红色的链接，表示必须对对应的操作进行配置。显示为蓝色的链接，表示可根据需要选择是否进行配置。


如果待加载网元是网关网元，强制选择FTP协议加载

参数含义

设置是否使用FTP协议为传送域/PTN网络中的网关网元（不包含RTN和TL1网元）进行软件包加载操作。如不选择此项，则通过华为私有协议进行软件包加载。

对系统的影响

如果使能了此功能却没有开启FTP服务，加载执行过程中网关网元将无法获取加载文件，系统会给出错误提示。

参数值

取值范围 | 缺省值
使能，不使能 | 使能

取值原则

  • 使能——当网管服务器已经开启FTP服务时，建议选择此参数，能够提高加载软件包至网关网元的效率。
  • 不使能——当网管服务器没有开启FTP服务，或者不需要使用FTP进行软件包加载时，选择此参数。


执行此步骤前停止

参数含义

设置任务开始执行后，是否在执行某项操作前自动暂停任务。建议在重要的操作前设置自动暂停，如“激活”操作。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | -

取值原则

  • 使能——当需要任务在执行到某项操作前自动暂停时，选择此参数。

    推荐保留软件上的缺省配置。其中，由于“激活”操作会影响网上业务，需要在晚上业务量少时再执行，因此请务必保留激活操作对应的“执行此步骤前停止”为使能状态。

  • 不使能——当需要任务顺序执行，不需要在执行到某操作前自动暂停时，选择此参数。


激活类型

参数含义

设置网元采用何种激活方式使新软件在网元上正式生效。

对系统的影响

激活可能导致网元业务中断，请谨慎操作。

参数值

取值范围

缺省值
  • 接入域网元：断业务，不断业务，业务板，延时重启
  • 路由器/交换机：立即重启，延时重启，定时重启，手工重启
不同网元支持的激活类型可能不同，请根据界面实际提供的选项进行选择。
  • 接入域网元：断业务
  • 路由器/交换机：立即重启

各参数取值的含义如下。

参数选项 | 说明
断业务，立即重启 | 激活时重启网元，网元业务会中断。
不断业务 | 激活时分别重启主用和备用主控板，网元业务不会中断。
业务板 | 激活时仅重启各业务单板，激活后各业务单板上将运行新软件。
延时重启 | 在下拉列表中选择延时时间，激活命令下发至网元后，网元延迟数分钟重启。 延时重启适用于级联组网的场景。如默认所有网元延时5～10分钟激活。采用延时重启可以保证全网所有网元都收到激活命令。避免上游网元激活后，下游网元无法收到激活命令。
定时重启 | 设置重启时间，在指定的时间重启网元。
手工重启 | 在终端窗口中通过命令行的方式重启网元。

取值原则

  • “（中）断业务”/“立即重启”——当需要在激活过程中立即重启网元（重启时网元业务会中断），选择此参数。
  • “不断业务”——当需要分别重启主用和备用主控单板，保障业务不中断时，选择此参数。
  • “业务板”——当需要仅重启业务单板时，选择此参数。
  • “延时重启”——当网元采用级联组网的场景，需要保障所有网元都收到激活命令时，选择此参数。
  • “定时重启”——当需要在指定的时间重启网元时，选择此参数。
  • “手工重启”——当需要通过命令行方式对网元进行重启时，选择此参数。


激活模式

参数含义

设置任务中网元的激活顺序。

对系统的影响

激活可能导致业务中断，请谨慎操作。

参数值

取值范围 | 缺省值
并行激活，分组激活 | 并行激活

各参数取值的含义如下。

参数选项 | 说明
并行激活 | 任务中所有网元同时执行激活操作。此种模式的激活效率高于串行模式（一个网元激活完成后下一个网元再进行激活）。
分组激活 | 手工创建激活分组。不同组间的网元串行激活（序号小的分组先激活，序号大的分组后激活）；同组内的网元并行（同时）激活。

取值原则

  • “并行激活”——当需要使任务中的网元同时激活以提高激活效率时，选择此参数。
  • “分组激活”——当需要手工对激活顺序进行调整时，选择此参数。


比较结果

参数含义

显示升级前与升级后网元上与网元软件管理接口协议的参数配置。通过查看此参数，可以了解升级过程是否造成网元配置发生改变。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如： | -


运行网元

参数含义

显示正在运行的网元的数目及占网元总数的百分比。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：5（20%） | -


未运行网元

参数含义

显示未运行的网元的数目及占网元总数的百分比。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：5（20%） | -


是否被隔离

参数含义

显示网元的单板是否被自动隔离。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
是，否 | -


资源状态

参数含义

显示软件包的状态。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：待激活态 | 空


文件路径

参数含义

显示或设置任务报告保存的路径。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：F:\nms\client\report | ..\client\report


查看失败的检测项

参数含义

设置检测项的过滤属性为仅显示检测失败的项目。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

根据需要选择是否使用此功能。


查看所有检测项

参数含义

设置检测项的过滤属性为显示全部检测成功和失败的项目。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

根据需要选择是否使用此功能。


查看

参数含义

显示网元的命令回显信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
- | -


查看差异和失败的检测项

参数含义

设置检测项的过滤属性为仅显示前后检测中存在差异的项目和所有检测失败的项目。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

根据需要选择是否使用此功能。


对比结果

参数含义

显示网元升级前检测和升级后检测中各检测项的对比情况。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
- | -


升级可用性

参数含义

显示网管对网元运行状态进行检查和分析的结果。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
OK，POK，NG | -

各参数取值的含义如下。

参数选项 | 说明
OK | 表示网元运行状况正常，可以安全升级。
POK | 表示网元运行状况有异常，不推荐用户执行升级操作。
NG | 表示网元运行状况不正常，不推荐用户执行升级操作。


状态

参数含义

显示网元或单板当前的软件加载状态。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：软件运行 | -


进度

参数含义

显示网元补丁的加载进度。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
0～100 | -


在运行版本

参数含义

显示正在运行的软件的版本信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如: 3.13 | -


待升级版本

参数含义

显示待加载软件的版本信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如: 3.14 | -


激活顺序

参数含义

显示网元/单板的激活顺序。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如： 1-osn | -

各参数取值的含义如下。

参数选项 | 说明
值域为单个数字 | 表示进行的是网元级激活，数字相同的网元激活顺序相同。
值域中包含“-” | 表示进行的是单板级激活。“-”后字符表示激活时所属组别，“-”前数字表示所属组别的激活优先级。值域越小，优先级越高。


详细运行版本

参数含义

显示选中单板详细的硬件和软件版本信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如: BIOS:1.0， Software: 1.0 | -


待加载文件及版本

参数含义

显示待加载软件名称及版本信息。单击该参数框区域可以查看选中网元或单板所有的加载文件信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如： fpga.pga 3.13 | -


状态

参数含义

显示网元补丁的加载状态。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
正常态、拷贝态、异常态 | -


在运行版本

参数含义

显示当前装载到内存中的补丁软件的版本。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如: sph001 | -


待升级版本

参数含义

显示装载到待升级区域的补丁软件版本。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如: sph002 | -


保存周期

参数含义

显示当前网元数据自动保存的周期和每次保存的开始时间。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • “周期”：每月，每周，每日
  • “日”：1～31（周期为“每日”），星期日～星期六（周期为“每周”），空（周期为“每日”）
  • “时间”：例如“01:00”
  • “周期”：每日
  • “日”：空
  • “时间”：01:00


保存策略状态

参数含义

显示网元当前的保存策略状态为开启或者禁用。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
启用，禁用 | 默认策略缺省为禁用状态 自定义策略缺省为启用状态


备份周期

参数含义

显示当前网元数据自动备份的周期和每次备份的开始时间。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • “周期”：每月，每周，每日
  • “日”：1～31（周期为“每日”），星期日～星期六（周期为“每周”），空（周期为“每日”）
  • “时间”：例如“02:00”
  • “周期”：每日
  • “日”：空
  • “时间”：02:00


备份策略状态

参数含义

显示网元当前的备份策略状态为开启或者禁用。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
启用，禁用 | 默认策略缺省为禁用状态 自定义策略缺省为启用状态


备份类型

参数含义

设置周期备份的网元数据的文件类型。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • 传送域/PTN网元：数据库包，配置数据
  • 接入域网元：数据文件，配置文件
  • 路由器/交换机：启动配置文件，运行配置文件

不同类型网元，缺省值不同

各参数取值的含义如下。

参数选项

说明

启动配置文件

路由器/交换机的一种数据文件类型。该文件由保存在网元Flash中的数据生成。

运行配置文件

路由器/交换机的一种数据文件类型。该文件由网元内存中当前运行的数据生成。

数据文件

接入域网元的一种数据文件类型。文件格式为二进制。升级时，对于不支持内部数据库升级的网元，需要使用升级工具对网元数据进行升级。

配置数据
  • 接入域网元的一种数据文件类型。文件中可查看具体的命令。升级时，不需要对配置文件进行升级。但由于升级前的配置文件可能在新版本中不完全兼容，从而导致业务丢失，因此推荐使用数据文件进行升级。
  • 传送域/PTN网元的一种数据文件类型。备份文件类型与网元版本相关，只有较早版本的网元支持配置数据。
    • 保障在主控板+CF卡同时故障时，可以快速恢复配置数据。
    • 网元升/降级操作前做备份，保障在升/降级操作失败时可以迅速恢复到操作前的配置状态。

数据库包
传送域/PTN网元的一种数据文件类型。备份文件类型与网元版本相关，多数网元支持数据库包。
  • 保障在主控板+CF卡同时故障时，可以快速恢复配置数据。
  • 网元升/降级操作前做备份，保障在升/降级操作失败时可以迅速恢复到操作前的配置状态。
说明：
  • 对于传送域/PTN网元，网管下发配置命令，会在网元中生成配置数据，包括网元的单板配置、时钟配置、保护关系、通信等信息。因为配置数据在内存中，复位会丢失。为了网元复位或掉电后能重新生成配置数据，接下来配置数据会以另一种形式存储到数据库中形成网元数据库包，这样可以从数据库中读出重新生成配置数据。因此网元数据库和配置数据是网元上的同一内容，区别是格式不同。
  • 对传送域/PTN网元，备份文件类型与网元版本相关，即一个网元版本仅支持一种备份文件类型。例如：备份1600G网元数据，对于网元版本5.08.03.XX仅支持配置数据的备份，而对于网元版本5.08.04.XX及其以后版本，仅支持数据库包的备份。在备份时，若选择了不支持的文件类型，网管会给出报错提示。

取值原则

用户可根据需要选择备份哪种类型的文件。


最大备份数

参数含义

显示已经设置的备份文件保留数目的上限值。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
手动清除 1～200 | 5


备份前保存

参数含义

显示是否已应用备份前保存功能。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 使能


变更触发备份

参数含义

显示是否已应用变更触发备份功能。应用此功能后，对于传送域/PTN网元，当配置在发生变更后30分钟内再无变化，网元软件管理会对网元数据进行一次备份；对于路由器网元，当配置在发生变更后会自动上报Trap消息，网元软件管理收到消息后，会立即对网元数据进行一次备份。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能


网元定时备份

参数含义

显示是否已使用网元软件管理为网元设置定时备份属性。此功能是“变更触发备份”的补充。选择此项后，可以通过网元软件管理对网元上报消息（Trap）的时间进行自定义设置（不需要每次发生变更都上报消息）。当网管收到触发性消息（Trap）后，会自动对网元数据进行备份。

对系统的影响

启用网元定时备份策略后，不会在每一次网元配置发生变更时进行备份。假设从上一次自动备份开始网元配置共发生了5次改变，预计还有1分钟到达下一次自动备份的时间，此时网元发生了故障，需要将第3次改变后的配置恢复到网元上，而网管上并不存在可用的备份文件为网元进行配置恢复。因此，建议不要将定时备份的时间设置得过长。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能


备份周期

参数含义

设置网元数据自动备份的周期和每次备份的开始时间。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • “周期”：每月，每周，每日
  • “日”：1～31（周期为“每日”），星期日～星期六（周期为“每周”），空（周期为“每日”）
  • “时间”：例如“02:00”
  • “周期”：每日
  • “日”：空
  • “时间”：02:00

取值原则

  • 当需要每月/每周/每日为网元数据进行一次自动备份时，在“周期”下拉列表中选择对应的参数。
  • 当已经选择了每月/每周为网元数据进行一次自动备份时，需要选择自动备份发生的具体的“日”，在下拉列表中选择对应的参数。
  • 在“时间”微调输入框中设置自动备份的具体时间，格式为“HH:mm”。


保存周期

参数含义

设置网元数据自动保存的周期和每次保存的开始时间。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • “周期”：每月，每周，每日
  • “日”：1～31（周期为“每日”），星期日～星期六（周期为“每周”），空（周期为“每日”）
  • “时间”：例如“01:00”
  • “周期”：每日
  • “日”：空
  • “时间”：01:00

取值原则

  • 当需要每月/每周/每日为网元数据进行一次自动保存时，在“周期”下拉列表中选择对应的参数。
  • 当已经选择了每月/每周为网元数据进行一次自动保存时，需要选择自动保存发生的具体的“日”，在下拉列表中选择对应的参数。
  • 在“时间”微调输入框中设置自动保存的具体时间，格式为“HH:mm”。


新增加网元的策略状态

参数含义

设置是否立即开启网元的策略。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
启用，禁用 | 启用

取值原则

  • “启用”——当新建/修改策略后需要立即开启策略时，选择此参数。
  • “禁用”——当新建/修改策略后不需要立即开启策略时，选择此参数。


备份类型

参数含义

设置备份哪种类型的网元数据文件。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • 传送域/PTN网元：数据库包，配置数据
  • 接入域网元：数据文件，配置文件
  • 路由器/交换机：启动配置文件，运行配置文件

不同类型网元，缺省值不同

各参数取值的含义如下。

参数选项

说明

启动配置文件

路由器/交换机的一种数据文件类型。该文件由保存在网元Flash中的数据生成。

运行配置文件

路由器/交换机的一种数据文件类型。该文件由网元内存中当前运行的数据生成。

数据文件

接入域网元的一种数据文件类型。文件格式为二进制。升级时，对于不支持内部数据库升级的网元，需要使用升级工具对网元数据进行升级。

配置数据
  • 接入域网元的一种数据文件类型。文件中可查看具体的命令。升级时，不需要对配置文件进行升级。但由于升级前的配置文件可能在新版本中不完全兼容，从而导致业务丢失，因此推荐使用数据文件进行升级。
  • 传送域/PTN网元的一种数据文件类型。备份文件类型与网元版本相关，只有较早版本的网元支持配置数据。
    • 保障在主控板+CF卡同时故障时，可以快速恢复配置数据。
    • 网元升/降级操作前做备份，保障在升/降级操作失败时可以迅速恢复到操作前的配置状态。

数据库包
传送域/PTN网元的一种数据文件类型。备份文件类型与网元版本相关，多数网元支持数据库包。
  • 保障在主控板+CF卡同时故障时，可以快速恢复配置数据。
  • 网元升/降级操作前做备份，保障在升/降级操作失败时可以迅速恢复到操作前的配置状态。
说明：
  • 对于传送域/PTN网元，网管下发配置命令，会在网元中生成配置数据，包括网元的单板配置、时钟配置、保护关系、通信等信息。因为配置数据在内存中，复位会丢失。为了网元复位或掉电后能重新生成配置数据，接下来配置数据会以另一种形式存储到数据库中形成网元数据库包，这样可以从数据库中读出重新生成配置数据。因此网元数据库和配置数据是网元上的同一内容，区别是格式不同。
  • 对传送域/PTN网元，备份文件类型与网元版本相关，即一个网元版本仅支持一种备份文件类型。例如：备份1600G网元数据，对于网元版本5.08.03.XX仅支持配置数据的备份，而对于网元版本5.08.04.XX及其以后版本，仅支持数据库包的备份。在备份时，若选择了不支持的文件类型，网管会给出报错提示。

取值原则

用户可根据需要选择备份哪种类型的文件。


备份最大份数

参数含义

设置保留备份文件数目的上限值。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
手动清除 1～200 | 5

取值原则

在取值范围内任意取值。建议使用缺省值。


备份前保存

参数含义

设置是否要应用备份前保存功能。使能该参数后，执行备份操作前先执行保存操作，将网元当前运行在内存中的数据保存至网元Flash中，确保从Flash中备份的数据为最新。（与网元当前运行的数据一致）

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 使能

取值原则

根据需要选择是否使用此功能。建议保留缺省值。


变更触发备份

参数含义

设置是否要应用变更触发备份功能。选择此项后，对于传送域/PTN网元，当配置在发生变更后30分钟内再无变化，网元软件管理会对网元数据进行一次备份；对于路由器网元，当配置在发生变更后会自动上报Trap消息，网元软件管理收到消息后，会立即对网元数据进行一次备份。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

根据网元的维护需要，选择是否使用此功能。


网元定时备份

参数含义

设置是否要使用网元软件管理为网元设置定时备份属性。此功能是“变更触发备份”的补充。选择此项后，可以通过网元软件管理对网元上报消息（Trap）的时间进行自定义设置（不需要每次发生变更都上报消息）。当网管收到触发性消息（Trap）后，会自动对网元数据进行备份。

对系统的影响

启用网元定时备份策略后，不会在每一次网元配置发生变更时进行备份。假设从上一次自动备份开始网元配置共发生了5次改变，预计还有1分钟到达下一次自动备份的时间，此时网元发生了故障，需要将第3次改变后的配置恢复到网元上，而网管上并不存在可用的备份文件为网元进行配置恢复。因此，建议不要将定时备份的时间设置得过长。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

根据网元的维护需要，选择是否使用此功能。

使能此功能后，在复选框后的链接上可以查看“网元定时备份”策略当前的配置信息。单击链接，进入“设置网元定时备份”对话框，参照界面信息自定义设置备份属性。


配置升级版本

参数含义

设置自动升级依赖的文件。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

选择网元类型后，该网元类型对应的“配置升级版本”链接将使能。配置升级版本的前提是已经将对应网元类型的软件包导入至软件库。

与其他参数的关联关系

只有当对应的“网元类型”设置为选中状态时，本参数才生效。


升级版本

参数含义

设置网元自动升级的目标版本。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
已导入软件库的全部软件的版本信息。 | -

取值原则

选择的版本须与系统当前运行的软件版本相同。

与其他参数的关联关系

只有当对应的“配置升级版本”为使能状态，单击链接后，进入可设置的对话框时，本参数才生效。


加载文件

参数含义

显示升级目标版本中对应的文件。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：createbin | -

与其他参数的关联关系

只有当“升级版本”已选定，选中加载文件对应的“序号”时，本参数才生效。


需要容灾备份

参数含义

设置是否要应用容灾备份功能。使能该参数后，可以自定义设置容灾备份的周期等信息。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

根据网元的维护需要，选择是否使用此功能。


备份到

参数含义

设置备份网元数据的目标路径。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
网管服务器，网管客户端 | 网管服务器

各参数取值的含义如下。

参数选项 | 说明
网管服务器 | 选择此选项后，将备份网元数据到文件传输根目录下的backup文件夹。
网管客户端 | 选择此选项后，将备份网元数据到客户端所在计算机的指定路径。单击“...”，设置备份的目标路径。

取值原则

  • “网管服务器”——当需要将网元数据备份到网管服务器所在计算机时，选择此参数。
  • “网管客户端”——当需要将网元数据备份到网管客户端所在计算机时，选择此参数。


文件类型

参数含义

设置备份哪种类型的网元数据文件。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值
  • 传送域/PTN网元：数据库包，配置数据
  • 接入域网元：数据文件，配置文件
  • 路由器/交换机：启动配置文件，运行配置文件

不同类型网元，缺省值不同

各参数取值的含义如下。

参数选项

说明

启动配置文件

路由器/交换机的一种数据文件类型。该文件由保存在网元Flash中的数据生成。

运行配置文件

路由器/交换机的一种数据文件类型。该文件由网元内存中当前运行的数据生成。

数据文件

接入域网元的一种数据文件类型。文件格式为二进制。升级时，对于不支持内部数据库升级的网元，需要使用升级工具对网元数据进行升级。

配置数据
  • 接入域网元的一种数据文件类型。文件中可查看具体的命令。升级时，不需要对配置文件进行升级。但由于升级前的配置文件可能在新版本中不完全兼容，从而导致业务丢失，因此推荐使用数据文件进行升级。
  • 传送域/PTN网元的一种数据文件类型。备份文件类型与网元版本相关，只有较早版本的网元支持配置数据。
    • 保障在主控板+CF卡同时故障时，可以快速恢复配置数据。
    • 网元升/降级操作前做备份，保障在升/降级操作失败时可以迅速恢复到操作前的配置状态。

数据库包
传送域/PTN网元的一种数据文件类型。备份文件类型与网元版本相关，多数网元支持数据库包。
  • 保障在主控板+CF卡同时故障时，可以快速恢复配置数据。
  • 网元升/降级操作前做备份，保障在升/降级操作失败时可以迅速恢复到操作前的配置状态。
说明：
  • 对于传送域/PTN网元，网管下发配置命令，会在网元中生成配置数据，包括网元的单板配置、时钟配置、保护关系、通信等信息。因为配置数据在内存中，复位会丢失。为了网元复位或掉电后能重新生成配置数据，接下来配置数据会以另一种形式存储到数据库中形成网元数据库包，这样可以从数据库中读出重新生成配置数据。因此网元数据库和配置数据是网元上的同一内容，区别是格式不同。
  • 对传送域/PTN网元，备份文件类型与网元版本相关，即一个网元版本仅支持一种备份文件类型。例如：备份1600G网元数据，对于网元版本5.08.03.XX仅支持配置数据的备份，而对于网元版本5.08.04.XX及其以后版本，仅支持数据库包的备份。在备份时，若选择了不支持的文件类型，网管会给出报错提示。

取值原则

用户可根据需要选择备份哪种类型的文件。


文件名称

参数含义

设置待恢复的文件。

对系统的影响

不影响系统运行。

参数值

取值范围

缺省值

浏览，历次备份记录，空
  • 如果已经在网元软件管理上为网元做过数据备份，则缺省显示最后一次备份的记录。
  • 如果没有在网元软件管理上为网元做过数据备份，则缺省显示为空。
  • 特例：对于通过代理网元与网元软件管理通信的网元，需要从第三方服务器上选择备份文件进行配置恢复。此情况下，参数缺省值为空，需要手工输入此参数。

取值原则

  • “浏览”——当需要在本地计算机上选择备份文件时，选择此参数。
  • 历次备份记录——当需要将已备份到网元软件管理上的数据恢复到网元上时，可在下拉列表中选择一条备份记录，通常会选择最新一次的备份记录。
  • 手工输入此参数值时，需要注意以下几点：
    • 备份时，备份的数据会生成在一个以时间命名的文件夹里面，恢复路径输入到以时间命名的文件夹即可。例如“20101216111922\vrpcfg.cfg”。
    • 文件名称中必须包含扩展名。
    • 输入的内容不能超过64个字符。


板

参数含义

设置将备份数据恢复到网元主控板的位置。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
主板、备板、主备板 | 主板

取值原则

  • “主板”——当需要将备份数据恢复到主用主控板时，选择此参数。
  • “备板”——当需要将备份数据恢复到备用主控板时，选择此参数。
  • “主备板”——当需要将备份数据同时恢复到主用主控板和备用主控板时，选择此参数。


激活类型

参数含义

设置网元采用何种激活方式使备份数据在网元上正式生效。

对系统的影响

激活是重启网元的操作，会导致业务中断，请谨慎操作。

参数值

取值范围

缺省值
  • 传送域/PTN网元：不重启，中断业务
  • 接入域网元：不重启，断业务
  • 路由器/交换机：不重启，立即重启
不同网元支持的激活类型可能不同，请根据界面实际提供的选项进行选择。

不重启

各参数取值的含义如下。

参数选项 | 说明
不重启 | 备份数据加载到网元上后，不自动重启网元。手工重启网元后完成数据恢复。
（中）断业务，立即重启 | 备份数据加载到网元上后，自动重启网元。重启时中断业务，重启后完成数据恢复。

取值原则

  • “不重启”——当备份数据加载到网元后，不需要立即重启网元，而是需要在其他时间手工重启网元时，选择此参数。
  • “（中）断业务”/“立即重启”——需要在备份数据加载到网元后立即重启网元（重启时网元业务会中断），选择此参数。


下发配置到单板

参数含义

设置是否将备份的配置信息同时下发到各业务单板上。

对系统的影响

由于备份时主控板可能未同步到业务单板上最新的数据，将此备份数据下发到业务单板时，可能导致与业务单板当前运行的数据不一致。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

  • 使能——当需要备份的配置恢复到业务单板时，选择此参数。
  • 不使能——当不需要备份的配置恢复到业务单板上，仅对网元主控单板的配置信息进行恢复时，选择此参数。

与其他参数的关联关系

只有当“激活类型”设置为“中断业务”时，本参数才生效。


清除模式

参数含义

设置采用何种方式删除不需要的备份文件。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
手工，自动 | 手工

各参数取值的含义如下。

参数选项

说明

手工
  • 不限备份文件存储数目。
  • 可以通过删除备份文件中所述方式，手动删除备份文件。

自动

当备份文件的数目超过“最大保留份数”时，将自动删除较早的文件。

取值原则

  • “手工”——当需要手工删除不需要的备份文件时，选择此参数。
  • “自动”——当需要系统按预先设置的条件自动删除不需要的备份文件时，选择此参数。


最大保留份数

参数含义

设置保留备份文件数目的上限值。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
手动清除 1～200 | 5

取值原则

在取值范围内任意取值。建议使用缺省值。

与其他参数的关联关系

只有当“清除模式”设置为“自动”时，本参数才可设置。


激活类型

参数含义

设置网元采用何种激活方式使加载数据在网元上正式生效。

对系统的影响

激活是重启网元的操作，会导致业务中断，请谨慎操作。

参数值

取值范围 | 缺省值
中断业务 | 中断业务

各参数取值的含义如下。

参数选项 | 说明
中断业务 | 数据加载到网元上后，自动重启网元。重启时中断业务，重启后完成数据恢复。


依赖于

参数含义

显示当前补丁所依赖的补丁。（只有接入域网元的冷补丁可能存在补丁依赖关系）存在依赖关系的补丁之间，补丁号大的依赖于补丁号小的补丁。加载（补丁号）较大的补丁之前，必须先激活并确认（补丁号）较小的补丁，否则较大的补丁无法加载成功。删除补丁时，删除（补丁号）较小的补丁，依赖于它的补丁会同时被删除。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
- | -


被依赖

参数含义

显示当前补丁被哪些补丁依赖。（只有接入域网元的冷补丁可能存在补丁依赖关系）存在依赖关系的补丁之间，补丁号小的补丁被补丁号大的依赖。加载（补丁号）较大的补丁之前，必须先激活并确认（补丁号）较小的补丁，否则较大的补丁无法加载成功。删除补丁时，删除较小的（被依赖的）补丁，依赖于它的补丁会同时被删除。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
- | -


补丁状态

参数含义

显示补丁的当前状态。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
激活，去激活，待激活（接入冷补丁），卸载，运行，去运行，待运行（接入冷补丁），待删除（接入冷补丁） | -


最大的补丁

参数含义

设置过滤条件，使补丁视图中仅显示ID 最大的补丁。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能


最小的补丁

参数含义

设置过滤条件，使补丁视图中仅显示ID 最小的补丁。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能


结果

参数含义

设置按网元执行指定操作的操作结果过滤日志。可以仅过滤操作成功的日志，或者操作失败的日志。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
成功（使能，不使能），失败（使能，不使能） | 成功（使能），失败（使能）

取值原则

“成功”和“失败”可以同时使能，或者仅使能其中一项。但是这两个选项不能同时为不使能。


客户端IP地址

参数含义

显示对网元进行了指定操作的客户端的IP地址。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：10.78.220.192 | -


结果

参数含义

显示网元执行操作结果为成功或失败。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
成功，失败 | -


开始时间

参数含义

显示对应的操作开始执行的时间。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：20/10/2010 14:34:53 | -


结束时间

参数含义

显示对应的操作结束的时间。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：20/10/2010 14:34:59 | -


文件路径

参数含义

网元执行了备份、加载、恢复操作后，可以在日志中查看文件在网元软件管理上的保存路径。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：D:\backup\9-230\20100723113129 | -


状态

参数含义

显示网元软件的备份状态。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
正常态、拷贝态、正常态-撤销、挂起态 | -


日志类型

参数含义

显示备份日志的类型。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
操作日志，安全日志 | 安全日志

各参数取值的含义如下。

参数选项 | 说明
操作日志 | 操作日志中记录了所有网元用户对本网元进行的操作信息。
安全日志 | 安全日志中记录了所有网元用户对本网元进行的与网元安全相关的操作信息。

取值原则

  • “操作日志”——需要备份网元的操作日志时，选择此参数。
  • “安全日志”——需要备份网元的安全日志时，选择此参数。


协议

参数含义

设定采用何种协议进行备份操作。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
ECC、IP over DCC | ECC

各参数取值的含义如下。

参数选项 | 说明
ECC | ECC（Embedded Control Channel），即嵌入式控制通路，是ECC组网方式中网元之间使用的通信通道。网元ID是该组网方式下非网关网元的惟一标识，网元之间的通信数据通过ECC通道传输。
IP over DCC | IP over DCC遵循标准的TCP/IP协议，通过Internet控制远端网元。IP over DCC即为使用段开销中的D字节（缺省为D1～D3）进行通信。华为光网络设备支持动态和静态的路由功能。

取值原则

  • “ECC”——当网元间采用的是ECC 组网方式时，选择此参数。
  • “IP over DCC”——当网元间采用的是IP 组网方式时，选择此参数。
  • 如图1中，网元间采用了ECC 组网方式。当需要将NE3的数据备份到DC所在计算机时，NE3与GNE1之间采用ECC通道传输数据，GNE1与NMS Server之间采用TCP/IP协议通信。进行数据库备份时，NE3上的数据库文件先通过ECC通道传送到GNE1，再通过xFTP（FTP/SFTP）协议传送到DC所在计算机上并保存，其中，DC已配置并启动了xFTP服务。
    图1 选择ECC协议并访问DC示意图

  • 如图2所示，网元间采用了IP 组网方式。当需要将NE3的数据备份到DC所在计算机时，NE3与GNE1、GNE1与ToolKit Server之间均采用TCP/IP协议通信。进行数据库备份时，再通过xFTP（FTP/SFTP）协议传送到DC所在计算机上并保存，其中，DC已配置并启动了xFTP服务。
    图2 选择IP over DCC协议并访问DC示意图


文件

参数含义

显示网元日志备份的路径。

对系统的影响

如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。

参数值

取值范围 | 缺省值
例如：F:/backup | -

取值原则

文件路径中不能包含除英文和数字之外的字符，否则会导致读取文件失败。


状态

参数含义

显示License文件当前的加载状态。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
正常态、拷贝态、回滚态、正常态-撤销、挂起态 | -


备份/加载

参数含义

设置备份或加载License。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
备份、加载 | -

各参数取值的含义如下。

参数选项 | 说明
备份 | 对于使用License进行管理的网元，为防止网元发生故障时License丢失，需要对License进行备份。建议在网元更新License之后立即对License进行备份。
加载 | 网元上的License文件可能会因为网元发生故障等原因而丢失或不可用，这时就需要将先前备份的License文件恢复到网元上去。需要更新网元License文件时，也要使用加载网元License功能。

取值原则

“备份”——当需要将网元当前运行的License文件备份到网元软件管理时，选择此参数。

“加载”——当需要将已备份到网元软件管理上的License文件恢复到网元上，或将已上传到网元软件管理的新License文件上传到网元上时，选择此参数。


文件

参数含义

显示License文件保存的路径。

对系统的影响

如果被访问文件路径中包含除英文和数字之外的字符，可能会读取文件失败。

参数值

取值范围 | 缺省值
例如：F:/backup | -

取值原则

文件路径中不能包含除英文和数字之外的字符，否则会导致读取文件失败。


网关类型

参数含义

选择待创建的网元对应的网关网元与网元软件管理间采用何种通信协议。

对系统的影响

选择的网关类型与实际组网情况不相符时，会导致创建网元失败。

参数值

取值范围 | 缺省值
IP网关，OSI网关 | IP网关

取值原则

  • “IP网关”——当网元软件管理与网关网元间采用IP通信协议时，选择此参数。
  • “OSI网关”——当网元软件管理与网关网元间采用OSI通信协议时，选择此参数。

与其他参数的关联关系

  • 当选择了“IP网关”时，需要在“网关地址”中输入网关网元的IP地址。“端口”保持缺省值。
  • 当选择了“OSI网关”时，需要在“网关地址”中输入网关网元的NSAP地址。“端口”保持缺省值。
    说明：

    NSAP地址是最长为20字节的16进制数，其格式为：域地址+08003e+网元ID+NSEL。其中“域地址”最长13字节，由用户输入。“NSEL”是网络层协议的端口号，固定为1d，占1个字节。


文件类型

参数含义

选择待导入的网元文件的类型。支持选择CSV和Excel两种文件类型。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
Excel文件（*.xls），CSV文件（*.csv） | Excel文件（*.xls）

取值原则

  • “Excel文件（*.xls）”——当待导入的文件由“导出网元”操作获得时，选择此参数。
  • “CSV文件（*.csv）”——当待导入的文件由“导出网元模板”操作获得时，选择此参数。


文件名

参数含义

输入文件保存的名称。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
任意字符但不能为空 | 空

取值原则

参数取值不能为空，文件名（包括后缀名）的长度不能超过255个字符。


网关类型

参数含义

显示搜索到的网元对应的网关网元与网元软件管理间采用何种通信协议。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
IP网关，OSI网关 | IP网关


创建该网元

参数含义

配置完网关网元的信息后，设置是否在网元软件管理的“网元视图”中创建该网元。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 使能

取值原则

  • “使能”——当需要直接创建该网关网元到网元软件管理“网元视图”上时，选择此参数。
  • “不使能”——当需要继续搜索并创建该网关网元下的非网关网元时，选择此参数。设置完成后，该网关网元只会出现在“搜索网元”对话框中，不会被创建至“网元视图”。


按照时间

参数含义

设置场景的时间区间，导出包含这个区间所有操作场景的文件。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
使能，不使能 | 不使能

取值原则

  • “使能”——当需要仅需要导出某一时间区间的所有操作场景时，选择此参数。然后，通过微调框设置“开始时间”和“结束时间”。
  • “不使能”——当需要导出在网元软件管理上的所有操作场景时，选择此参数。


读团体名称

参数含义

显示/设置向网元发送读操作请求的团体名。只有与该网元认可的读团体名相同时，才能进行读操作。

对系统的影响

网元软件管理上配置的读团体名必须与网元侧一致，否则无法进行读操作。

参数值

取值范围 | 缺省值
例如：public | public

取值原则

字符串型，最大长度为64。


写团体名

参数含义

显示/设置向网元发送写操作请求的团体名。只有与该网元认可的写团体名相同时，才能进行写操作。

对系统的影响

网元软件管理上配置的写团体名必须与网元侧一致，否则无法进行写操作。

参数值

取值范围 | 缺省值
例如：private | private

取值原则

字符串型，最大长度为64。


代理类型

参数含义

显示/设置网元与网元软件管理间的连接方式。

对系统的影响

“代理类型”配置错误，会导致无法通过网元软件管理对网元进行操作。

参数值

取值范围 | 缺省值
直连，自动代理 | 直连

各参数取值的含义如下。

参数选项 | 说明
直连 | 网元软件管理直接连接到目标网元。
自动代理 | 网元软件管理连接不到目标网元A，而可以连接到另外一台网元B（B只能为“NSM-UNIX”、“Cisco”、“Telent.huawei.com”或“Huawei”类型网元）,并且，网元B也能连通目标网元A。则网元B即为自动代理网元。

取值原则

“直连”——当所创建的网元与网元软件管理所在的PC通过网线或者串口线直接相连，从PC上可以直接通过Telnet、SSH或串口方式连接上网元时，选择此参数。

“自动代理”——当所创建的网元是“NSM-UNIX”、“Cisco”、“Telent.huawei.com”或“Huawei”类型之一，用来使网元软件管理可以自动连上目标网元时，选择此参数。选择此参数的网元的子节点仍可以选择为“自动代理”（2级代理）。从1级代理网元开始，最多能创建6级代理网元，第7级网元必须为直连网元。


License状态

参数含义

显示网元license各种状态的解释。

对系统的影响

无

参数值

取值范围 | 缺省值
缺省状态，调测状态，正常状态，保护期状态，紧急状态 | 缺省状态

各参数取值的含义如下。

参数选项 | 说明
缺省状态 | 网元以License控制项的最小配置运行，已有的网元License功能可以正常使用，不允许新添加网元License功能。
调测状态 | 调测网元时申请的网元License，其状态为调测状态。在调测状态下，可以一定的时间内正常使用网元各项功能。但License过期后，将影响正常使用，请在License到期前申请商用License。
正常状态 | 在正常状态下可以正常使用网元License中包含的资源和功能。
保护期状态 | 在网元License已经过期情况下，为了预留时间申请新的License，License会在一段时间内处于保护期。此时网元License中的各个控制项仍然可以用。
紧急状态 | 在救灾等紧急状态下，网元License可以设为紧急状态。在紧急状态中，网元的License控制将被解除，容量取设备最大配置，从而保护网元业务不受损失。 说明： 当进入网元License紧急状态需要联系华为技术支持工程师进行操作。

取值原则

无


任务类型

参数含义

管理网元license过程中创建的任务所属的类型。

对系统的影响

无

参数值

取值范围 | 缺省值
加载License文件、同步网元信息、调整License容量、导出网元申请信息、失效License | -

各参数取值的含义如下。

参数选项 | 说明
加载License文件 | 执行加载License文件任务。
失效License | 执行失效License任务。
同步网元信息 | 执行同步网元信息任务。
调整License容量 | 执行调整License容量任务。
导出网元申请信息 | 执行导出网元申请信息任务。

取值原则

无


执行状态

参数含义

显示任务当前的状态。任务分为主任务和子任务。

对系统的影响

无

参数值

取值范围 | 缺省值
主任务的状态从0%到100%。 | -
子任务的状态包括：“正在执行”、“执行成功”、“执行超时”、“执行失败”、“上载中断”、“上载失败”、“轻微错误”、“重要错误”、“开始上载”、“正在上载和上载成功，正在激活”。 | -

各参数取值的含义如下。

参数选项 | 说明
0%到100%。 | 主任务完成的百分比。
子任务的状态包括：“正在执行”、“执行成功”、“执行超时”、“执行失败”、“上载中断”、“上载失败”、“轻微错误”、“重要错误”、“开始上载”、“正在上载和上载成功，正在激活”。 | -

取值原则

无


加载补丁

通过配置加载补丁选项，实现在任务中自动加载更新补丁。

前提条件

路径只能由字母、数字和下划线组成，不能包含中文、空格和特殊字符，如!@#$%^&*()- + = ./*[]{}等。

背景信息

如果在创建任务时已经选择了“目标版本”，可选择不进行本节所述配置操作。

操作步骤

  1. 在“选择操作步骤”对话框中，根据设备类型不同，单击“选择加载补丁”链接或“选择补丁”链接。
  2. 在对话框中，选择待加载的补丁文件。
  3. 对路由域网元，此操作前提：使用第三方FTP服务器进行升级，即勾选了“使用第三方服务器设置”复选框。
    1. 单击 [image] ，在“选择加载文件”区域框中，会增加一行。
    2. 双击“程序”字段，手工输入加载文件名称与路径。该路径为相对路径，例如：“\load”。路径中根目录默认使用第三方FTP服务器上设置的根目录。具体举例如下：第三方FTP服务器上设置根目录为“D：\”，加载文件相对路径为“\load”，待加载文件为“filename.pat”。在“选择加载文件”中应该输入“\load\filename.pat”。表明加载文件是位于第三方FTP服务器上“D：\load”路径下的“filename.pat”文件。若单击 [image] 可删除文件。
  4. 单击“确定”。
  5. 可选：如果需要任务在执行完加载软件后暂停，选中下一个配置选项后的“执行此步骤前停止”复选框。

    说明：

    任务暂停后，需要通过继续任务操作，使任务继续运行。

操作结果

配置加载软件完成，返回“选择操作步骤”对话框。


加载软件

操作含义

从指定路径中选择新软件，任务执行到加载操作步骤时，会将该软件自动加载到网元上。

按钮说明

按钮 | 按钮说明
选择文件 | 路由器/交换机进行升级/降级时，为任务中部分网元单独加载配置文件或GTL License文件。 路由器/交换机进行升级/降级时，使用第三方FTP服务器上软件进行升级/降级，需要手工输入加载文件名称与路径。
检测网元空间 | 对路由域网元升级/降级时，显示网元空间的检查结果。 对路由域网元升级/降级时，若使用了第三方FTP服务功能，不能手工检测网元空间。

各参数取值的含义如下。

参数选项 | 说明
路径 | 所需加载文件的存放位置。
文件类型/内容类型 | 界面左侧已经选择的文件的类型。不同网元类型，可以选择的文件类型不同。
网元文件 | 加载配置文件与GTL License文件时，需要选择文件路径与文件名称进行加载。


配置备份操作

操作含义

为防止任务执行过程中出现异常导致网元数据丢失，任务执行前需要先对网元数据进行备份。备份操作不是任务中必须进行的操作。如果创建任务前已对数据进行了手动备份或定时备份，可以对此配置选项进行去选。

对系统的影响

无

参数值

取值范围 | 缺省值
文件类型/内容类型 备份目的地 | -

各参数取值的含义如下。

参数选项 | 说明
文件类型/内容类型 | 网元类型不同，可选的内容可能不同。
备份目的地 | 网元类型不同，备份目的地可能不同。若使用第三方FTP服务器进行升级，网元上的文件备份到第三方FTP服务器上。

取值原则

无


前检测操作

操作含义

在执行任务前，对网元信息进行采集，例如：网元状态、告警等，以判断是否可以继续进行任务。而且前检测中采集的信息还可与后检测信息对比，以判断执行任务后，网元上是否丢失业务数据、配置信息等。

对系统的影响

无

参数值

取值范围 | 缺省值
检测项 | -

各参数取值的含义如下。

参数选项 | 说明
检测项 | 不同类型的网元需要配置的检测项可能不同。 对于支持配置“自定义检查项”的网元，可以通过输入命令行，自定义配置检测信息；或者导入自定义检测项模板，提高定制自定义检测项的效率。 连通性测试，即通过Ping或Tracert命令测试待升级网元与其他网元间的连通性。

取值原则

无


后检测操作

操作含义

配置升级后检测选项，升级完成后可以通过查看相应的网元检测信息，了解网元升级后的状态。

对系统的影响

无

参数值

取值范围 | 缺省值
检测项 | -

各参数取值的含义如下。

参数选项 | 说明
检测项 | 不同类型的网元需要配置的检测项可能不同。 对于支持配置“自定义检查项”的网元，可以通过输入命令行，自定义配置检测信息；或者导入自定义检测项模板，提高定制自定义检测项的效率。 连通性测试，即通过Ping或Tracert命令测试待升级网元与其他网元间的连通性。

取值原则

无


升级数据操作

操作含义

仅接入域设备支持该功能。

升级网元数据文件需要使用数据升级工具。配置升级数据后，网元软件管理会在任务执行过程中自动获取升级工具对网元数据库进行升级。

对系统的影响

无

参数值

取值范围 | 缺省值
文件路径 | -

各参数取值的含义如下。

参数选项 | 说明
文件路径 | 在服务器指定路径下选择升级工具 该步骤操作前提：已经将升级工具拷贝到服务器“ftpboot”文件夹下。

取值原则

无


升级后业务处理

操作含义

升级后，对网元上软件进行处理，确保升级成功。

对系统的影响

无

参数值

取值范围 | 缺省值
大包更新 激活GTL License 检查版本 | 操作项目随网元类型不同而改变。

各参数取值的含义如下。

参数选项 | 说明
大包更新 | 将大包文件从CF2卡拷贝到CF1卡上，并该大包文件设置为启动文件（CX600网元类型）。
激活GTL License | 激活网元上的GTL License文件。若在创建任务时加载了GTL License文件，才需要配置该项。
检查版本 | 检查网元升级情况，确保EPLD/MonitorBus的升级。

取值原则

无


启动配置类型

操作含义

设置网元重启时使用的软件文件类型。

对系统的影响

无

参数值

取值范围 | 缺省值
启动加载文件 手动启动网元文件 | -

各参数取值的含义如下。

参数选项 | 说明
启动加载文件 | 无需配置，单击“确定”。该方式下，网元重启时使用的软件文件，是“加载软件”中设置的，重启时使用的软件文件。
手动启动网元文件 | 在需要的网元上设置重启文件。该方式下，网元重启时使用的软件文件，是网元上已经存在的软件文件。

取值原则

无


升级准备

操作含义

在升级前需要对网元上软件进行处理、检查，以保证升级操作。

对系统的影响

无

参数值

取值范围 | 缺省值
删除补丁 启动配置 CRC检查 升级BootROM | 操作项目随网元类型不同而改变。

各参数取值的含义如下。

参数选项 | 说明
删除补丁 | 卸载网元上旧的补丁程序。
启动配置 | 设置网元重启时使用的软件文件。
CRC检查 | 检验网元软件文件的正确性与兼容性。
升级BootROM | 升级网元单板的BootRom。需要加载程序文件或配置下一次启动程序文件才能选择该项。

取值原则

无


使用第三方FTP服务器进行升级

操作含义

当网元与网元软件管理之间不能直接使用FTP协议通信，而网元可以与另一计算机使用FTP协议通信时，可以在网元软件管理上设置使用第三方FTP服务器，对网元进行加载或备份操作。此时网元软件管理与网元之间依然是连通的，只是不能直接使用FTP协议通信。

对系统的影响

无

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项 | 说明
使能 | 在任务中使用第三方FTP服务器。 在后续“加载软件”操作步骤中，需要手工填写文件路径以及名称。
不使能 | 在任务中不使用第三方FTP服务器。 在路由器/交换机升级/降级时，就可以选择“目标版本”，将软件文件导入到软件库中。只是在加载配置文件与GTL License文件时，需要选择文件路径与文件名称进行加载。

取值原则

无


按需加载

操作含义

网元将根据自身的单板类型，从软件包中获取其对应的软件。这样可以提高效率，有效减少用户操作。

只有支持该功能的网元才显示“按需加载”复选框。

对系统的影响

无

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项 | 说明
使能 | 网元根据当前的单板类型，自动在升级软件包中，获取与单板类型匹配的软件。 若网元不支持按需加载，将按普通方式加载。
不使能 | 按普通方式加载。

取值原则

无


文件类型

操作含义

设置待加载软件文件的类型。

对系统的影响

此参数的设置结果必须与实际加载的软件类型匹配，否则会导致文件加载失败或者加载的软件不可用。

参数值

取值范围 | 缺省值
不同系列的网元支持的文件类型可能不同。请根据具体网元配套的升级指导书中提供的文件列表进行选择。 | 举例如下：程序/软件映像/补丁。

取值原则

无


操作

操作含义

需要对网元上软件进行处理检查，以保证升级操作。用户根据实际需要，选择在任务中具体执行哪些操作。

对系统的影响

无

参数值

参数范围 | 缺省值
删除补丁 启动配置 CRC检查 升级BootROM | -

各参数取值的含义如下。

参数选项 | 说明
删除补丁 | 卸载网元上旧的补丁程序。
启动配置 | 设置网元重启时使用的软件文件。
CRC检查 | 检验网元软件文件的正确性与兼容性。
升级BootROM | 升级网元单板的BootRom。需要加载程序文件或配置下一次启动程序文件才能选择该项。

取值原则

无


操作

操作含义

升级后，对网元上软件进行处理，确保升级成功。这些操作项目随网元类型不同而改变。

对系统的影响

无

参数值

参数范围 | 缺省值
大包更新 激活GTL License 检查版本 更新补丁 | -

各参数取值的含义如下。

参数选项 | 说明
大包更新 | 将大包文件从CF2卡拷贝到CF1卡上，并该大包文件设置为启动文件（CX600网元类型）。
激活GTL License | 激活网元上的GTL License文件。若在创建任务时加载了GTL License文件，才需要配置该项。
检查版本 | 检查网元升级情况，确保EPLD/MonitorBus的升级。
更新补丁 | 更新补丁程序文件。路由器/交换机软件升级任务中也可以进行补丁升级。若创建任务时已经加载了补丁，才需要配置该项。

取值原则

  • 需要在任务中自动执行的操作，设置为使能。（对应操作前的复选框为选中状态）
  • 不需要在任务中执行的操作，设置为不使能。（对应操作前的复选框为去选状态）


备份

操作含义

CX600网元类型与ATN910、ATN950网元支持该功能。显示某一网元全部的备份文件信息。这些操作项目可能随网元类型不同而改变。

对系统的影响

无

参数值

参数范围 | 缺省值
文件类型 | -
备份目的地 | -

各参数取值的含义如下。

参数选项 | 说明
文件类型 | 选择需要备份的类型。
备份目的地 | 对于一些类型的网元，系统提供待备份文件的文件类型和备份目的地。 若使用第三方FTP服务器进行升级，网元上的文件备份到第三方FTP服务器上。

取值原则

-


前检测操作

操作含义

在进行补丁更新任务前，对网元信息进行采集，例如：网元状态、告警等，以判断是否可以继续进行任务。而且前检测中采集的信息还可与后检测信息对比，以判断执行任务后，网元上是否丢失业务数据、配置信息等。

对系统的影响

无

参数值

取值范围 | 缺省值
检测项 | -

各参数取值的含义如下。

参数选项 | 说明
检测项 | 不同类型的网元需要配置的检测项可能不同。 对于支持配置“自定义检查项”的网元，可以通过输入命令行，自定义配置检测信息；或者导入自定义检测项模板，提高定制自定义检测项的效率。 连通性测试，即通过Ping或Tracert命令测试待升级网元与其他网元间的连通性。

取值原则

无


后检测操作

操作含义

配置补丁更新任务后检测选项，任务完成后可以通过查看相应的网元检测信息，了解网元的状态。

对系统的影响

无

参数值

取值范围 | 缺省值
检测项 | -

各参数取值的含义如下。

参数选项 | 说明
检测项 | 不同类型的网元需要配置的检测项可能不同。 对于支持配置“自定义检查项”的网元，可以通过输入命令行，自定义配置检测信息；或者导入自定义检测项模板，提高定制自定义检测项的效率。 连通性测试，即通过Ping或Tracert命令测试待升级网元与其他网元间的连通性。

取值原则

无


离线模式

操作含义

任务创建过程中不连接网元，也不查询或校验网元信息。例如：查询包加载状态、包定制模式、按照路由获取激活分组等操作。

对系统的影响

无

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项 | 说明
使能 | 在单击 [image] 后，系统不会检测所选网元的软件包状态，右侧窗格会中显示已选网元，但不显示网元的软件包状态。 在创建任务过程中，进行到“获取缺省激活分组”步骤时，系统只是列出需要升级的网元，不会按由远及近的激活分组顺序显示。
不使能 | 在单击 [image] 后，系统自动检测所选网元的软件包状态，右侧窗格会中显示已选网元和网元的软件包状态。

取值原则

无


采用包定制

操作含义

仅将网元实际插入的单板所对应的软件加载到网元上，相较于加载完整软件包，效率会有所提升。

对系统的影响

无

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项

说明

使能
  • 启用包定制后，系统会自动选中各分组后的“组前暂停”复选框。
  • 如果所选网元不支持包定制技术，则该复选框不可选。

不使能

不使用该功能。

取值原则

无


前检测操作

操作含义

对网元的即时告警信息和健康状况信息进行检测，通过检测结果可以判断网元当前状态是否适合升级。此外，还可以通过检测结果判断网元在升级后是否丢失业务数据、配置信息等。

除告警和健康检测以外，还可以在任务中对网元进行自动扩展检测。由于网元的类型不同、源/目标版本不同，所需的检测项可能存在差异，因此扩展检测项需根据具体的待升级网元自行定制。使用网元软件管理对具体网元进行升级时，只需要在创建任务时导入自定义的检测脚本压缩文件（通常，该文件会随网元升级软件同时发布），即可实现自动检测。

对系统的影响

无

参数值

取值范围 | 缺省值
检测项 | -

各参数取值的含义如下。

参数选项 | 说明
检测项 | 不同类型的网元需要配置的检测项可能不同。 当已经在“选择操作步骤”对话框中选择了“目标版本”（即，通过软件库选择了目标版本软件），可选择在任务中对网元进行“扩展检测”。检测脚本压缩文件（格式为*.ZIP）。 通过查询任务执行报告可以了解升级前网元检测结果。

取值原则

无


后检测操作

操作含义

对网元的即时告警信息和健康状况信息进行检测，通过检测结果可以判断网元当前状态是否适合升级。此外，还可以通过检测结果判断网元在升级后是否丢失业务数据、配置信息等。

对系统的影响

无

参数值

取值范围 | 缺省值
检测项 | -

各参数取值的含义如下。

参数选项 | 说明
检测项 | 不同类型的网元需要配置的检测项可能不同。 通过查询任务执行报告可以了解升级前网元检测结果。

取值原则

无


备份

操作含义

为防止升级过程中出现异常导致网元数据丢失，升级前需要先对网元数据进行备份。

对系统的影响

无

参数值

取值范围 | 缺省值
内容类型 | -

各参数取值的含义如下。

参数选项 | 说明
内容类型 | 选择需要备份文件的类型，例如：数据库包。

取值原则

无


获取缺省激活分组

操作含义

当软件包中软件已分发至对应单板后，即可进行激活操作。升级软件必须进行激活后才能在网元中生效。激活前可以获取网元上缺省的激活分组，并根据情况进行调整，提高升级效率。

对系统的影响

激活网元存在中断业务的风险。

参数值

取值范围 | 缺省值
获取缺省激活分组 | -

各参数取值的含义如下。

参数选项

说明

获取缺省激活分组
  • 同组中的单板同时激活，不同组的单板按照组序由小到大依次激活。
  • 建议根据待升级网元上业务保护关系以及网络拓扑结构划分分组，确保分组内网元激活过程中，经过网元上业务的保护链路不发生中断。
  • 为避免网元激活过程中其他待激活的网元发生脱管，分组序号要根据网元路由由远及近的顺序作出调整。

取值原则

无


选择纤缆配置文件

操作含义

如果需要对默认激活分组进行优化，就可以使用该功能。

对系统的影响

激活有可能会中断业务。

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项 | 说明
使能 | 导入光纤配置文件后，光纤两端需要单独进行复位的单板可以同时复位，从而减少业务中断的时间。 光纤配置文件必须为“*.txt”格式的文本文件，可以通过网管导出。
不使能 | 不使用该功能。

取值原则

无


加载

操作含义

从指定路径中选择新软件后，网元软件管理会将待加载的软件与网元类型、单板类型进行校验，显示出结果。“加载”复选框决定了对单板是否进行加载。

对系统的影响

无

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项 | 说明
使能 | 若单板上原有软件版本与目标版本不同，网元软件管理需要对该单板进行升级。该单板后的“加载”复选框缺省选中。 若单板上原有软件版本与目标版本相同，网元软件管理不会加载对应的软件文件。单板后的“加载”复选框缺省不被选中。可手动调整是否对单板进行加载操作。
不使能 | -

取值原则

无


第三方FTP服务器

操作含义

当网元与网元软件管理之间不能直接使用FTP协议通信，而网元可以与另一计算机使用FTP协议通信时，可以在网元软件管理上设置使用第三方FTP服务器，对网元进行操作。当填写了第三方FTP服务器信息后，并在“第三方FTP服务器”下拉框中选中所需的第三方FTP服务器，在任务中进行加载、备份操作时才可以通过该第三方FTP服务器进行。

对系统的影响

无

参数值

取值范围 | 缺省值
使能 不使能 | -

各参数取值的含义如下。

参数选项

说明

使能
  • 选择“第三方FTP服务器”复选框后，可以在后面的下列表框中选择需要的条目。升级过程中的备份、加载操作将在网元与此处选择的第三方FTP服务器之间进行。
  • 在创建任务过程中，若设置了“用第三方FTP服务器上的软件升级”后，在后续“加载软件”操作步骤中，需要手工填写文件路径以及名称。
  • 在使用第三方FTP服务器情况下，网元软件管理与网元间的接口为Telnet命令行接口，不是SNMP接口。

不使能

-

取值原则

无


选择

含义

选择导入文件。

对系统的影响

无

参数值

取值范围 | 取值
文件名 文件类型 | -

取值原则

根据实际导入的文件显示对应参数。


导入网元类型描述文件

含义

选择网元类型描述文件进行导入。

对系统的影响

无

参数值

取值范围 | 取值
文件名 | -

取值原则

根据实际导入的文件显示对应参数。


文件名称

参数含义

显示脚本文件的名称和路径。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
任意字符但不能为空 | 空


接口协议

参数含义

使用终端工具登录网元，可以使用命令行对网元进行操作。设置登录网元使用的接口协议。

Telnet：TCP/IP协议堆栈中的标准终端仿真协议。

SSH（Secure Shell）：安全外壳协议，一套标准和网络协议，允许在本地计算机和远程计算机之间建立安全渠道。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
Telnet SSH | 空


网元license管理

参数含义

网元license管理包括了对网元license的查询、申请、安装、调整容量和变更。

对系统的影响

不影响系统运行。

参数值

按钮 | 缺省值
查询license信息 网元license维护 | 空


网元版本

参数含义

显示所选网元当前的软件版本。可通过“获取版本”操作获取或者刷新此参数的显示结果。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
例如：V800R007C01 | -


SNMP模板名

参数含义

对于使用SNMP协议与网元软件管理通信的网元，需要在网元软件管理侧配置与待操作网元对应相同的SNMP参数。显示SNMP模板名称。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
SNMP协议版本+模板名称 | SNMPv1：default


资源名称

参数含义

显示网元的名称、IP或单板等相关信息。

对系统的影响

不影响系统运行。


网元IP/LAN/网关IP

参数含义

  • 网元IP：网元的IP地址。
  • LAN：网元在OSI（Open Systems Interconnection）组网下网元所在的网络地址。
  • 网关IP：网关的IP地址。

对系统的影响

不影响系统运行。


网元类型

参数含义

显示网元的类型。

对系统的影响

不影响系统运行。


网元版本

参数含义

显示网元的软件版本。

对系统的影响

不影响系统运行。


升级状态

参数含义

显示单板的升级状态。

对系统的影响

不影响系统运行。


物理拓扑树

参数含义

根据子网和网元类型浏览网元列表。

对系统的影响

不影响系统运行。

参数值

取值范围 | 缺省值
子网及网元视图、网元视图 | 子网及网元视图

各参数取值的含义如下。

参数选项 | 说明
子网及网元视图 | 真实反映设备在Topo界面上属于哪个子网，复制网元情形除外。 如果Topo界面上存在被复制到其他子网中的网元，当按子网及网元视图浏览时，只显示一条网元记录。
网元视图 | 根据网元类型以及网元类型中的不同版本来浏览设备列表。

取值原则

  • “子网及网元视图”——当需要根据子图来浏览网元时，选择此参数。
  • “网元视图”——当需要根据设备类型和版本号来浏览网元时，选择此参数。


FTP连接失败

错误描述

备份网元数据或测试FTP连接等情况，可能出现“FTP连接失败”。

可能原因

FTP服务未启动或配置不正确。

处理建议

参考“配置文件传输服务”配置FTP，确保FTP服务正常启动。


SFTP连接失败

错误描述

备份网元数据到客户端或测试FTP时，DC上报“SFTP连接失败。”

可能原因

SFTP服务未启动或配置不正确。

处理建议

  1. 参考“配置文件传输服务”配置和启动SFTP。
  2. 若SFTP服务无法配置正常，可使用FTP完成客户端与服务器端的文件传输。


登录网元失败

错误描述

在DC上对网元操作时提示:登录网元失败。

可能原因

  • 网络连接不通。
  • 网元上已经删除DC登录的用户。
  • DC在给网元下发命令时，网元正在进行其他操作（如，主备倒换或批量备份等），无法及时响应DC命令。

处理建议

  1. 检查网元与DC间的网络连接。

    在安装DC工具的计算机上Ping网元的IP地址：
    • 如果Ping不通，说明网元与DC间网络连接不通，则需要到现场通过串口对网元进行操作。
    • 如果能Ping通，执行步骤2。

  2. 修改登录网元的用户信息，具体操作请参见联机帮助“修改网元参数”。

    修改时，需确保该用户信息有效，即能够正常登录网元，并具有网元的操作权限。修改用户信息后，重试当前操作，如果仍然失败，请执行步骤3。

  3. 检查网元上是否正在进行其他操作，待这些操作完成后，重试当前操作。

    如果重试几次后仍失败，请执行步骤4。

  4. 联系华为技术支援工程师。


没有配置网管服务器IP地址

错误描述

创建模拟包任务，上报：“没有配置网管服务器IP地址”。

可能原因

没有配置服务器IP。

处理建议

  1. 在主菜单中，选择“工具 > FTP设置”。单击“系统信息”页签。
  2. 配置网管服务器IP地址。


该网元没有升级到目标版本

错误描述

升级软件过程中，依次进行软件加载、激活。操作结果如图1所示。

图1 激活软件失败

可能原因

版本名称前没有加上网元形态。

处理建议

在产品版本名称前加上网元形态。例如“S3328V100R005C01”，其中“S3328”为网元形态。如下图：


文件传送失败

错误描述

开始升级任务后，网元的升级状态显示“文件传送失败”。

可能原因

被升级网元的文件传输协议配置错误：被升级网元的文件传输协议采用缺省值，与“网元与网管服务器间”实际的文件传输协议不一致。

处理建议

说明：
在DC上的文件传输协议（网元与网管服务器间）应与实际使用的传输协议一致，否则将导致文件传送失败。
  1. 在主菜单中，选择“工具 > FTP设置”。单击“传输协议”页签。
  2. 检查“客户端与服务器的文件传输协议”与网管服务器设置的文件传输服务协议是否一致。

    若不一致，应修改一致。

  3. 单击“文件传输服务设置”页签，单击“测试xFTP”，测试选定的FTP连接是否正常。


源地址错误

错误描述

使用FTP加载网关网元时，上报“源地址错误”，如图所示。

可能原因

包路径的长度超过59个字符，网元限制了FTP加载时：相对路径最长只能有59个字符。

处理建议

  1. 选择上报失败的任务，单击右键，选择“查看任务”。
  2. 选择“软件加载”页签，选择文件路径，查看文件长度是不是超过了59个字符。

  3. 将要加载的包文件copy到一个路径小于59字符的位置，然后重新创建任务。


传送网元操作失败

错误描述

对传送网元进行操作，提示失败。

可能原因

通过网元软件管理对传送域网元操作前，需要先检查是否在网管中设置了网元软件管理的登录网元用户以及登录网元使用的连接协议，否则不能正常操作。

处理建议

  1. 主菜单中选择“系统 > 网元安全 > 网元登录管理”。单击“DC登录用户管理”页签。
  2. 网元列表中选择需要的网元，单击“切换网元用户”。
  3. 在弹出的对话框中，设置网元软件管理的登录“用户”和“密码”。
  4. 可选：设置“连接协议”。
    说明：
    • 对不支持该功能的网元，“连接协议”显示为“-”。
    • 如果使用STelnet协议，需先配置网元为SSH终端。


同步主备机的网元软件数据文件

错误描述

主备机倒换后未进行手工同步，服务器中缺少部分网元软件文件。

可能原因

主备机倒换后未进行手工同步。

处理建议

  1. 使用ossuser用户登录备机操作系统，启动系统监控客户端，执行如下操作，默认网管安装目录为“/opt/oss”。
    $ cd /opt/oss/client
$ ./startup_sysmonitor_global.sh
    弹出“用户登录”对话框，输入用户名和密码，进入系统监控客户端。
  2. 停止网元软件管理服务进程，执行如下操作：
    1. 在系统监控客户端单击“进程名”列排序，找到“DCServer”进程。
    2. 右键单击“DCServer”进程，左键单击“停止进程”。
    3. 在弹出的确认对话框中，单击“是”。
    4. 等待状态由“运行”变为“停止”。
  3. 通过FileZilla使用sftp传输方式，拷贝主用站点上的网元软件数据文件到备用站点。网元软件数据文件的路径为：“FTP主目录+ ftproot/dc/load”，如果FTP主目录为“/opt/backup/ftpboot”时，则网元软件数据文件的路径为：“/opt/backup/ftpboot/ftproot/dc/load”。如果有同名文件，覆盖。
    说明：
    • 通过FileZilla使用sftp传输方式的具体操作可以参考“U2000调测指南”的“如何通过FileZilla使用sftp传输文件”章节。
    • FTP主目录的查看方法：在主菜单中选择“系统 > 设置 > 本地xFTP设置”（传统风格）或在“应用中心”中选择“系统管理”，再选择“设置 > xFTP设置 > 本地xFTP设置”（应用风格）。

  4. 以root用户登录备用站点操作系统，执行如下命令修改load目录的属组：
    # cd /opt/backup/ftpboot/ftproot/dc/load
# chown -R ftpuser:ossgroup /opt/backup/ftpboot/ftproot/dc/load
# chmod -R 775 /opt/backup/ftpboot/ftproot/dc/load
  5. 使用ossuser用户登录备机操作系统，在备用站点上启动“DCServer”进程。
    1. 在系统监控客户端单击“进程名”列排序，找到“DCServer”进程。
    2. 右键单击“DCServer”进程，左键单击“启动进程”。
    3. 等待状态由“停止”变为“运行”。


收集DC信息

  1. 记录详细的DC版本号。
    • client版本：\client\style\productstyle\conf\about\DC_package.xml文件中。
    • server版本：\server\conf\about\ dcver.cfg文件中
  2. 完整的操作过程、截图和网元软件。截图必须是全图，最好要选中出错的网元或单板，那样对定位很有帮助，开发才知道什么时间点报错或失败的。如果不便于附上网元软件，至少附上网元软件详细的版本信息，以便开发人员到support网站上去获取。
  3. 拷贝DC后台日志。
    注意：
    日志生成的时间要正确，每天都不同，出错的那天的日志最好全部取。
    1. \server\log\

      DC_Server_Log_Info.log0、iMAPMdp_p2_*.log、base_p148_*.log、base_p148_Comm_*.log

    2. \server\log\tklog\

      *nemsg*.log、Clientmsg*.log、Debug*.log

  4. 拷贝DC前台日志。


激活数据库

对网元数据库进行恢复后，必须进行激活操作使数据生效。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

  • 仅传送域/PTN网元支持该功能。
  • 恢复网元数据后需要进行激活网元数据库操作。恢复网元数据操作请参见恢复网元数据。
    注意：

    激活数据库会中断业务，请慎重操作。

    恢复网元数据后必须在5分钟内进行激活数据库操作，否则会自动回滚。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择待操作的网元，单击右键，选择“数据库高级操作 > 激活数据库”。

  3. 在“激活类型”下拉列表中，选择需要的激活方式。

    说明：
    此处选择激活类型，但是不会执行激活操作。当前仅支持“重启”。

  4. 可选：选中“下发配置到单板”复选框。

    说明：
    • 只有部分类型网元支持此项设置，对不支持“下发配置到单板”功能的网元，请去选此项设置。
    • 进行此设置后，配置信息下发到主控板的同时会下发到其他单板。

  5. 单击“开始”。

操作结果

网元视图中显示操作进度，操作完成后，显示操作结果成功或失败。


删除数据库

当升级/降级前后数据库版本不兼容时，激活前，需要先删除数据库。

前提条件

  • 网元软件管理所在计算机与网元间通讯正常。

背景信息

仅传送域/PTN网元支持该功能。

注意：

删除数据库会中断业务，请慎重操作。

操作步骤

  1. 在主菜单中，选择“网元软件管理 > 网元数据备份/恢复”。
  2. 选择一个或多个同类型网元，单击右键，选择“数据库高级操作 > 删除数据库”。
  3. 单击“确定”。

操作结果

网元视图中显示操作进度，操作完成后，显示操作结果成功或失败。


FTP服务器配置

通过本节所述功能可以将服务器上指定目录设置为FTP服务器目录。无需另采用第三方FTP工具配置FTP服务器。

背景信息

设置FTP参数成功后，将重启FTP Server,以前设置的FTP Server也会被停止。因此，在设置FTP参数之前，请确认网元软件管理未使用FTP传送功能。

操作步骤

  1. 在主菜单中，选择“工具 > FTP服务器配置”。
  2. 在弹出对话框中，设置FTP参数，单击“启动”。

    说明：

    此处设置的“主目录”需要与“文件传输服务设置”的根目录保持一致。“文件传输服务设置”的入口和设置方法可参见配置传输协议。

    如需要停止FTP Server，则单击“停止”，但是不能停止正在使用的FTP Server。

  3. 在弹出的提示对话框中单击“确定”。